• No audio


    ls -ld /home/*
    

    SHOULD LOOK LIKE THIS:

    drwx--x---+ 55 yourusername users 12288 29. Apr 23:51 /home/yourusername
    drwx------   2 root       root  16384 25. Mär 2018  /home/lost+found
    
    
  • @joekamprad Mine looks like this on both computers. But i did have a test folder in Home which was from a previous temporary user account. I deleted it. I assume this is why you have the lost+found folder also from something previous.

    drwx------ 23 rick users 4096 Apr 30 09:38 /home/rick
  • Sorry. I was very busy for the past few days and didn’t get a chance to mess with my machine. I’m also incredibly lost as to what I should be doing with my computer. Can someone explain what was going on with the permissions and why pulseaudio wasn’t working?

  • @mattwong It doesn’t have access to it because home has the wrong permissions. Should be this.

    [[email protected] ~]$ ls -ld /home/*
    drwx------ 24 rick users 4096 May  5 23:26 /home/rick
    [[email protected] ~]$ 
    
    

    So as @joekamprad has suggested change your home permissions.

    sudo chown -R yourusername /home/yourusername
    
    

    Replace yourusername to fit your username ;)…

  • @ricklinux

    I’ve done that. What’s the next step?

  • reboot… may the force is with you.🖖🏻

  • @joekamprad I’ve rebooted. There’s still no audio available, and unmuting doesn’t do anything.

  • Does it still say it’s not accessible? Maybe now that you fixed the home permissions go back to the mixer and try changing devices. Check pavucontrol. One of them has to be working. Use f6 to select the sound card. That’s all i can suggest now.

  • @mattwong may it would be more easy to do a new clean install, as your home will not be changed owner on its own, there must be something happens/tinkering before causing this…

  • @mattwong :

    ls -ld /home/*
    /usr/bin/systemctl --user status pulseaudio.service
    
  • Output:

    [[email protected] mysql-workbench-git]$ ls -ld /home/*
    drwxrwxrwx 1 root root  4096 May 10 15:16 /home/data
    drwxrwxrwx 1 root root 12288 May 13 17:50 /home/mattwong
    [[email protected] mysql-workbench-git]$ /usr/bin/systemctl --user status pulseaudio.service
    ● pulseaudio.service - Sound Service
       Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: ena>
       Active: failed (Result: exit-code) since Fri 2019-05-10 21:00:02 EDT; 3 days ago
      Process: 837 ExecStart=/usr/bin/pulseaudio --daemonize=no (code=exited, status=1/FAILUR>
     Main PID: 837 (code=exited, status=1/FAILURE)
    
    May 10 21:00:02 Apple systemd[564]: pulseaudio.service: Service RestartSec=100ms expired,>
    May 10 21:00:02 Apple systemd[564]: pulseaudio.service: Scheduled restart job, restart co>
    May 10 21:00:02 Apple systemd[564]: Stopped Sound Service.
    May 10 21:00:02 Apple systemd[564]: pulseaudio.service: Start request repeated too quickl>
    May 10 21:00:02 Apple systemd[564]: pulseaudio.service: Failed with result 'exit-code'.
    May 10 21:00:02 Apple systemd[564]: Failed to start Sound Service.
    
  • @mattwong said in No audio:

    drwxrwxrwx 1 root root 12288 May 13 17:50 /home/mattwong

    you do not change the owner of your home directory… so same as before pulseaudio is running as normal user and it needs access to write to your home directory.

    su
    chown -R mattwong /home/mattwong
    
    
  • @joekamprad I think the issue is that chown isn’t working as it should be.

    [[email protected] root]$ ls -ld /home/*
    drwxrwxrwx 1 root root  4096 May 10 15:16 /home/data
    drwxrwxrwx 1 root root 12288 May 14 04:15 /home/mattwong
    [[email protected] root]$ su
    Password: 
    [[email protected] ~]# chown -R mattwong /home/mattwong
    [[email protected] ~]# su mattwong
    [[email protected] root]$ ls -ld /home/*
    drwxrwxrwx 1 root root  4096 May 10 15:16 /home/data
    drwxrwxrwx 1 root root 12288 May 14 04:15 /home/mattwong
    
  • su
    chown -R mattwong:users /home/mattwong
    

    may work?
    group is also wrong…

  • @mattwong
    What does this show (as both normal user and root)?

    type chown
    
  • @mattwong
    Oh, the permissions are drwxrwxrwx which is very strange.
    So what do commands

    df -hT
    grep home /etc/fstab
    

    show?

  • @manuel said in No audio:

    the permissions are drwxrwxrwx which is very strange

    that’s true also, as i say before there must be something happen before what is may the real culprit.

  • I guess it is a mounted home partition, but maybe not correctly.

  • @manuel yes this would show exactly
    drwxrwxrwx user=root group=root
    If you use bind inside fstab for example…

audio50 Posts 80Views 388
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.