• No audio


    Wondering what I should do with the following information if I wanted to finally get audio working on this machine.

    In the system settings, I’m getting the message that there are no audio output devices detected. However, when I look into alsamixer, I see that there are two devices, one of which has actual volume settings but is not set as the default.

  • @mattwong Click on speaker and go into sound settings Ouput…click on line out and test sound & ckeck volume level. See if there is anything here first.

  • @ricklinux Where is that?

  • @mattwong The speaker Icon …mine is on the task bar but i use Cinnamon desktop so could be different or not there.

  • I use KDE. What do you mean by line out, test sound, and check volume level?

  • @mattwong Yes it has a test there…shows speakers.

  • @mattwong Did you check alsamixer from terminal?

    Screenshot from 2019-04-22 21-16-31.png

    Screenshot from 2019-04-22 21-16-39.png

  • @ricklinux lspci | grep -i audio

  • e3d60c49-a7c2-466f-b3df-e9b477afcad6-image.png
    17eebb0a-3373-43d0-bf3e-b5cd0fca2f98-image.png
    7540d2b3-08ac-46a1-9d79-9a34a92b89bd-image.png

    This is what I have for those things

  • @mattwong Auto mute mode is enabled by the looks of it.

    Press right arrow to get to “auto-mute mode”, then up or down arrow to change it, then Escape to exit.

  • @mattwong Also try F6 to select the correct sound device.

  • @mattwong Try open pavucontrol from terminal and set output device.

  • I selected the Realtek, disabled the auto-mute, and tried opening pavucontrol.

    pavucontrol is always stuck establishing a connection to pulseaudio, and every time I reboot, the auto-mute is enabled again.

  • @mattwong Maybe @joekamprad can advise more as he wrote the book on this. ☺

  • @ricklinux

    now on Amazon!

    joekamprad: on audio at linux

  • @mattwong said in No audio:

    pavucontrol is always stuck establishing a connection to pulseaudio

    That’s where the problem is buried ?

    try to remove the pulsesettings and reboot for a first try:

    rm -R ~/.config/pulse
    

    Pulseaudio is mostly working together with alsa but in most cases do not need a setup for alsa (using automatic defaults) [ Alsa is used as a Back-end only]
    So seting up sound should work with pulseaudio tools like pavucontrol:
    Bildschirmfoto vom 2019-04-23 22-40-16.png
    in some cases you will need to disable one device to get the other one unmuted…
    I got this if i want to run Bluetooth headset, where i need to put hdmi audio device to OFF, but if i remember right it is also possible to enable simultaneous output with paprefs to get all devices working together:
    Bildschirmfoto vom 2019-04-23 22-45-11.png

    To get a deeper info on devices from pulseaudio:

    pactl list sinks
    
  • @joekamprad Thanks for the reply! I tried removing the configs, rebooting, then running pavucontrol, but it still gives me the same problem. I’ve also tried the procedure without rebooting without any luck. I think it is a part of the problem, but pactl list sinks is returning a failed connection error.

  • @joekamprad This is funny! 😃

  • @mattwong i can have a deeper look later this day.
    Can you provide info on hardware and boot?

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io
    

    Simple run in terminal an paste the url/link it gives out

audio50 Posts 79Views 307
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.