• Dual Boot Windows 10 not detected


    I have here a rather new computer with a 250 GB SSD as start medium. The dealer has installed a current Windows 10 Professional 64 Bit system there on my request. At my request, the dealer configured everything in GPT/UEFI mode so that I could then install Linux in the free, i.e. not yet partitioned part of the SSD.

    I created a bootable Antergos Live Stick with Rufus from Windows and - after some problems and good advice here in the forum - was able to install my Antergos as a new partition (sda5) in the unpartitioned area of the SSD. During the installation, however, the boot partition (sda2), which apparently controls the boot conditions of the operating systems, also had to be changed. Of course, I made sure that this existing sda2 was not formatted. Result:

    Antergos now runs fine, but the Windows system is no longer recognized. So I can’t run Windows anymore. Maybe I have to set up my quite new computer completely new, first Windows 10, then a special boot manager, then Antergos? But maybe there is also a solution to make Windows run again without a complete rebuild?

    Translated with www.DeepL.com/Translator

  • @mr-ed Is it possible for you to show the output of the following commands. Run each separate in the terminal.

    This command allows you to view the default boot entry (BootCurrent), boot order and all boot entries. Each boot entry is identified by a boot number in hexadecimal. The asterisk (*) means the boot entry is active.

    efibootmgr

    You can also add -v option to show verbose information.

    efibootmgr -v

  • @ricklinux said in Dual Boot Windows 10 not detected:

    efibootmgr

    [[email protected] ~]$ efibootmgr
    BootCurrent: 0000
    Timeout: 1 seconds
    BootOrder: 0000,0006,0001,0002
    Boot0000* antergos_grub
    Boot0001* Hard Drive
    Boot0002* CD/DVD Drive
    Boot0006* Windows Boot Manager
    [[email protected]]$
    
  • @ricklinux said in Dual Boot Windows 10 not detected:

    efibootmgr -v

    [[email protected] ~]$ efibootmgr -v
    BootCurrent: 0000
    Timeout: 1 seconds
    BootOrder: 0000,0006,0001,0002
    Boot0000* antergos_grub	HD(2,GPT,843fc719-de91-44de-9f06-7aa279794d59,0xfa000,0x31800)/File(\EFI\ANTERGOS_GRUB\GRUBX64.EFI)
    Boot0001* Hard Drive	BBS(HD,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0200)..GO..NO..........S.a.m.s.u.n.g. .S.S.D. .8.6.0. .E.V.O. .2.5.0.G.B...................\.,[email protected]=.X..........A...........................>..Gd-.;.A..MQ..L.3.S.J.Y.C.N.K.0.1.9.4.9.7.0. .J. . . . ........BO..NO..........S.T.2.0.0.0.D.M.0.0.8.-.2.F.R.1.0.2...................\.,[email protected]=.X..........A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .F.W.0.L.C.H.E.B........BO
    Boot0002* CD/DVD Drive	BBS(CDROM,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0300)..GO..NO..........H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.H.2.4.N.S.D.1...................\.,[email protected]=.X..........A...........................>..Gd-.;.A..MQ..L.1.K.G.B.A.C.5.I.5.4. .7. . . . . . . . ........BO
    Boot0006* Windows Boot Manager	HD(2,GPT,843fc719-de91-44de-9f06-7aa279794d59,0xfa000,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO
    [[email protected]]$
    
  • @mr-ed Boot 0000 is your Antergos grub boot loader and it is set to boot first. The problem is that the grub boot loader doesn’t have Windows loaded to it because the os-prober can’t mount the EFI partition to get the path. Boot 0006 is your Windows boot loader. Both of these boot files reside inside the EFI partition separately but the grub boot loader doesn’t have the path to the Windows boot loader added to it. So it’s easy here to change the boot order to get it to boot Windows but getting back to Antergos then is a complex process of booting the live ISO and going through a bunch of stuff. I’m just not sure what the best solution is and i would like @joekamprad and or @manuel to advise. So far you have perfectly intact Windows partitions so you don’t want to mess that up or this whole thing is going to end up with a total re-install. Antergos is on a separate / partition so for now you are safe as long as you don’t mess it up.

    As i stated in the previous post the problem is os-prober can’t mount the EFI partition to get to the path and add it to the grub bootloader for what ever reason which i think is because of Windows 10 fast boot or hiberfile.

  • @ricklinux said in Dual Boot Windows 10 not detected:

    So far you have perfectly intact Windows partitions so you don’t want to mess that up or this whole thing is going to end up with a total re-install.

    I won’t change anything!

  • @mr-ed The Antergos Grub boot files reside in the EFI partition in a the folder (\EFI\ANTERGOS_GRUB\GRUBX64.EFI)

    Normally this is the grub bootloader that you would be using and the one that comes up when booting Antergos. Problem is it doesn’t have the Windows added to it.

    The other one is the Windows boot loader from when you had Windows 10 installed. It will only boot Windows. It resides in the EFI partition in the folder (\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)

    I hope this makes sense to you.

  • @mr-ed I think it would be a good idea since this is a new post to also post the picture of gparted to show your partition scheme again.

    Also maybe run:

    lsblk -l

    lsblk -fm

    sudo fdisk -l

  • @ricklinux said in Dual Boot Windows 10 not detected:

    I hope this makes sense to you.

    Yes, I understand that. Apparently my Windows 10 bootloader is still okay. But I’m not going to play around to make a difference. In my MSI BIOS I have also tried to change the BOOT order. “Fast boot” is disabled. I don’t need it, the BOOT process is fast enough even without it. Change the BOOT order without success. The SSD hard disk with the Windows boot loader was not accepted.

  • @ricklinux said in Dual Boot Windows 10 not detected:

    Also maybe run:

    I’ll try.

  • [[email protected]]$ lsblk -l
    NAME MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda    8:0    0 232,9G  0 disk 
    sda1   8:1    0   499M  0 part 
    sda2   8:2    0    99M  0 part /boot/efi
    sda3   8:3    0    16M  0 part 
    sda4   8:4    0   132G  0 part 
    sda5   8:5    0 100,3G  0 part /
    sdb    8:16   0   1,8T  0 disk 
    sdb1   8:17   0    16M  0 part 
    sdb2   8:18   0 882,3G  0 part /run/media/ich/Erst mal
    sr0   11:0    1  1024M  0 rom  
    [[email protected]]$
    
  • [[email protected]]$ lsblk -fm
    NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT   SIZE OWNER GROUP MODE
    sda                                                                              232,9G             brw-rw----
    ├─sda1
    │    ntfs   Wiederherstellung
    │                 8878555E78554C56                                                 499M             brw-rw----
    ├─sda2
    │    vfat         CA1A-04D7                              97,1M     0% /boot/efi     99M             brw-rw----
    ├─sda3
    │                                                                                   16M             brw-rw----
    ├─sda4
    │    ntfs         E0F85655F8562A54                                                 132G             brw-rw----
    └─sda5
         ext4         8ce55ea6-b360-4f60-814f-8572b59742ee   91,1G     6% /          100,3G             brw-rw----
    sdb                                                                                1,8T             brw-rw----
    ├─sdb1
    │                                                                                   16M             brw-rw----
    └─sdb2
         ntfs   Erst mal
                      3260C30C60C2D5AF                      209,7G    76% /run/media 882,3G             brw-rw----
    sr0                                                                               1024M             brw-rw----
    [[email protected]]$
    
  • @mr-ed There is a way of doing this by changing the boot order to boot Windows using efibootmgr in Antergos. Then make sure Windows fast boot and hiberfile are turned off. Then i would install Easy UEFI in Windows which would allow you to change the boot order back to Antergos Grub and reboot into Antergos and then fix the Grub boot loader to add Windows to it. This would only work if the problem is in fact Windows 10 fast boot and Hiberfile that are causing the problem with
    os-prober not being able to access the EFI partition. I am going to let @joekamprad and possibly @manuel come up with some other Linux based options as they have way more experience with Linux commands and utilities than i do. We need to figure out why os-prober can’t access and allow the commands to update grub bootloader.

  • [[email protected]]$ sudo fdisk -l
    [sudo] Passwort für ich: 
    Festplatte /dev/sda: 232,9 GiB, 250059350016 Bytes, 488397168 Sektoren
    Festplattenmodell: Samsung SSD 860 
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
    E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
    Festplattenbezeichnungstyp: gpt
    Festplattenbezeichner: 7D9840AD-9AE0-46B1-9558-4E2966C036F6
    
    Gerät         Anfang      Ende  Sektoren  Größe Typ
    /dev/sda1       2048   1023999   1021952   499M Windows-Wiederherstellungsumgebung
    /dev/sda2    1024000   1226751    202752    99M EFI-System
    /dev/sda3    1226752   1259519     32768    16M Microsoft reserviert
    /dev/sda4    1259520 278085631 276826112   132G Microsoft Basisdaten
    /dev/sda5  278085632 488397134 210311503 100,3G Linux-Dateisystem
    
    
    Festplatte /dev/sdb: 1,8 TiB, 2000398934016 Bytes, 3907029168 Sektoren
    Festplattenmodell: ST2000DM008-2FR1
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
    E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
    Festplattenbezeichnungstyp: gpt
    Festplattenbezeichner: CAA04170-3A24-4653-8A0C-9E874DBBDC45
    
    Gerät      Anfang       Ende   Sektoren  Größe Typ
    /dev/sdb1      34      32767      32734    16M Microsoft reserviert
    /dev/sdb2   32768 1850413055 1850380288 882,3G Microsoft Basisdaten
    
    Partition 1 beginnt nicht an einer physikalischen Sektorgrenze.
    
    
    [[email protected]]$
    
  • @mr-ed Perfect now there is enough information for them to see your set up.

  • @mr-ed By the way. Which desktop version of Antergos did you install?

  • The Antergos default system: Gnome.

  • @mr-ed I use the Cinnamon desktop. My system i built and is similar hardware like yours. I have installed Antergos many, many many times on my own computers and others. My set up is a little different.

    I have Windows 10 installed on an 480 GB fast m.2 pcie-e drive and my Antergos install is on a fast separate SSD drive. I also have a 4 TB Hard Drive. So on my setup i have an EFI partition on both drives but it basically does the same function. The Grub bootloader files are installed on the EFI partition on the SSD drive with Antergos Linux and boots both windows and Antergos. The m.2 drive has an EFI partition with the Windows boot loader files on it. So the Grub bootloader just provides the path to the Windows boot loader files on the EFI partition on the m.2 drive.

    Hopefully that makes sense to you.

  • @mr-ed
    Hello again!
    Great that you have Antergos now installed.

    What @ricklinux suspected, the problem now may be the hibernate at Windows. I’m not that familiar with Windows hibernate, so I don’t know how you could remove that now that you cannot boot to Windows.

    But anyway, you could try one thing in order to boot Windows.
    Write the following lines to file /boot/grub/custom.cfg:

    menuentry "Windows 10" {
      savedefault
      set file=/EFI/Microsoft/Boot/bootmgfw.efi
      insmod fat
      search --set --file $file
      chainloader $file
    }
    

    and reboot.

    You should see a new boot entry Windows 10 in the end of the boot entries list.
    Select that and hopefully Windows starts.

    If not, please take a picture(s) of the screen to record what the errors are, and show the picture(s) here.

  • My dealer told me yesterday that I can use the EasyBCD program to manage my DualBoot configuration. EasyBCD runs under Windows. So I would have to delete or deactivate my Antergos installation to start Windows again. That wouldn’t be a big problem because I haven’t installed many programs under my Antergos yet. But under Windows 10 there are many programs running that I need!

    I had imagined that I could continue to run my everyday programs under Windows 10 and then migrate these programs step by step to Antergos. Step by step I wanted to learn how to manage an application under a Linux system. But now Windows 10 is no longer available for me.

    To cut a long story short: It is no problem for me to completely uninstall Antergos when I can safely access my Windows 10 again. Then I can start working with Antergos again, step by step.

boot320 windows73 dual40 detected17 Posts 102Views 234
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.