• Hard Drive wakes from standby when anything is mounted on USB.


    I’ve got my OS installed on a 120 GB SSD which then has a limited but usable amount of storage space. All my other data is on a 1 TB hard drive that’s quite noisy when mounted, so in Disks/Drive Settings I’ve set the hard drive to go into standby/spin down after 5 minutes of non-use. This works well for me as I don’t need to access the hard drive much and it gives me a virtually silent PC.

    My problem is that whenever I mount a USB stick or memory card it wakes up the hard drive.

    Anyone got any ideas why this might be or how to stop it happening?

  • @anivegmin
    https://wiki.archlinux.org/index.php/Udisks
    https://wiki.archlinux.org/index.php/Udev
    https://wiki.archlinux.org/index.php/File_systems#Mount_a_file_system

    See also

    man udisks
    man udisks2.conf
    # may need to install these first:
    man hdparm
    man sdparm
    

    One more thing (that may be overkill):

    gconf-editor
    
    • org/gnome/desktop/media-handling/automount
  • @manuel
    Thanks for the links. Plenty to learn. I’ve come across hdparm before for acoustic management settings.

  • @anivegmin
    The problem may be vendor specific. I’ve never encountered such a problem, so I have no clear solution. Just the links, and one idea to try.

usb116 standby6 mounted4 wakes1 Posts 4Views 51
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.