• Laptop Wifi Not Working


    Hi my wifi has suddenly stopped working. I’m running the latest gnome. The laptop is a Dell Inspiron 15 5558. It was working fine all day in work and when I came home it wouldn’t connect to the internet. If open settings and look in the wifi it was Wifi adapter not found. If I run lspci I get this:

    06:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
    

    So looks like it is at least seen.

    I’m now connected via ethernet and that is working fine.

    Any idea how to resolve?

  • @doyler78 show output of this command.
    lspci -vnn | grep -i net

  • Hi @ricklinux output as requested.

    lspci -vnn | grep -i net
    06:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
    07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller [10ec:8136] (rev 07)
    	Subsystem: Dell RTL810xE PCI Express Fast Ethernet controller [1028:06ae]
    
  • @doyler78 also check that you have accidentally turned off wireless on your laptop

  • I’ve checked in both the hardware switch and in the BIOS and both are enabled.

  • @doyler78 Did the laptop happen to goe into sleep mode as it may not turn wifi back on! Try rebooting it.

  • I’ve rebooted it several times. Unfortunately made no difference.

  • @doyler78 Okay i guess that answers that question. So in the network settings icon you don’t see any connection for wifi?

  • @ricklinux No just a message saying “No Wi-FI Adapater Found”. If I toggle airplane mode off and on. Makes no difference either. Same message. Wondering if maybe some recent update has borked it. Might try LTS kernel and see if that resolves the issue.

  • @doyler78 The only driver i see for that adapter is in the AUR RTL810xE-dkms so i’m not sure how you originally had it working?

  • That’s interesting. It’s definitely not installed. Laptop has been working with wifi out of the box since I installed it a couple of years ago though i did do a reinstall about 6 months or so a go just so I could freshen things up again.

  • @doyler78 So it had wireless from the start? I see it’s a realtek RTL810xE pci express wi-fi adapter. That’s the chip on the hardware. So 'll let @joekamprad or @manuel chime in here as they have more experience when it comes to this as i have to head off to work.

  • Just looking that is. Is the realtek not the ethernet. The wireless is Intel is it not?

  • @doyler78 Sorry that’s the ethernet… i meant Intel.

  • @doyler78 You could try…
    rfkill list all
    #to see if it actually is blocked
    #if yes then.
    rfkill unblock all

  • @ricklinux Well the Linux LTS changed nothing. Still no wifi. I’ve ran that command and looks like there are no blocks. The output is:

    rfkill list all
    0: hci0: Bluetooth
    	Soft blocked: no
    	Hard blocked: no
    1: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    
    

    I’m going to boot into my Windows 10 partition and see if it’s working there just to make sure it’s definitely working.

  • @doyler78 Okay …well i tried. Got to head off to work. Someone will help i’m sure.

  • @ricklinux Thanks a lot for trying. Windows at least confirms the wifi adapter is working.

  • @doyler78
    Can you install inxi from AUR?
    If yes, then please show the output of

    inxi -F
    

    It may be caused by a kernel update. If that’s the case, hopefully it will be fixed on the next kernel update.
    If your wifi driver is iwlwifi, you could try package iwlwifi-next (both are in AUR). Not sure if it changes anything, but worth a try.

  • @manuel I’ve installed inxi and the output is below:

    System:    Host: antergos-laptop Kernel: 5.0.7-arch1-1-ARCH x86_64 bits: 64 Desktop: Gnome 3.32.0 Distro: Antergos Linux 
    Machine:   Type: Laptop System: Dell product: Inspiron 5558 v: 01 serial: <root required> 
               Mobo: Dell model: 086DKN v: A00 serial: <root required> UEFI: Dell v: A15 date: 02/02/2018 
    Battery:   ID-1: BAT0 charge: 27.4 Wh condition: 27.4/32.6 Wh (84%) 
    CPU:       Topology: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP L2 cache: 4096 KiB 
               Speed: 2783 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 1684 2: 1826 3: 1736 4: 1695 
    Graphics:  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel 
               Device-2: NVIDIA GK208BM [GeForce 920M] driver: nouveau v: kernel 
               Display: x11 server: X.Org 1.20.4 driver: intel,nouveau unloaded: fbdev,modesetting,vesa resolution: 2560x1440~60Hz 
               OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 19.0.2 
    Audio:     Device-1: Intel Broadwell-U Audio driver: snd_hda_intel 
               Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel 
               Sound Server: ALSA v: k5.0.7-arch1-1-ARCH 
    Network:   Device-1: Intel Wireless 3160 driver: iwlwifi 
               IF: wlp6s0 state: down mac: b4:6d:83:ed:01:8e 
               Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
               IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: 20:47:47:e7:96:8d 
               IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: 00:50:56:c0:00:01 
               IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: 00:50:56:c0:00:08 
    Drives:    Local Storage: total: 894.25 GiB used: 484.50 GiB (54.2%) 
               ID-1: /dev/sda vendor: SanDisk model: SDSSDHII960G size: 894.25 GiB 
    Partition: ID-1: / size: 73.21 GiB used: 69.19 GiB (94.5%) fs: ext4 dev: /dev/sda6 
               ID-2: swap-1 size: 15.62 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda11 
    Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A sodimm: 37.0 C gpu: nouveau temp: 43 C 
               Fan Speeds (RPM): cpu: 0 fan-2: 0 fan-3: 0 
    Info:      Processes: 248 Uptime: 39m Memory: 15.58 GiB used: 4.93 GiB (31.7%) Shell: bash inxi: 3.0.33 
    
wifi150 laptop54 Posts 79Views 185
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.