• systemd lvm2 woes


    systemd lvm2 rebooting woes

    Hi.

    systemd seems to be working fairly well but…

    Over one year ago, it added a 30 seconds delay on exiting (see below) because of a UID=1000 problem I never understood and never succeeded to correct.

    Some weeks ago, it added on top of it a 90 seconds delay because of an lvm2 related problem I do not understand (and I do not use lvm…)

    It is fairly irritating to encounter problems of this kind and that no plain cut solution can be found. systemd spots a cryptic problem, does not care about hinting for a solution.

    I tried

    systemctl disable lvm2-monitor.service

    to no avail. wiki related information is beyond me. Just waiting that this damned service stops. Very frustrating.

    Text errors on exiting:

    1. A stop job is running for User Manager for UID 1000 (30 seconds)

    2. Stopping Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling (90 seconds!)

    Question : How to really stop forever this lvm2 things I never used?

  • @roger64 Try this and see if it makes any difference.

    The solution is to open shell and “shutdown now” then when the machine comes back on then do a “reboot” and the message goes away and future reboots do not hang anymore.

    LVM2 runs on my Antergos too. But i have no issue. Shuts down immediately and or reboot. I think the problem is related to something else.

    Screenshot from 2019-04-15 23-29-09.png

  • Thanks ricklinux

    Nothing changed.

    I am puzzled because I changed nothing in my configuration and partitions. It (this lvm2 thing) suddenly came out of nowhere after a kernel update, went away for one week and it seems it decided to stay.

  • I succeeded three times in a row to suppress this 90 secs delay by using the command below before using the command “reboot”

    time sudo systemctl stop lvm2-monitor.service
    

    If only I knew how to start without this service, that would probably help…

  • @roger64 you could use systemctl mask to stop it from starting. I’m not sure if it will cause any problems though.

    A masked service is one whose unit file is a symlink to /dev/null . This makes it “impossible” to load the service, even if it is required by another, enabled service. When you mask a service, a symlink is created from /etc/systemd/system to /dev/null , leaving the original unit file elsewhere untouched.

  • In the man pages of systemctl, it says that I can mask “units” but not a service or I missed something.

  • @roger64 I read you can do service but just to warn you that when you unmask it sometimes it doesn’t turn back on and requires intervention from some of the stuff i’m reading. I’m not that up on it i have just read some others using it for similar issue.

  • @roger64 My understanding is you just type systemctl mask (service) and or unmask to put it back.

  • @roger64 Like this:

    systemctl mask name.service
    systemctl unmask name.service

  • @ricklinux Have you run these commands? See what is taking the longest time.
    systemd-analyze blame
    systemd-analyze critical-chain

  • Thanks for this. Up to now, your “mask” command above did the trick. The lvm2 service does not appear anymore at start-up. Of course it’s too early to know if there are some side-effects, but i ma pretty sure none of my partitions ever used it. If there is a problem, it’s easy to revert this command.

    So I mark it solved.

  • Mask it, as it could do the job…

  • @roger64 I’m glad it worked for you. It’s my understanding that a disabled service will still start if it’s required by another dependency where as a masked service won’t because it changes to symlink to go to /dev/null which is nowhere so it can’t start. ☺

  • I’ve noticed some few days ago an update of lvm2 package. I tried it and found that there was no more this 90 sec waiting time on exiting. So, this delay was due to some regression which has been solved by now.

  • @roger64 An update to the package won’t make any difference if you have it masked. It doesn’t start anyway.

systemd36 lvm23 woes1 Posts 15Views 115
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.