• Problems with Dual Boot Installation of Live USB Stick


    If you have big amount if RAM installed swap is not needed… +more then 8GB

  • @manuel, @joekamprad On the SSD are 100.28 GiB free. I would like to provide Antergos about 40 GiB, can also be more (?). Nothing should run on the 250 GB SSD (sda) except Win 10 and Antegros Linux. Installed RAM 8 GB.

  • @mr-ed
    With 8GB of RAM, swap most probably is not needed (but that depends on how “heavy” apps you are going to run).
    But for “normal” small apps, no swap is needed.

    And it can be installer later if needed (optionally as a swap file, not swap partition).

  • Okay, @manuel. What would you recommend: How much space on the SSD should I provide Antergos if I don’t need anything else but Windows? I want to use GIMP and Darktable for image processing under Antergos, that can be very computation intensive.

  • @mr-ed
    Depends on show much disk space those apps and your working data needs.
    Currently I have less than 20GB for Antergos system (part of it is my own data files), so maybe 10GB is currently taken by Antergos Xfce.
    So, as a very, very rough calculation, is 40GB - 20GB = 20GB for your data files enough? If not, then adjust accordingly. And of course, different Desktops require different amounts of space.

  • @manuel First I want to install Gnome (default). For example, I wouldn’t have a problem giving Antergos 60 GiB on my SSD and adding a 20 GiB SWAP partition there.

  • @mr-ed
    As you have 8GB of RAM, adding more than about 8GB of swap is unnecessary and does not really help anything (AFAIK).

    I suggest (without knowing how memory intensive your apps will be) you don’t add swap at all.

    And if you notice apps are crashing because running out of memory, then add a swap file of about 8GB, but no more than that.

    https://wiki.archlinux.org/index.php/Swap

  • Okay and thank you, @manuel. I think so too. I’ll try it now with the newly burned stick and let you know what happened. But maybe tomorrow, too.

  • Thanks again for your help! I have tried all possible settings at Rufus this morning. I also re-created a stick with Etcher. If I used the dd mode with Rufus, the stick was not recognized by my system at all. Etcher gave me a short feedback. I then tried to follow the instructions from https://wiki.archlinux.de/title/UEFI_Installation. I could just confirm the OK with the return key, then the connection broke down and Windows started. Finally I tried the installation from a DVD. Antergos also started, but trying to install the system on my SSD caused the same problems as my many previous attempts from the USB stick. I am at a loss.

    I also wonder if it still makes sense to continue the discussion here in the forum. Everything seems to go round in circles. Maybe I made a stupid mistake somewhere? Maybe Windows is configured so that it doesn’t allow any changes? My dealer knew that I wanted to install a Linux parallel to Windows. As far as I can tell, he has considered everything that is necessary.

  • @mr-ed
    Very strange problem indeed. The immediate problem is that the stick is not recognized after “burning” the ISO to it.

    Now that you have created the installer stick with etcher and also Rufus in DD mode, the only potential reasons I can think of right now are:

    • BIOS and its settings:
      – Secure boot should be disabled
      – Motherboard BIOS update might be needed?
    • USB ports:
      – Try connecting the stick to different USB ports. It has been reported that some ports just don’t always work with a particular stick. Try also USB 2.0 and 3.0 ports.
    • The stick itself:
      – Does it work as a “normal” stick after re-formatting it?
      – Did you give a sync terminal command after burning the stick, or use the file manager to safely remove the stick? If you quickly remove the stick after burning, some write process to the stick might have crashed.
  • @manuel
    Secure boot is disabled in BIOS. I bought the computer four weeks ago, so BIOS should be up to date. I changed USB ports several times. And, as I said, the first Live Stick I created still works, but I can’t finish the installation. It’s the same with the DVD.

  • If DVD causing the same issue it must be something not related to usb stick at all…

  • @joekamprad So I think too.

  • Would be helpfull to get bootlog:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io
    

    From live session … Will give out a link to the pastebin of logs

  • I can create a bootlog file under Windows. Would that help?

  • @mr-ed
    No, you should boot the Antergos live stick and there get the log.

  • Maybe I still have a trace in Secure Boot: the manual of my MSI motherboard says the following (setting in my system italic):

    <—msi manual start—>
    “Windows OS Configuration” There:
    Windows 10 WHQL Support [Enabled]
    Enables the supports for Windows 10 or disables for other operating systems.
    Before enabling this item, make sure all installed devices & utilities (hardware &
    software) should meet the Windows 10 requirements.
    [Enabled] The system will switch to UEFI mode to meet the Windows
    equirement.
    [Disabled] Disables this function.
    […]
    Secure Boot
    Sets the Windows secure boot to prevent the unauthorized accessing. Press Enter
    to enter the sub-menu. This sub-menu will appear when Windows 10 WHQL
    Support is enabled.
    Secure Boot Support [Disabled]
    Enables or disables secure boot support.
    [Enabled] Enables the secure boot function and allow you to set the secure
    boot settings.
    [Disabled] Disables this function.
    Secure Boot Mode [Custom]
    Selects the secure boot mode. This item is to select how the secure boot keys be
    loaded. This item appears when Secure Boot Support is enabled.
    [Standard] The system will automatically load the secure keys from BIOS.
    [Custom] Allows user to configure the secure boot settings and manually load
    the secure keys.
    </—msi manual end—>

    Here is a screenshot of the MSI motherboard (hope you can still read it, I’ve made it a bit smaller):

    190417_MSI_SnapShot.jpg
    “Secure Boot – Disabled” - that’s why I thought Secure Boot was no problem. But maybe it is? There are people on the net who say you can simply disable this “Windows 10 WHQL Support”. Without data loss. I’m always a bit cautious.

  • @joekamprad said in Problems with Dual Boot Installation of Live USB Stick:

    lspci >

    I entered the Linux statement (lspci > …) and also got a result. I saved it as a text file, but the file is too big to post here …

  • On my Asus board you have to clear the secure keys after disabling secure boot because they are loaded when secure boot is activated and windows 10 is installed. So secure boot need to be turned off and keys cleared and save the Bios settings. Then it is off and the keys are unloaded.

  • I see two settings. Delete all key variables and below it is key management. So if you read the manual it should explain. You need to have secure boot off and the keys cleared and save the Bios settings after doing both.

installation326 boot320 live59 dual40 Posts 148Views 392
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.