• How to get a fully working Vivaldi Browser?


    @manuel
    If you’re planning to put the vivaldi-ffmpeg-codecs, choose the bin version, the other one takes an awful long time to build.

  • @Bryanpwo
    Thanks!
    I also noticed that it takes ages to compile it. So I’ll probably add the bin version.

  • @Bryanpwo
    What exactly is the AUR package you recommend? Is it vivaldi-codecs-ffmpeg-extra-bin or something else?

  • @manuel
    Yes, that’s the one, I always forget the exact name of the package.

  • OK, I just added vivaldi-codecs-ffmpeg-extra-bin to github.

    Can someone please test it now.

    Note that I have not tested it because I’m not a vivaldi user and thus not a suitable tester.

    Note also that it uses a newer ubuntu deb package than what the AUR package uses. You can see the deb version in the package name.

  • Now there’s package vivaldi-widevine at github.

    All in all, the vivaldi packages there are:

    • vivaldi
    • vivaldi-codecs-ffmpeg-extra-bin
    • vivaldi-widevine

    I didn’t test the extensions. But please report here if there are problems. And yes, successful usage can be reported, too! 😄

    EDIT: just tested vivaldi-stable, but it didn’t work. So currently it cannot be used, I try to fix it as soon as possible.

  • Downgraded vivaldi-codecs-ffmpeg-extra-bin, and now vivaldi-stable seems to work.
    But I didn’t test it much, so please test it and report the results.
    This way we can make it work. 😃

  • @joekamprad
    Build speed. The bin package is already compiled, recommended by @Bryanpwo
    I don’t know if it has all codecs, but it would be nice if someone can test various use cases.

  • @manuel it do not use the same source, and version differs also…

  • @joekamprad
    True. I’m relying on the Ubuntu devs, since the AUR package maintainer is also doing so.
    Do you think the bin version is not OK?

  • Bin version is older, and it is unclear wgat patches are included… As on development of vivaldi every new version have a change on needed patches

  • @joekamprad
    I already tried with the latest codecs version 73.0.3683.103 (at Ubuntu site) but it didn’t work.

    I suppose I’ll have to check those things a bit more.
    Thanks for the heads up!

  • @joekamprad
    I’m using this one for over a year and it never gave or gives me problems.

  • @manuel
    What doesn’t work, when you tried?

  • @Bryanpwo
    It complained about a missing library contents (probably libm.so.6 or similar), don’t remember now the content error.

  • That’s strange, then how come it’s working over here?

  • I just removed Vivaldi and all the necessary codecs, removed every file and then reinstalled everything back, including the vivaldi-codecs-ffmpeg-extra-bin and it still works.

  • @Bryanpwo i do not like to use sources with unclear state…
    Using ffmpeg code directly from chromium sources like we do before is more clean:

    https://github.com/Antergos/antergos-packages/blob/master/antergos/vivaldi/PKGBUILD.inactive

  • @joekamprad
    I completeley understand your point of view, but that doesn’t make the other solution the wrong one to choose.

browser35 vivaldi20 fully3 Posts 50Views 304
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.