• GDM lock screen shield is black


    I’m running gnome, with GDM enabled. I have the nvidia drivers installed.

    When resuming from suspend, the lock screen shield is black (the image selected for the lock screen is not displayed). If I mouse up to unlock or start typing it goes to the password entry lock screen. Everything else appears to be working correctly.

    I’ve looked over journalctl -b, but haven’t found anything personally that would look like an error with displaying the lock screen shield.

    Any thoughts on what to look at to figure out what is going on?

  • Which nvidia card are you using?

  • I have the Geforce GTX 1050.

  • Have you disabled lightdm lock screen in the tweak menu?
    (Your GPU isn’t that new that it may cause problems, in case you’re wondering why I’m not doing anything with that info)

  • I haven’t, I’m not sure I know where to find that setting.

  • You can find it in the tweaktool under extensions.

  • I forgot to mention that you have to reboot the machine, after you’ve done that. (Complete reboot, not just logging off and logging in.)

  • I’m not seeing anything for disabling the lightdm lock screen in the extensions. I have seen in the light locker settings that I could disable. I have done that, and restarted. But am still seeing the same things.

  • My apologies for the confusion, this extension was one that came with the previous version of Gnome in Antergos.
    How many users do you have installed on Gnome?

  • No worries. I only have one user setup in gnome.

  • I’m using an older Nvidia card and I don’t have it, there were earlier problems with Gnome 3.32, but they got fixed with Gnome shell updates. I’m sorry, but I’m out of ideas.

  • have you tried to change the lock screen image manually just to make sure there isn’t an issues the currently selected image?

  • I’m not quite sure what you mean by changing the lock screen image manually. Is that in say a config file or dconf?

  • @kendellfab
    @galvez_65 probably means to select another image as your lockscreen in either the settings menu or the the tweaktool. Just to be sure, pick one of the Gnome backgrounds.

  • I tried changing to a Gnome specific background. It actually worked a couple of times. However after those couple of times, it went back to the black background problem.

  • This appears to be an upstream issue. Gnome Shell

black83 gdm49 lock33 shield1 Posts 16Views 166
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.