• Brightness (Screen) on iMac with Radeon Not Working

    I have a 2011 iMac that I can’t get the screen brightness to adjust – no matter what boot parameters that I pass – using either the keyboard or the slider in the menu bar. I can get it to work with:

    sudo -i
    echo [*number 1-255*] > /sys/class/backlight/radeon_bl0/brightness

    I have tried the following additions to my boot stanza:


    This computer has mutiple partitions with several linux distros (Ubuntu, Fedora, etc.). The following addition to the boot stanza works on those:

    acpi_backlight=vendor radeon.dpm=0

    I should mention that I use rEFInd as my bootloader. Also, I have updated after each change to the boot stanza using mkinicpio, though I’m not sure if that would actually do anything in the context of boot stanzas.

    This makes me think it is a kernel or hook issue in Antergos. But no idea what to change.


  • Have you tried the LTS kernel?

  • No! Will try that today. Thanks for the suggestion. Will report back.

  • Unfortunately, it didn’t work. I installed lts and booted successfully to that kernel (uname -r = 4.19.34-1-lts) with the acpi_backlight=vendor kernel parameter, but still no brightness control.

    Is there some hook or module I needed to include?

  • @Archer
    For some hardware, program xbacklight of package xorg-xbacklight helps. But not all.

  • @manuel Thanks, tried that. No joy.

  • I did look at that link, but it doesn’t seem to have any solutions. And its a few years old. I’m not sure why the brightness would work on a number of other distros with that single kernel parameter (acpi_backlight=vendor), and just not on Antergos. That’s kind of the key to my question - is there some aspect of Antergos that needs to be modified to make it accept that parameter?

    I would ask on Arch, as there must be at least one 2011 iMac user there, but I understand that is not allowed.

  • @Archer
    Yes, Arch people want to help only Arch users.
    But Antergos is extremely close to Arch, only some subtle differences.
    If you have the time, you could install Arch and if the same problem occurs, then ask at Arch forums. Unfortunately I don’t have iMac so I can’t experiment with various kernel parameters. (Well I used to have an iMac, but it wasn’t very Linux friendly at the time, so I got rid of it).

  • Sorry for the late reply, but can you tell us which DE you’re using on Antergos and on the other Linux distro’s and are you still using macos?

  • @Bryanpwo
    The DE on Antergos is GNOME (3.32).

    The DE on Ubuntu is GNOME (3.30). The DE on Fedora is GNOME (3.30).

    I have a MacOS partition that is alive, but I don’t use it unless something happens with my rEFInd bootloader. For example, updates to Ubuntu inevitably update GRUB which messes with rEFInd (still need to run that one down). And the easiest way to fix is to boot into MacOS and reinstall rEFInd. So I use it for emergencies.

  • Which Gnome shell theme are you using? If it’s Numix (the default Antergos theme), try switch it to the default Gnome theme. I know it sounds silly, but during the 3.32 version transition last month, some themes don’t look AND function that well in Gnome.

  • @manuel Well, that may work. I will see if I can find an install tutorial. I’ve avoided straight Arch b/c of the time involved in installing and maintaining. But it may be worth it at this point. Also, I have some extra partitions on this hard drive ready for the occasion.

  • @Bryanpwo
    I swear I responded to this. Anyway, I was running Numix. But I switched to default and rebooted. Still no brightness control – at least not without root and

    echo [*number 1-255*] > /sys/class/backlight/radeon_bl0/brightness
  • Unfortunately, I had to give up on Antergos as an OS. I really wanted to make it work, but brightness is kind of a fundamental need. I did try to install Arch, but after a successful install, couldn’t get the DM to work – and got no help from the Arch forums. So, at least for now, I have to go back to Fedora. I will leave this open in case someone has a solution.

  • @Archer
    For a solution someone active user should have about the same machine as yours. Hopefully that someone will be found. :)

  • So, FWIW, I have the same problem on a Lenovo install. For the Lenovo, here is the lspci.

    00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
    00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 02)
    00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
    00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
    00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
    00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
    00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
    00:15.3 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #3 (rev 21)
    00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
    00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
    00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)
    00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
    00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
    00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
    00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
    01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
    02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961

    Anyone running Antergos on either an iMac or a Lenovo?

  • @Archer
    That may be slightly different issue, since you have Intel GPU. Is that the only GPU?
    What drivers do you have installed?

    pacman -Qs xf86-video

    Depending on what you have, installing xf86-video-intel may help.
    If not, please show the output of

    lspci -vnn | grep -A9 VGA

    or preferably

    inxi -Fc0
brightness18 radeon15 imac3 Posts 18Views 141
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.