• Qt5ct issues


    Hello,

    So, there was an update recently to qt5 stuff and now I can’t make nheko (matrix client) work. Here is its output:

    Reading profile /etc/firejail/nheko.profile
    Reading profile /etc/firejail/disable-common.inc
    Reading profile /etc/firejail/disable-devel.inc
    Reading profile /etc/firejail/disable-interpreters.inc
    Reading profile /etc/firejail/disable-passwdmgr.inc
    Reading profile /etc/firejail/disable-programs.inc
    Reading profile /etc/firejail/whitelist-common.inc
    Parent pid 1418, child pid 1419
    1 program installed in 14.61 ms
    Warning: cleaning all supplementary groups
    Warning: cleaning all supplementary groups
    Warning: cleaning all supplementary groups
    Warning: /sbin directory link was not blacklisted
    Warning: /usr/sbin directory link was not blacklisted
    Warning: cleaning all supplementary groups
    Blacklist violations are logged to syslog
    Child process initialized in 64.81 ms
    qt5ct: using qt5ct plugin
    
    (nheko:8): Gtk-WARNING **: 16:27:15.746: Unable to locate theme engine in module_path: "adwaita",
    
    (nheko:8): Gtk-WARNING **: 16:27:15.746: Unable to locate theme engine in module_path: "adwaita",
    qt5ct: D-Bus system tray: no
    qt5ct: custom style sheet is disabled
    
    Parent is shutting down, bye...
    

    Any idea what could be happening? I am using i3wm.

  • qt5ct is basicly to match your gtk to qt5 .

    add QT_QPA_PLATFORMTHEME=“qt5ct” to your /etc/environment , you also probably got some qt5 settings of qt5ct to choose theme to use.

    dont know what kinda program it is? looks as other issue?

  • @ringo32 I am sorry, but I don’t know what you mean by your post. adding that environmental variable does not help the issue.

    This is the program: https://github.com/Nheko-Reborn/nheko/

  • for qt5ct there is normally qt5ct oin menu , is just to select qt theme to use for that qt theme. does not use gtk theme QT_QPA_PLATFORMTHEME=“qt5ct” need to be set to use qt5ct as configurator

    i gues somewhere in xsession can but i do perosnally in /etc/enviroment , then reboot

    you have to launch qt5-settings and select theme if that does not start te program then some rule set is wrong i gues?

  • I do have a theme selected in qt5 settings. The issue arised with the newest updates from antergos.

  • @markoff Is it possible to downgrade those updates? Did you view history in the update manager and try to figure out which updates messed it up?

  • Sadly, I already tried to downgrade a few things but couldn’t make it work. I think it broke in this update:

    upgraded at-spi2-core (2.32.0-1 -> 2.32.1-1)
    upgraded autojump (22.5.1-2 -> 22.5.3-1)
    upgraded icu (63.1-2 -> 64.1-1)
    upgraded libxml2 (2.9.9-1 -> 2.9.9-2)
    upgraded bind-tools (9.13.7-1 -> 9.14.0-1)
    upgraded boost-libs (1.69.0-1 -> 1.69.0-2)
    upgraded libinput (1.13.0-1 -> 1.13.1-1)
    upgraded harfbuzz (2.4.0-1 -> 2.4.0-2)
    upgraded qt5-base (5.12.2-1 -> 5.12.2-2)
    upgraded qt5-location (5.12.2-1 -> 5.12.2-2)
    upgraded pixman (0.38.0-2 -> 0.38.2-1)
    upgraded qt5-webkit (5.212.0alpha2-24 -> 5.212.0alpha2-26)
    upgraded xfsprogs (4.20.0-1 -> 4.20.0-2)
    upgraded calibre (3.40.1-1 -> 3.40.1-2)
    upgraded libmagick (7.0.8.37-1 -> 7.0.8.39-1)
    upgraded imagemagick (7.0.8.37-1 -> 7.0.8.39-1)
    upgraded liblouis (3.8.0-1 -> 3.9.0-1)
    upgraded cups-filters (1.22.4-1 -> 1.22.5-1)
    upgraded libcroco (0.6.12+4+g9ad7287-2 -> 0.6.13-1)
    upgraded glib-networking (2.60.1-1 -> 2.60.1+2+g1ce6b40-1)
    upgraded libsoup (2.66.0-1 -> 2.66.1-1)
    upgraded file-roller (3.32.0-1 -> 3.32.1-1)
    upgraded glslang (7.10.2984-1 -> 7.11.3113-1)
    upgraded gobject-introspection-runtime (1.60.0-1 -> 1.60.1-1)
    upgraded gvfs (1.40.0-1 -> 1.40.1-1)
    upgraded gvfs-gphoto2 (1.40.0-1 -> 1.40.1-1)
    upgraded gvfs-mtp (1.40.0-1 -> 1.40.1-1)
    upgraded libwbclient (4.10.0-3 -> 4.10.2-1)
    upgraded smbclient (4.10.0-3 -> 4.10.2-1)
    upgraded gvfs-smb (1.40.0-1 -> 1.40.1-1)
    upgraded harfbuzz-icu (2.4.0-1 -> 2.4.0-2)
    upgraded lib32-icu (63.1-2 -> 64.1-1)
    upgraded lib32-libxml2 (2.9.9-1 -> 2.9.9-2)
    upgraded libcdr (0.1.5-1 -> 0.1.5-2)
    upgraded libe-book (0.1.3-4 -> 0.1.3-5)
    upgraded libical (3.0.4-2 -> 3.0.4-3)
    upgraded libmspub (0.1.4-4 -> 0.1.4-5)
    upgraded libqxp (0.0.2-1 -> 0.0.2-2)
    upgraded libvisio (0.1.6-5 -> 0.1.6-6)
    upgraded libzmf (0.0.2-5 -> 0.0.2-6)
    upgraded raptor (2.0.15-10 -> 2.0.15-11)
    upgraded libreoffice-fresh (6.2.2-2 -> 6.2.2-3)
    upgraded libsynctex (2018.48691-7 -> 2018.48691-8)
    upgraded linux (5.0.6.arch1-1 -> 5.0.7.arch1-1)
    upgraded portaudio (190600_20161030-2 -> 190600_20161030-4)
    upgraded python-jinja (2.10-2 -> 2.10.1-1)
    upgraded qt5-webengine (5.12.2-1 -> 5.12.2-2)
    upgraded qutebrowser (1.6.0-1 -> 1.6.1-1)
    upgraded simple-scan (3.32.0-1 -> 3.32.1-1)
    upgraded vte-common (0.56.0-1 -> 0.56.1-1)
    upgraded vte3 (0.56.0-1 -> 0.56.1-1)
    upgraded webkit2gtk (2.24.0-1 -> 2.24.0-2)
    upgraded youtube-dl (2019.03.18-1 -> 2019.04.07-1)
    

    I downgraded the packages below to the previous version, but it didn’t fix it:

    qt5-base-5.12.2-2  qt5-location-5.12.2-2  qt5-webengine-5.12.2-2  qt5-webkit-5.212.0alpha2-26
    
  • @markoff Sorry to hear that. When i break something and it’s usually my fault because i can’t leave well enough alone i end up reinstalling. But, i always learn something in the process! ☺

  • @ringo32 said in Qt5ct issues:

    QT_QPA_PLATFORMTHEME=“qt5ct”

    oh yeah i forgoth, if you build stuf from AUR, and in a update that package is broken, did you rebuild the package at current? downgrading stuf dont work… rebuilding in some cases Yes. …

    did you rebuild the package since also relies on cmake etc… ?

  • @ricklinux But in this case it is not my fault. It has to do with Antergos. Antergos users are having this issue, Arch users are not. One idea is to remove antergos and just go with pure Arch.

    Here is one issue regarding this: https://github.com/Antergos/antergos-packages/issues/455

    The solution there doesn’t fix it for me though, possible because I am using i3?

  • I should try to rebuild that package since its from Aur. Thats also a basic aur rule, even you use pure arch. but every update it can be back. if you not rebuild package you dont know, sometimes a package need a rebuild if something is changed. thats currently i set my cent on if on other packages qt5 works on theming. rebuild can fix some stuf.

  • basicly that config is set in Xsession of lightdm, if you not use lightdm, those configuration does not configured in the system, so adding in /etc/environment works always

  • I already rebuilt the package and it didn’t help.

  • @markoff
    https://aur.archlinux.org/packages/nheko/
    Last Updated: 2019-02-09 11:19
    may AUR PKGBUILD needs to be updated by the providing user…

    reminder: AUR builds are not official packages, this are buildinstructions provided by users.

  • @markoff Sometimes when it’s already broken the fix isn’t going to fix it. Been there done that!

  • @markoff https://wiki.gnome.org/Apps/Fractal
    if you are under i3 i would take this:
    sudo pacman -S fractal
    Bildschirmfoto vom 2019-04-11 10-59-29.png

  • @joekamprad, fractal doesn’t support E2EE while nheko does.

    Also, I think it’s important to note that it was an update that broke nheko and only antergos users are experiencing difficulties. So it’s not nheko’s fault, because if it was arch users would also experience it.

  • @markoff said in Qt5ct issues:

    only antergos users are experiencing difficulties…

    the problem at Antergos with qt5ct was that it was used under KDE/plasma, where it should not be used.
    Under i3-wm it is recommended to be used to configure Qt-style.
    You can easily remove Antergos pre-configs for qt5ct by moving them out of the way for the current user:
    mv ~/.config/qt5ct ~/.config/old-qt5ct
    original Antergos configs for newly created users: /etc/skel/.config/qt5ct
    As packages updated are from Archlinux repositories…

    Antergos have this ones only:

    pikaur -Ss antergos/qt 
    searching.. [###]
    antergos/tomahawk 0.8.4.r11350-1 (music) 
        A Music Player App written in C++/Qt    
    antergos/quazip 0.7.6-2 
        C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package    
    antergos/qt5-styleplugins 5.0.0.20170311-11 
        Additional style plugins for Qt5    
    antergos/octopi 0.9.0-1 
        This is Octopi, a powerful Pacman frontend using Qt libs    
    antergos/libechonest-qt5 2.3.1-3 
        C++ library for interfacing with Echo Nest    
    antergos/antergos-lxqt-meta 1.0-1 
        Meta package for Antergos LXQt
    
  • flatpak may work for you:

    sudo pacman -S flatpak
    flatpak install flathub io.github.mujx.Nheko
    

    Bildschirmfoto vom 2019-04-11 14-49-40.png

    but matrix servers are down at the moment

  • i see you’re using firejail with it. have you run it without firejail?

issues100 qt5ct2 Posts 21Views 261
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.