• HP Zbook X360 G5 - Wacom Touchscreen not working and undetected


    Hi! I’ve installed Antergos on my HP Zbook X360 G5 for a few weeks now, but haven’t been able to make its Wacom touchscreen work no matter what I try (and also the Fn special keys). This laptop is pretty recent (2018) and seems to still have weak support sadly.

    About my setup, I current run an Dual boot Luks encrypted Antergos.
    I run Wayland which is the only session type to work with bumblee on my Nvidia Optimus Quadro P1000 with hybrid graphics in the Bios. X11 only works with discrete graphics, is a bit sluggish anyway and doesn’t work in touch mode any better.

    I noticed that my touchscreen doesn’t even seem detected when I do xinput --list or libinput list-devices (see https://pastebin.com/A0JMXw4f)
    However I can see it if I use udevadm (see https://pastebin.com/SmcZWuqZ):

    ...
    P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88
    L: 0
    E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88
    E: SUBSYSTEM=acpi
    
    P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88/ELAN2514:00
    L: 0
    E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88/ELAN2514:00
    E: SUBSYSTEM=acpi
    E: MODALIAS=
    
    P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88/INT3515:00
    L: 0
    E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88/INT3515:00
    E: SUBSYSTEM=acpi
    E: MODALIAS=
    
    P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88/WCOM48A0:00
    L: 0
    E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:88/WCOM48A0:00
    E: SUBSYSTEM=acpi
    E: MODALIAS=acpi:WCOM48A0:PNP0C50:
    E: USEC_INITIALIZED=16895283
    E: ID_VENDOR_FROM_DATABASE=Wacom
    ...
    : /devices/pci0000:00/0000:00:15.0/WCOM48A0:00
    L: 0
    E: DEVPATH=/devices/pci0000:00/0000:00:15.0/WCOM48A0:00
    E: SUBSYSTEM=platform
    E: MODALIAS=acpi:WCOM48A0:PNP0C50:
    E: USEC_INITIALIZED=17060240
    E: ID_VENDOR_FROM_DATABASE=Wacom
    
    P: /devices/pci0000:00/0000:00:15.0/i2c_designware.0
    L: 0
    E: DEVPATH=/devices/pci0000:00/0000:00:15.0/i2c_designware.0
    E: SUBSYSTEM=platform
    E: DEVTYPE=mfd_device
    E: DRIVER=i2c_designware
    E: MODALIAS=platform:i2c_designware
    
    P: /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1
    L: 0
    E: DEVPATH=/devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1
    E: SUBSYSTEM=i2c
    

    My /etc/default/grub contains the following:

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="Antergos"
    GRUB_CMDLINE_LINUX_DEFAULT='quiet acpi_osi=! acpi_osi="Windows 2009" acpi_backlight=vendor nvidia-drm.modeset=1'
    GRUB_CMDLINE_LINUX="cryptdevice=UUID=XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX:root root=/dev/mapper/antergosvg-root"
    GRUB_PRELOAD_MODULES="part_gpt part_msdos lvm"
    GRUB_ENABLE_CRYPTODISK=y
    ...
    

    and have the following in /etc/modprobe.d/:

    options nvidia-drm modeset=1 
    options nvidia NVreg_UsePageAttributeTable=1
    options i915 modeset=1
    blacklist nouveau
    options nouveau modeset=0
    

    And /etc/mkinitcpio.conf as follows:

    MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm ext4"
    BINARIES=()
    FILES=""
    HOOKS="base udev autodetect modconf block keyboard keymap encrypt lvm2 filesystems fsck"
    

    My kernel modules are as follows (https://pastebin.com/TfiYZvx0) where wacom and wacom_i2c seem to be loaded.

    And finally, I see some ACPI errors in dmesg (https://pastebin.com/7pRmeQfw):

    ...
    [    0.874668] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
    [    0.890837] ACPI: Dynamic OEM Table Load:
    [    0.890855] ACPI: SSDT 0xFFFFA05EAC00BE00 0000F4 (v02 PmRef  Cpu0Psd  00003000 INTL 20160527)
    [    0.891329] ACPI: \_SB_.PR00: _OSC native thermal LVT Acked
    [    0.892073] ACPI Error: Field [CAP1] at bit offset/length 64/32 exceeds size of target Buffer (64 bits) (20181213/dsopcode-201)
    [    0.892078] ACPI Error: Method parse/execution failed \_SB._OSC, AE_AML_BUFFER_LIMIT (20181213/psparse-531)
    ...
    [    4.231920] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-7e])
    [    4.231920] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
    [    4.231920] acpi PNP0A08:00: _OSC: platform does not support [PCIeHotplug SHPCHotplug PME AER]
    [    4.231920] acpi PNP0A08:00: _OSC: OS now controls [PCIeCapability LTR]
    [    4.231920] acpi PNP0A08:00: FADT indicates ASPM is unsupported, using BIOS configuration
    ...
    [    4.898664] ACPI Error: AE_AML_PACKAGE_LIMIT, Index (0x000000005) is beyond end of object (length 0x5) (20181213/exoparg2-396)
    [    4.898673] ACPI Error: Method parse/execution failed \_TZ.GETP, AE_AML_PACKAGE_LIMIT (20181213/psparse-531)
    [    4.898677] ACPI Error: Method parse/execution failed \_TZ.CHGZ._CRT, AE_AML_PACKAGE_LIMIT (20181213/psparse-531)
    [    4.900544] ACPI Error: AE_AML_PACKAGE_LIMIT, Index (0x000000005) is beyond end of object (length 0x5) (20181213/exoparg2-396)
    [    4.900553] ACPI Error: Method parse/execution failed \_TZ.GETP, AE_AML_PACKAGE_LIMIT (20181213/psparse-531)
    [    4.900557] ACPI Error: Method parse/execution failed \_TZ.CHGZ._CRT, AE_AML_PACKAGE_LIMIT (20181213/psparse-531)
    [    4.900565] [Firmware Bug]: No valid trip found
    ...
    

    So would anyone know had the same problems or know what I could try? Even if it requires patching the kernel or anything else?
    Thanks in advance!

  • @rtmv you can try dkms wacom driver to get a more recent driver installed:

    input-wacom-dkms (AUR)

    For X-Org session make sure x-driver is installed:

    xf86-input-wacom

    (sidenote: better take another pastebin service, as pastebindotcom is called unsecure)

  • Thanks for the advice @joekamprad , I’ll avoid it next time.

    So I already have xf86-input-wacom and already tried input-wacom-dkms (tried it again to be sure) but I had no luck with any of them…

    By the way it’s unclear to me if that’s related but I also see the following in dmesg :

    [   16.711306] ish-hid {33AECD58-B679-4E54-9BD9-A04D34F0C226}: [hid-ish]: enum_devices_done OK, num_hid_devices=3
    [   16.737935] hid-generic 001F:8086:22D8.0001: hidraw0: <UNKNOWN> HID v2.00 Device [hid-ishtp 8086:22D8] on 
    [   16.738580] hid-generic 001F:8086:22D8.0002: hidraw1: <UNKNOWN> HID v2.00 Device [hid-ishtp 8086:22D8] on 
    [   16.739388] hid-generic 001F:8086:22D8.0003: hidraw2: <UNKNOWN> HID v2.00 Device [hid-ishtp 8086:22D8] on 
    
  • Suprisingly, using the daily Ubuntu Live image, I managed to have touch screen work without doing anything special (by the way, weirdly, I couldn’t manage to start an Antergos live as it freezes on the loading white screen with antergos Logo…). I don’t know if it’s related to its Kernel 5.0.0-8-generic which is not yet available in Arch.

    I can notably see the following lines appearing in dmesg in addition to what I have on my Antergos install:

     intel-lpss 0000:00:15.0: enabling device (0000 -> 0002)
     nvme nvme0: pci function 0000:6f:00.0
     VFIO - User Level meta-driver version: 0.3
     i2c_hid i2c-WCOM48A0:00: i2c-WCOM48A0:00 supply vdd not found, using dummy regulator
     i2c_hid i2c-WCOM48A0:00: Linked as a consumer to regulator.0
     i2c_hid i2c-WCOM48A0:00: i2c-WCOM48A0:00 supply vddl not found, using dummy regulator
    ...
     random: fast init done
     intel-lpss 0000:00:15.1: enabling device (0000 -> 0002)
     nvme nvme0: Shutdown timeout set to 8 seconds
     i2c_hid i2c-SYNA307B:00: i2c-SYNA307B:00 supply vdd not found, using dummy regulator
     i2c_hid i2c-SYNA307B:00: Linked as a consumer to regulator.0
     i2c_hid i2c-SYNA307B:00: i2c-SYNA307B:00 supply vddl not found, using dummy regulator
     nvme nvme0: 12/0/0 default/read/poll queues
      nvme0n1: p1 p2 p3 p4 p5 p6
     usb 1-4: New USB device found, idVendor=0781, idProduct=556b, bcdDevice= 1.26
     usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
     usb 1-4: Product: Cruzer Edge
     usb 1-4: Manufacturer: SanDisk
     usb 1-4: SerialNumber: 4C530599961017104443
     usb-storage 1-4:1.0: USB Mass Storage device detected
     scsi host4: usb-storage 1-4:1.0
     usbcore: registered new interface driver usb-storage
     usbcore: registered new interface driver uas
    ...
     ata4: SATA link down (SStatus 4 SControl 300)
     usb 1-7: new high-speed USB device number 3 using xhci_hcd
     input: WCOM48A0:00 056A:48A0 Touchscreen as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-WCOM48A0:00/0018:056A:48A0.0001/input/input12
     input: WCOM48A0:00 056A:48A0 as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-WCOM48A0:00/0018:056A:48A0.0001/input/input13
     input: WCOM48A0:00 056A:48A0 as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-WCOM48A0:00/0018:056A:48A0.0001/input/input14
     input: WCOM48A0:00 056A:48A0 as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-WCOM48A0:00/0018:056A:48A0.0001/input/input15
     input: WCOM48A0:00 056A:48A0 Mouse as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-WCOM48A0:00/0018:056A:48A0.0001/input/input16
     hid-generic 0018:056A:48A0.0001: input,hidraw0: I2C HID v1.00 Mouse [WCOM48A0:00 056A:48A0] on i2c-WCOM48A0:00
     input: SYNA307B:00 06CB:CD46 Mouse as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-SYNA307B:00/0018:06CB:CD46.0002/input/input17
     input: SYNA307B:00 06CB:CD46 Touchpad as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-2/i2c-SYNA307B:00/0018:06CB:CD46.0002/input/input18
     hid-generic 0018:06CB:CD46.0002: input,hidraw1: I2C HID v1.00 Mouse [SYNA307B:00 06CB:CD46] on i2c-SYNA307B:00
     usbcore: registered new interface driver usbhid
     usbhid: USB HID core driver
    ...
     ish-hid {33AECD58-B679-4E54-9BD9-A04D34F0C226}: [hid-ish]: enum_devices_done OK, num_hid_devices=3
     hid-generic 001F:8086:22D8.0003: hidraw0: <UNKNOWN> HID v2.00 Device [hid-ishtp 8086:22D8] on
     hid-generic 001F:8086:22D8.0004: hidraw2: <UNKNOWN> HID v2.00 Device [hid-ishtp 8086:22D8] on
     hid-generic 001F:8086:22D8.0005: hidraw3: <UNKNOWN> HID v2.00 Device [hid-ishtp 8086:22D8] on
     usb 1-8: new full-speed USB device number 4 using xhci_hcd
     input: Wacom HID 48A0 Pen as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-WCOM48A0:00/0018:056A:48A0.0001/input/input20
     input: Wacom HID 48A0 Finger as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-WCOM48A0:00/0018:056A:48A0.0001/input/input21
     wacom 0018:056A:48A0.0001: hidraw0: I2C HID v1.00 Mouse [WCOM48A0:00 056A:48A0] on i2c-WCOM48A0:00
    
  • @rtmv
    Hi,
    I’m not familiar with Ubuntu’s package numbering. Arch has kernel 5.0.7.arch1-1, and Ubuntu has 5.0.0-8. Does that mean Ubuntu’s kernel is newer?
    In fact, kernel.org says 5.0.7 is the newest currently.

  • @manuel said in HP Zbook X360 G5 - Wacom Touchscreen not working and undetected:

    5.0.7.arch1-1

    Oups you’re right my bad! I missed a .0 😄 ! Indeed that would have been suprising to have Ubuntu run such a bleeding edge Kernel close to a release…
    Indeed I have 5.0.7 (5.0.7-arch1-1-ARCH) and it looks like their is older (5.0.0)! So wrong hypothesis.

    I’m starting to wonder if my acpi parameters are implied (I use acpi_osi=! acpi_osi=“Windows 2009” acpi_backlight=vendor). I remember I fought with them the first them. I’ll try some other values…

  • @rtmv
    I was too thinking about those kernel parameters, are they currently OK or not.
    You could write them down now for reference, and then try to remove (or modify) them one by one. The less you need them, the better.

    Kernels do get many fixes as time goes by, and it is very much possible that some of them are no more needed.

    Another idea is to try the LTS kernel (linux-lts) unless you already have done that.

  • So I tweaked parameters and couldn’t find a way to make my PC start with kernel parameters other than acpi_osi="Windows 2009" (I tried lots of combinations without result, taking inspiration on https://wiki.archlinux.org/index.php/Talk:ASUS_E403SA)…

    But! I also tried to completely throw away the Nvidia driver, nouveau, and anything I could (I’m running on intel vesa). And then I was able to get rid of acpi_osi parameters at boot. And now my touchscreen is working 😃 !
    But I have a crappy GPU and no way to start my Quadro… 😢

    So my conclusion is that acpi_osi="Windows 2009" that is required for my NVidia card messes with the ability to recognize the Wacom touchscreen… So I’m now facing a cornelian choice 😓 : it’s either my touchscreen or my dedicated GPU, knowing that switching between both mode is not that trivial…

    I quickly tried to enable nouveau to see if it would work better but couldn’t manage to make it even loaded at runtime (despite it being activated in mkinitcpio and the blacklisting command disabled in modprobe…). I’ll try again hoping I can find why.

  • @rtmv
    Great that you have some progress! Seems that your hardware is not the easiest for Arch based distros.
    But I guess Arch wiki and/or lots of googling (or whatever search you use) can provide many ideas, and hopefully one of them proves to solve the case.

    BTW, if you install inxi and provide its output here, maybe, just maybe someone’s light bulb switches on…

    inxi -Fxxxc0
    
  • Here is inxi:

               dm: GDM 3.32.0, LightDM 1.28.0 Distro: Antergos Linux 
    Machine:   Type: Laptop System: HP product: HP ZBook Studio x360 G5 v: N/A Chassis: type: 10 
               Mobo: HP model: 844F v: KBC Version 16.35.00 UEFI: HP v: Q71 Ver. 01.06.03 date: 02/15/2019 
    Battery:   ID-1: BAT0 charge: 75.8 Wh condition: 95.8/95.8 Wh (100%) volts: 12.3/11.6 model: Hewlett-Packard Primary 
               type: Li-ion 2018/07/27 status: Unknown 
    CPU:       Topology: 6-Core model: Intel Core i7-8850H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
               flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62232 
               Speed: 800 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
               9: 800 10: 800 11: 800 12: 800 
    Graphics:  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
               Device-2: NVIDIA GP107GLM [Quadro P1000 Mobile] vendor: Hewlett-Packard driver: N/A bus ID: 01:00.0 
               chip ID: 10de:1cbb 
               Display: server: X.org 1.20.4 driver: none FAILED: nvidia unloaded: modesetting compositor: gnome-shell tty: 238x57 
               Message: Advanced graphics data unavailable for root. 
    Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
               chip ID: 8086:a348 
               Sound Server: ALSA v: k5.0.7-arch1-1-ARCH 
    Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
               chip ID: 8086:a370 
    Partition: ID-1: / size: 350.81 GiB used: 245.64 GiB (70.0%) fs: ext4 dev: /dev/dm-1 
               ID-2: /boot size: 363.9 MiB used: 81.7 MiB (22.5%) fs: ext4 dev: /dev/nvme0n1p5 
    Sensors:   System Temperatures: cpu: 45.0 C mobo: 41.0 C 
               Fan Speeds (RPM): N/A 
    Info:      Processes: 298 Uptime: 52m Memory: 15.45 GiB used: 2.72 GiB (17.6%) Init: systemd v: 241 Compilers: gcc: 8.2.1 
               Shell: bash (sudo) v: 5.0.2 running in: gnome-terminal inxi: 3.0.33 
    

    I’m now able to load Nouveau kernel module but not yet to enable the NVidia card (inxi tells me none FAILED: nvidia unloaded, DRI_PRIME doesn’t work)… That’s annoying because performances (e.g. Blender) with the integrated GPU are awful…

touchscreen8 wacom5 zbook3 x3602 Posts 10Views 122
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.