• Battery Widget Indicator in panel time remaining no longer updating


    After some recent system updates, that included the fairly recent kernel 5.x update, the KDE Plasma battery widget in the panel is seemingly no longer accurately reporting the “time remaining”.

    For example, at 93% battery, it might say 2 hours 24 minutes (2:24) remaining. Yet at 80% and even 50%, it’ll indicate the same thing. Seems to arbitrarily calculate a value at boot and stick with it. I don’t recall this being a problem prior to the 5.x kernel update.

    Hardware is an MSI MS-16H8 laptop.

    I’m fairly new to Antergos and the Arch Ecosystem, coming from Debian and Ubuntu.
    Just joined this community, so please go easy on me. ☺

    One step I’ve taken to try and resolve this was uninstall and then reinstall TLP. Didn’t seem to affect anything.

    Thanks in advance…

  • @tech101us: Updating this post myself. Issue still exists (Unsolved). However, I’m noticing the behavior is such that the battery widget seems to update the remaining time once (when I boot the laptop and login) and that’s it. Any thoughts on how I might resolve this are extremely welcome.

  • To see that it is kernel related you can install LTS kernel and boot on this.

    sudo pacman -S linux-lts linux-lts-headers
    

    Followed by:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    To get the entry into bootmenu.
    Then reboot and choose LTS kernel from Antergos advanced Option menu.

    Take care to install nvidia-lts if you are using nvidia proprietary driver!

panel37 battery22 widget5 indicator2 Posts 3Views 38
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.