• Boot to Terminal Woes


    Hello,

    Earlier today I got a blank screen at login and eventually used a usb w/ antergos to chroot into my installation and disable all display managers, because I could not access the other tty terminals and the screen was just completely blank.

    I have had to do disable display manager’s in the past and I eventually re-enable them after some time. Every time I learn something, but at the same time it is a huge headache. I’m finally going to never use them again and I only want to boot using the cli.

    However, this is where my problem/question starts. Every time I have disabled usage of the display manager and edit grub to have a non graphical boot, my terminal and all tty’s are “invisible.”

    I figured this out by luck one time because I just thought to myself, “Well, the screens are just to visually provide feedback, what if I just can’t see the terminal” and then proceeded to type in my username/pw -> startx and it worked. Maybe it’s intended to not be shown, but I do not feel like that is the case. Also, this consistently works on every boot.

    My Question: How do I make the login just the terminal login on boot? I have already done some of the basic stuff like modifying the grub boot script to have systemd.unit=multi-user.target, adding text, and 3, but I still cannot see the cli.

    Any help would be greatly appreciated.

    I’ve never asked a forum question before so feel free to ask me clarification and I’ll do my best to provide it.

    For some background I have been using antergos for ~1.5 years but still feel pretty newbie.

  • @gub
    You can write the following contents to file /boot/grub/custom.cfg:

    menuentry "Antergos TTY" {
        savedefault
    
        set bootuuid="your-boot-partition-uuid"
        set rootuuid="your-root-partition-uuid"
        set swapuuid="your-swap-partition-uuid"
    
        search --no-floppy --fs-uuid --set=root $bootuuid
        linux   /vmlinuz-linux root=UUID=$rootuuid rw quiet resume=UUID=$swapuuid systemd.unit=multi-user.target
        initrd  /intel-ucode.img /initramfs-linux.img
    }
    

    You just need to change the “your-*-partition-uuid” to match your partitions.
    With command

    lsblk -fm
    

    you can find the UUIDs of partitions.

    And if you use linux-lts, just change the word “linux” to “linux-lts”.

    With this you get a new boot menu entry “Antergos TTY” that boots to non-graphical environment.

  • @manuel

    Hello and thank you very much!

    On the Grub menu, I see a new boot option to “Antergos TTY” – when selecting it I do see some new text, but ultimately the terminal is still “invisible.”

    I’m not sure where to go from here. Should I be looking at dmesg to try to find something abnormal? I’m looking at my systemctl services that are enabled and running and do not see anything that stands out to me.

    Actually, I just noticed something. Do I need to disable plymouth to correctly boot to terminal?
    I’m curious as to why it does not show up in my grep of enabled.
    Screenshot from 2019-04-02 09-09-37.png

    If this is not the answer then I am not sure where to go from here.

    Thank you again.

  • @gub
    If the actual problem is booting to blank screen, I think we need more info about the machine and system.

    With program inxi you could show more info about your graphics.
    Then you could show what graphics drivers you have installed, and how.
    One thing could also be to install another kernel, and even reinstall current kernel.
    And depending on the info from inxi and others, maybe dkms versions of certain packages could provide some help.

  • @gub said in Boot to Terminal Woes:

    Actually, I just noticed something. Do I need to disable plymouth to correctly boot to terminal?

    plymouth? do you install it and have it running for a reason?

  • @manuel
    Hello again,
    Here is the output from inxi, I’ve never used it before but it seems very useful!
    Also regarding what your first response consisted of, what would I have needed to google/know in order to come up with this solution myself? Something like “How to add a boot option to grub”?
    Screenshot from 2019-04-02 11-15-51.png

    @joekamprad
    Hello,
    Hmm I mentioned plymouth because when I ran systemd-analyze blame it was the longest running service. I have not, to my knowledge, explicitly installed plymouth myself. However, I could definitely see myself accidentally doing this when I was first starting out. From my understanding plymouth is only for graphical boots. So I am not sure why I see it when running systemd-analyze blame

    Here is the full output,
    Screenshot from 2019-04-02 11-21-40.png

    I’d also like to mention, I am not able to access other tty’s, when I swap to them they just say “starting antergos root” or something of that nature and a statement of available/used blocks. I am not sure where to go from here. Is this a graphical thing or should I be looking more at something regarding the services listed above?

  • @gub
    Could you show the output of

    lsblk -fm
    sudo fdisk -l
    
  • @manuel
    Here it is
    Screenshot from 2019-04-02 21-21-05.png

  • @gub
    Thanks. Didn’t notice anything unusual there.
    Then the question is your graphics drivers.
    You have hybrid graphics. How did you install graphics drivers? Did you use nvidia-installer?

  • @manuel
    No, I used the AUR to install the nvidia drivers, which might use the nvidia-installer – I’m not sure.
    Here is what I have installed.
    Screenshot from 2019-04-02 21-29-31.png

    If this is a graphics issue, I should mention that I have recently had corrupted (pink+black patterns) backgrounds on my two alternate screens. Although that could be completely unrelated. I have not fixed it yet because I’ve just been using alt+f2 typing r and then pressing enter and then the screens are fixed. This could be completely unrelated, but I thought I should mention it just in case.

  • @gub
    Have you checked Arch wiki about nvidia? There’s lots of great info.

    If you use many packages from AUR, that may cause issues. AUR packages are not officially supported.

    Program systemctl manages services. E.g.

    systemctl status ”service-name”
    

    I suggest you install nvidia-installer and study it. Check command

    nvidia-installer -t
    

    If you also use the Intel graphics, add option -b.

  • This post is deleted!
  • @manuel

    Hey thank you for that information! After using nvidia-installer and uninstalling old drivers I can now see alternate tty’s.

    My initial boot screen is still blank. I know that plymouth is failing due to looking at its status. After snooping around more, I’m still not sure on exactly what to do to fix this.

    Here is what I know is happening:

    • On boot I get a blank screen
      • Even if I do not have systemd.unit=multi-user.target and quiet splash the screen is blank
    • Other tty’s now work after using nvidia-installer instead of the drivers from aur.
    • plymouth-start.service and other plymouth services are failing on boot.

    Also I modified grub to generate a log file of plymouth by adding plymouth:debug to the kernel line in grub but nothing looks odd. I am showing it here anyways because I don’t know this stuff that well.

    Screenshot from 2019-04-04 18-40-31.png

    Oh and I should mention when I added plymouth:debug the boot actually hung and I wasn’t able to enter anything into the invisible terminal like I normally would be able to.

  • @gub
    Hi!
    Seems that you could uninstall package plymouth and all related to it, something like this:

    sudo pacman -Rsn plymouth
    

    But first I suggest, as a general precaution, backup all your important data to an external drive.

    And you probably want to check first which plymouth related packages you currently have:

    pacman -Qs plymouth
    

    BTW, what Display Manager (one of: lightdm, sddm. or gdm) do you have now?

    pacman -Qs sddm
    pacman -Qs lightdm
    pacman -Qs gdm
    

    If the removal of plymouth does not help, you can try changing the Display Manager with the following commands:

    sudo pacman -S --needed <another-dm>
    sudo systemctl disable <your-current-dm>
    sudo systemctl enable <another-dm>
    reboot
    

    And be sure to update your system:

    sudo pacman -Syyu
    
  • @manuel
    Hi, currently I have none of those dm’s installed. I’ve had trouble in the past with both lightdm and gdm where I had to log into an alternate tty instead because the dm’s just didn’t work. I’ve never heard of sddm and I do not believe that I have used it before. I just keep using the invisible terminal to login to my computer since it is consistent.

    Also regarding uninstalling plymouth. I’ve read on various forums when googling things that plymouth is typically implemented into the distribution itself because of when it is supposed to be displayed/run. As a result, I have not tried uninstalling it because various things said I’d have to rebuild something (initrd iirc), which I have never done before and didn’t want to if I didn’t have to (me being lazy/weary). Is that not true for antergos or just unavoidable at this point? I believe I mostly read ubuntu forums about plymouth. Should I try reinstalling plymouth first or would that result in a rebuild too anyways?

    Thank you again for your continued help.

  • @gub
    I don’t have any plymouth related packages installed on my Xfce. And I’m using sddm, but lightdm and gdm also work here.

    So your issue sounds like a graphics driver problem. But there are other potential reasons, like a somehow incompatible display manager, some AUR packages replacing official ones, not properly updated system, etc.
    BTW, the Arch wiki is usually the best source of information with Arch based distros.
    A simple way of regenerating kernel stuff is simply reinstall the kernel:

    sudo pacman -S linux  # or linux-lts
    

    One tip is to use dkms versions of certain packages. That requires also kernel headers like linux-headers or linux-lts-headers.

  • @gub said in Boot to Terminal Woes:

    Also regarding uninstalling plymouth. I’ve read on various forums when googling things that plymouth is typically implemented into the distribution itself because of when it is supposed to be displayed/run.

    plymouth is only used on Antergos on installer ISO, but it is not installed to any Desktop Envoronment on Antergos, so it is saved to remove it.

    Second: if you are booting with proprietary nvidia drivers, plymouth needs to be configured to run an alternative framebuffer device Uvesafb… what is not easy to configure and mostly do not work… so i do assume that you do not set this up.

    But it looks like the service is enabled in a way, it is not enabled automatic after installation of the package and it needs to setup inside mkinitcpio.conf what is causing the need to rebuild kernel-image yes… check if it is inside your image by taking a look inside the config:

    cat /etc/mkinitcpio.conf
    

    and search if the line starting with: HOOKS=" have the plymouth hook inside.

  • @joekamprad

    Funnily enough that’s exactly what I’ve been trying to figure out for the past 2 hrs right after my last post. I’ve been trying to figure out how exactly it’s firing off because it’s not in HOOKS at all.

    I have no idea how it’s firing
    Screenshot from 2019-04-06 00-54-03.png

    Here is my hooks,
    Screenshot from 2019-04-06 00-55-12.png

    Is it safe to remove plymouth before I remove it from whatever is firing it off? Is disabling it as simple as systemctl disable plymouth-start.service?

    I’ve been reading the wiki pages on plymouth, KMS, nvidia, mkinitcpio for the past 2 hours and I have been rebooting a bunch, while trying out different things. I still have no idea what is firing plymouth off. I want to uninstall plymouth like @manuel said. I guess my last remaining question is, is it safe to remove plymouth when I haven’t removed it from whatever is firing it off?

    In my head, I would think it’d be ideal to completely disable plymouth while it is still on my system, then remove it. If this is not the case then I will just remove it. Oh and this is what is installed plymouth-wise.
    Screenshot from 2019-04-06 01-03-46.png

    I have no idea how it got enabled in the first place if it is only used on Antergos ISO installer. From my knowledge I’ve never seen a splash screen in the past 1.5 years lol.

    On another note, I’ve also backed everything important up in multiple places if things go sideways.

    Thanks again for all the continued help.

  • uninstalling will also remove the systemd service files so it will not try to start it after uninstall.
    if you want to disable it before you can do by:
    sudo systemctl disable plymouth.start

  • @gub
    AFAIK, as your install is “relatively” old, then you may have plymouth installed. Things tend to change a lot in a rolling release.

    And great that you have backups. So, from the technical point of view, you are free to experiment with your system as much as you like, even reinstall Antergos.

    So I think it is safe to remove plymouth.
    After removing it, you may need to enable another dm (like sddm) again (if you want to have a dm active):

    sudo systemctl --force enable sddm
    reboot
    

    BTW, I’d use pacman (the official package manager) instead of yay with official packages. Yay is primarily meant for AUR packages, although it works with official packages quite well.

    And hey Joe, the more cooks the better soup, right? 😉

boot321 help-me3 login-screen3 Posts 22Views 221
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.