• Copying Files to USB hangs at 99%


    When you copy larger files to USB it hangs at 97-99% and won’t finish. I have tried this on multiple Linux distributions and it’s the same. So if you try to copy a larger file such as a movie in mp4 or avi even only 1.6 GB this happens so larger 5-10 GB would be almost impossible as i can’t copy multiple files. If i use an external SSD drive this doesn’t happen and i notice the symbol is different when you plug it in. Anyone else find this too?

  • stick may fat32 formatted?

    4GB filesize maximum on fat32 filesystems.

    And flash media do not copy constantly it flashes asyncron to the media

  • @joekamprad usb sticks are fat32 and copying files smaller than 4 GB such as 1-4 GB are a problem. Larger is also not going to work either. It just gets stuck at 99% even though the file is copied it just doesn’t let go of the process. External SSD drives aren’t an issue it’s just usb drives. I tried on Manjaro also …same thing. What is the way around this problem on Linux. I read lots of stuff about disk cache and dirty files etc. Why do external SSD not cause this problem?

  • @joekamprad said in Copying Files to USB hangs at 99%:

    And flash media do not copy constantly it flashes asyncron to the media

    https://en.wikipedia.org/wiki/USB_flash_drive#File_transfer_speeds

    I assume you are copy files over filebrowser… what is causing slow process …
    If you are using command to copy files it will be faster…

  • Agree with Joe.
    Have you tried using the terminal and the cp command? Something like:

    cp fromfile todirectory && sync
    

    With big files you just need to wait long enough. If the USB stick supports only USB version 2.0 or older, then copying really takes a lot more time.
    And note that USB sticks are much slower than SSD drives.

    You could also format the stick to ext2 or ext4 to support larger files (if you don’t use the stick with Windows). E.g. program gparted can format the stick.

    BTW, if the USB stick supports USB 3.0 or better, then you may be using USB 2.0 ports of your machine. If that’s the case, use a faster USB port. Often USB 3.0 ports are blue and USB 2.0 ports are black.

  • @joekamprad Yes i am copying some movie files using file browser. It’s not the slowness that is the problem. It just hangs at 99% and doesn’t release the process. I just found this out recently and found it weird as i was doing it for someone else. If i use an external SSD this doesn’t happen. The files aren’t that big… less than 2 GB but i understand what your saying about fat32 and the drives. I tried one formatted to ntfs and it doesn’t do this. I will try what @manuel advised using cp command in terminal. The reason i was using the fat32 so it is compatible with other media player.

  • @ricklinux
    If the USB stick is old, it may be going south …

usb117 Posts 7Views 164
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.