• Machine stops booting


    [b:2klv42p2]Machine[/b:2klv42p2]: Thinkpad x240 54 bit
    [b:2klv42p2]DE[/b:2klv42p2]: KDE

    [b:2klv42p2]Situation:[/b:2klv42p2]

    • default booting
    • 3 failures are observed
      1- Failed to start Kerberos 5 KDC
      2 - Failed to start Light Display Manager
      3 - Failed to start Network Manager Wait Online

    Last 5 lines of the displayed text are:
    Dependency failed for WPA daemon (interface - specific version).
    Dependency failed for WPA daemon (interface- and nl180211 driver specific version).
    Dependency failed for WPA daemon (interface - amd wired driver specific version).
    Reached target Multi User Service
    Reached target Graphical Interface

    [b:2klv42p2]Additionally I observed[/b:2klv42p2] that I could not do:

    • Leave (shut down)
    • Restart
    • Log off
      Therefore I pressed the power button to force a shut down.

    [b:2klv42p2]What did I do before[/b:2klv42p2]:
    1 - To change the trackpad behaviour I added a few script lines into

      
    2 - I forced the machine to shut down using the power button  
      
    [b:2klv42p2]  
    What do I want to do:[/b:2klv42p2]  
    Start machine in terminal mode and comment the lines I added   
    [b:2klv42p2]  
    What do I believe that I need to do[/b:2klv42p2]  
    - to start machine in terminal mode?  
    - to comment lines in 
    

    I am also open for any other helpful suggestions!

    As always I do appreciate your help a lot.

  • [b:2klv42p2]Machine[/b:2klv42p2]: Thinkpad x240 54 bit
    [b:2klv42p2]DE[/b:2klv42p2]: KDE

    [b:2klv42p2]Situation:[/b:2klv42p2]

    • default booting
    • 3 failures are observed
      1- Failed to start Kerberos 5 KDC
      2 - Failed to start Light Display Manager
      3 - Failed to start Network Manager Wait Online

    Last 5 lines of the displayed text are:
    Dependency failed for WPA daemon (interface - specific version).
    Dependency failed for WPA daemon (interface- and nl180211 driver specific version).
    Dependency failed for WPA daemon (interface - amd wired driver specific version).
    Reached target Multi User Service
    Reached target Graphical Interface

    [b:2klv42p2]Additionally I observed[/b:2klv42p2] that I could not do:

    • Leave (shut down)
    • Restart
    • Log off
      Therefore I pressed the power button to force a shut down.

    [b:2klv42p2]What did I do before[/b:2klv42p2]:
    1 - To change the trackpad behaviour I added a few script lines into

      
    2 - I forced the machine to shut down using the power button  
      
    [b:2klv42p2]  
    What do I want to do:[/b:2klv42p2]  
    Start machine in terminal mode and comment the lines I added   
    [b:2klv42p2]  
    What do I believe that I need to do[/b:2klv42p2]  
    - to start machine in terminal mode?  
    - to comment lines in 
    

    I am also open for any other helpful suggestions!

    As always I do appreciate your help a lot.

  • Hi,

    You can boot to command line by pressing " e " on the grub menu and adding the following parameter to the kernel boot line. You should remove the “quiet” parameter and add this one in its place:[code:1zw32zyu]systemd.unit=multi-user.target[/code:1zw32zyu]

    Best Regards,
    Dustin

  • Thanks for the quick reply!

    I started the machine and interrupted booting with “e”.
    When the process stopped I saw a few lines starting with
    setparams "Antergos Linux"
    on this screen I did ctrl+c and got

    [code:hu928bd0]grup>.[/code:hu928bd0]

    Now I am stuck.

    • What is the “quiet” parameter?
    • What do I need to do to remove the “quiet” parameter?
    • How does the last line of screen look like before I have to enter the command you indicated?
  • You should allow Grub to load its boot menu before pressing " e ". You will see the word “quiet” towards the bottom of the screen. YOu may have to scroll down with your cursor.

  • :exclamation:*Sorry, this attachment is unavailable.*Thanks for all your explanations. I hope you can be a bit more patient with a bloody newbie like me.

    I started the machine several time to see if I can identify the situation you mentioned. (…should allow Grub to load its boot menu before pressing " e ").

    I took the above 4 screen shots which to help you to guide me.

    I really appreciate your patience a lot!

  • [b:2gb38ml0]Pres " e " on this screen:[/b:2gb38ml0]
    [img:2gb38ml0]http://forum.antergos.com/download/file.php?id=295&t=1[/img:2gb38ml0]

    Next you should see an all black screen that shows your grub.cfg file. Look for the line that begins with:

    linux /vmlinuz-linux root=UUID=
    

    You will see the word “quiet” around the end of the line. Erase “quiet” and add the systemd command I provided. Then finally press F10 to continue boot.

    Good luck

  • Thanks for your advice. Now i found the line you indicated.

    I deleted the word “quiet” at the end of the line and added space and
    [code:2wyz9bqh]systemd.unit=multi-user.target[/code:2wyz9bqh]
    Next F10 to continue booting.

    While booting I observed a few failure and the last screen showed the same as what I described in my post Sat Aug 30, 2014 6:09 pm

    What should I do try next?

  • Use this instead:[code:33xjumnx]systemd.unit=emergency.target[/code:33xjumnx]

  • This script line was successful.
    According to the text displayed I am now in the emergency mode and being asked to give root password or to press ctrl-d.

    Entering the password is not possible. No reaction when typing anything.
    But crtl+D made the machine moving and 2 new lines about the status are shown.

    [ 458.131831] thinkpad\_acpi: Unsupported brightness interface, please contact i  
    [ 458.202856] kvm: disabled by bios  
    
    

    These are the last lines.

    What do I need to do next to get the -prompt to use Linux commands?

  • @“52ROSt”:12jesdj3 said:

    Entering the password is not possible. No reaction when typing anything.
    But crtl+D made the machine moving and 2 new lines about the status are shown.[/quote:12jesdj3]This is strange. If you had no response from the keyboard to log in as root then that should mean Ctrl + D doesn’t work either. It doesnt make sense.

    I dont know why I didn’t think of this before…boot using the Live USB/CD, mount your Antergos Root and fix the files you edited before the problem occurred.

    Best Regards,
    Dustin

  • Entering the password is not possible. No reaction when typing anything.

    You won’t see anything on the screen (it’s for security). Simply type the root password and hit enter.

  • Hi, guys, i think i’ts a bug:

    [https://bugs.archlinux.org/task/41711][0]">[https://bugs.archlinux.org/task/41711][1]

    [https://bbs.archlinux.org/viewtopic.php?id=186244][0]">[https://bbs.archlinux.org/viewtopic.php?id=186244][2]

    snormett

    Hi

    When installing run [b:3je0uyi4]‘systemd-machine-id-setup[/b:3je0uyi4][/size:3je0uyi4]’ in chroot (arch-chroot)[b:3je0uyi4] to fix the problem[/b:3je0uyi4][/size:3je0uyi4]

    Yeaaah !!!, Works for me in Archlinux installation…

    Best Regards,

    Héctor.

    [0]: <a href=
    [1]: https://bugs.archlinux.org/task/41711
    [2]: https://bbs.archlinux.org/viewtopic.php?id=186244

  • I am glad you also say that the behavior around ctrl+d is strange.

    However, using the Live USB is a great idea, which I applied immediately.

    But, there is again a but, I cannot open the file (50-synaptics.conf) with root rights. The context menu shows only “Open wit GEdit” or “Open with” and than only GEdit is available. Nothing to be seen, which allows me to open with root rights.

    I successfully opened the last folder (the folder which contains the file 50-synap…) and got the $ prompt.
    Next I searched 2 books for a way to edit the 50-syna… file in terminal mode but failed. Just don’t understand yet enough of Linux

    Thus what do I need to do open the file, add some " # " and save it with the same name?

  • No worries, everyone was new to linux at some point in time
    1. sudo nano /some/file/you/need/to/fix.conf
    2. *Make Corrections*
    3. Ctrl + O (Save as)
    4. Enter (dont change the name)
    5. Ctrl + X (Exit)

    Let me know how it goes

  • Thanks again for help and encouragement.

    I could open the file in the terminal BUT the content of the file content in terminal mode looks the same as the original file. Original means, non of the modification made are to be seen in terminal mode.

    When I go to the file in file explorer and open it in GEdit, I see all the modifications I made.

    I was and I am still puzzled. Still I save the file in terminal mode hoping that this saved file will help me to boot the machine again properly but the booting problem is exactly as described at the very beginning.

    I am now considering to make a new installation; just want to wait until your next reply.

  • Was the 50-synaptics file the only file you changed just prior to the problem? Try moving the file out of the conf.d directory like this:

    sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf /home/YOUR-USERNAME/
    

    The file is not necessary for X to start. It would be helpful to know what is causing the boot to fail as it may not be a file you changed afterall ? Do you have a USB drive that you can save the logs to? If so here are the commands:

    su  
    mount /dev/sdb1 /mnt  
    journalctl -b 1 \> /mnt/journal.last  
    journalctl -b 2 \> /mnt/journal.2last  
    journalctl -b 3 \> /mnt/journal.3last  
    cp /var/log/Xorg.0.log /mnt  
    cp /var/log/Xorg.0.log.old /mnt
    

    Be sure to make an attempt to boot normally before you copy the logs otherwise they won’t be useful.

    Best Regards,

  • Hi Dustin,

    I apologize but I gave up to fix the problem and re-installed antergos; I need to move on. A project came in which requires more time now. I hope you can understand.

    The machine is again running fine.

    I also installed LibO using the terminal command you kindly gave me It is currently only the US version . I need to add other languages (for Japanese I need the UIs, and for German and Dutch, dictionaries etc are sufficient no UIs needed). I will create a new question on this.

    Thanks a lot for you continuing support and encouragement of a newbie.

Posts 18Views 1974
Log in to reply