• Cnchi error - cannot find qt5-styleplugins


    I selected all default options, picked Cinnamon desktop, and I ended up with this error. How come the auto-selected mirrors don’t have q5 packages?

    IMG_20190326_214357.jpg

  • @joekamprad said in Cnchi error - cannot find qt5-styleplugins:

    BUG https://github.com/Antergos/antergos-packages/issues/450

    The ticket was closed but there was no response saying whether it’s been fixed or not. Is it fixed? I can’t check at the moment.

  • @developers
    The qt5-styleplugin is an orphaned package, that’s the reason why Cnchi can’t find it, the git version is still active.

  • Seems that it has been fixed: https://github.com/Antergos/antergos-packages/commit/1dec9de2875e61ea08cd414b9251742d918b115f

    But it may take some time to arrive at the mirrors.

    EDIT: I got the same install error just now.

    EDIT2: got the installing started with two modifications in the same file:

    su
    cd /usr/share/cnchi/data
    nano packages.xml
    
    • change qt5-styleplugins to qt5ct
    • remove line with xorg-mkfontdir (old issue is rising again!)

    Then start cnchi (as root) again with command:

    cnchi -p $PWD/packages.xml
    
  • Looks like buildserver is still buggy…

  • @captainplanet said in Cnchi error - cannot find qt5-styleplugins:

    I selected all default options, picked Cinnamon desktop, and I ended up with this error. How come the auto-selected mirrors don’t have q5 packages?

    try the install again. this time when you get to the desktop CLOSE the installer. connect to the internet first thing without doing nothing else. after being connected use sudo pacman -Syyu wait to finish THEN open the installer and try again

  • @trytip said in Cnchi error - cannot find qt5-styleplugins:

    @captainplanet said in Cnchi error - cannot find qt5-styleplugins:

    I selected all default options, picked Cinnamon desktop, and I ended up with this error. How come the auto-selected mirrors don’t have q5 packages?

    try the install again. this time when you get to the desktop CLOSE the installer. connect to the internet first thing without doing nothing else. after being connected use sudo pacman -Syyu wait to finish THEN open the installer and try again

    as cowspace is little this will fail for sure, better only update database sudo pacman -Syy then reinstall cnchi to make sure it has the latest changes: sudo pacman -S cnchi but as long as cnchi, and antergos-common-meta is not fixed this will not help on installing … only if you do change packages.xml

  • Damn, I really joined in at the wrong time. Just when I wanted to try Antergos, the installer doesn’t work.

    So you are saying I should just wait till the fixes kick in?

  • @captainplanet
    Well if you really want to install now, it is possible as I explained above. Just some fiddling with packages.xml and you’re good to go.

  • @joekamprad said in Cnchi error - cannot find qt5-styleplugins:

    qt5-styleplugins

    is available over Antergos Repository now 🙄

    antergos-common-meta changed back as far as i understand, as long as it will not changed again…

  • @joekamprad
    Now a new package problem: gamin is moved to AUR, and the installer fails…

    A workaround (I think but didn’t test) is to remove gamin and xorg-mkfontdir from packages.xml (as outlined above).

    EDIT: the install works with the above workaround.

    https://github.com/Antergos/Cnchi/issues/1141

  • So is everything good now? Or should I wait a bit more before attempting install again?

  • @captainplanet
    Yes, it seems to be fixed now. I just installed Antergos with Xfce.

  • @captainplanet said in Cnchi error - cannot find qt5-styleplugins:

    So is everything good now? Or should I wait a bit more before attempting install again?

    if you keep getting errors you can always just choose the base install and add the desktop from the command line.

    i typically install base and install KDE after.

    let us know how it goes :)

  • @megaman

    But does adding desktops from command line also pull in the desktop customizations like search bars, battery indicators etc?

  • Now the installer can’t locate Vivaldi packages

  • @captainplanet
    Vivaldi AFAIK cannot be selected anymore, since it is removed from the Antergos packages. The installer will be fixed not to provide vivaldi no more, but it seems to take some time, probably the next installer release.

    Vivaldi is available from AUR, that may be easiest way to go for now.
    And @joekamprad may have a vivaldi package available at his repo, he probably will tell more about it.

error340 cncni1 Posts 18Views 701
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.