• Headphones recognised but produce no sound

    Hi everyone,

    Recently I installed Antergos-19.1 on my HP Omen laptop. Speakers work, but when I plug in headphones to audio jack, there is no sound produced at all. The output of the command pactl list sinks |& grep -E "Sink|Ports|analog-ou"

    Sink #0
        analog-output-speaker: Speakers (priority: 10000, not available)
        analog-output-headphones: Headphones (priority: 9000, available)
    Active Port: analog-output-headphones

    Therefore, as I understand, headphones are detected and is set to be active port. How to solve this problem?

    P.S. I have Windows 10 installed in my laptop too and headphones work there.

  • @karlos Maybe click on the volume control, sound settings, output, device and see if the headphones are listed there and and click on it to select and test sound. Maybe it’s just not switching when you plug them in? Just a thought?

  • Thanks @ricklinux and @joekamprad for your responses.

    The volume control has this view: Screenshot from 2019-03-28 17-29-21.png

    Headphones are visible, recognised and switched automatically.

    The following is alsamixer’s view:
    Screenshot from 2019-03-28 17-58-20.png

    If you have any idea what can I do to fix the problem, please let me know!!
    Thanks in advance.

  • @karlos in alsamixer you can press F6 may show your headphone as device?
    I do not know how the headphone is build… May it is a usb-soundcard-device, so it is handled as a soundcard seperate from internal one… Has it a headphone jack or is it connected via usb?

  • @joekamprad It is connected with headphone jack. The list of sound cards is:

    Screenshot from 2019-03-28 18-36-55.png

    This is displayed when default is selected.

    Screenshot from 2019-03-28 18-38-27.png

  • Most newer hardware has a multi function port that does mic and or headphone. Is your HP Omen like that? I notice on the picture you posted that it shows the headphones and internal mic enabled? Do you have a mice hooked up? Is there a mic port and a headphone port? or just one multi function port? Something is weird or it’s that simple that it’s hiding in plain site! Had you used headphones before on it? In Linux or Windows? Have you tried F1 and moved from one control to another? I’m not sure if there is any setting on this? Hmm? Either the hardware works or it doesn’t so it has to be something simple if that is the case.

  • @karlos Did you try clicking on the playback panel and change device there?

  • @karlos It seems from what i’m reading that the HP Omen cannot use the Headphones along with the Internal Mic. I have read a lot of different forums regarding headphones not working. A lot of users are making changes to the etc/modprobe.d/alsa-base.conf file but i don’t have the expertise to advise you. One user reported adding this line and it solved the issue.
    options snd-hda-intel model=laptop-amic

    Others have different stuff depending on the hardware etc. @joekamprad is probably better to advise you or someone else as i’m not sure that this is the problem or not and i’m not knowledgeable enough to advise you on this issue.

  • @karlos i do have an issue on getting no sound if i do have more then one device activated on configuration, so try to put all other then headphone to of here:

    Bildschirmfoto vom 2019-03-30 08-53-32.png

  • @ricklinux, my laptop has two ports, one- multifunctional with mic and headphone, the other is only for mic. I tried to disable my mic, but again there is no any sound in my headphone. As I mentioned, headphones are working perfectly in windows 10

    @joekamprad, in the list of output devices, there are two ports when my headphones are plugged in. One is headphones (displayed in screenshot) and speakers that show “unavailable”. Screenshot from 2019-04-01 00-30-11.png

    The configuration screen is below. The “Profile” has four options but selection one of them does not change anything. That options are: “Analog Stereo Duplex”, “Analog Stereo Input”, “Analog Stereo Output”, “Off”.
    Screenshot from 2019-04-01 00-34-35.png

    Additionally, here what the “Playback” tab displays:
    Screenshot from 2019-04-01 00-35-37.png

sound62 headphones8 recognised1 produce1 Posts 11Views 88
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.