• VirtualBox (Oracle) fails to start on Kernel 4.19.31 LTS


    My VirtualBox works fine on Kernel 5.0.4 (after installing linux-headers…) but fails to start on my 4.19.31 LTS kernel.
    I tried to install linux-headers while i’m using kernel 4.19.31, but it always refers to/as linux-headers are already installed and up to date on kernel 5.0.4. ???

    I tried using these 2 commands and here’s the result i get on the terminal (picture) :

    • sudo pacman -Syyu
    • sudo /sbin/rcvboxdrv setup

    2019-03-26_10-29.png

  • @philipc
    What have you installed:

    pacman -Qs virtualbox
    

    You need at least:

    sudo pacman -S linux-lts-headers
    
  • @manuel said in VirtualBox (Oracle) fails to start on Kernel 4.19.31 LTS:

    linux-lts-headers

    this must be installed… for sure…

  • I installed linux-lts-headers but still fails to start, virtual box gives error message after i rebooted my pc :
    2019-03-26_16-24.png 2019-03-26_16-25.png

  • for other kernels (like LTS) choose virtualbox-host-dkms instead of virtualbox-host-modules-arch as it will build modules for both kernels if they get updated automatically.
    https://antergos.com/wiki/system-admin/virtualization/how-to-install-virtualbox/

  • @joekamprad
    Thanks, i will try this out tonight! 👍

  • @joekamprad

    I followed the instructions and reinstalled VirtualBox trought the terminal, but i was not ask for installing the core package, so i could not choose VIRTUALBOX-HOST-DKMS.
    I don’t know how to choose this option.

    2019-03-26_17-50.png 2019-03-26_17-51.png

  • @joekamprad said in VirtualBox (Oracle) fails to start on Kernel 4.19.31 LTS:

    virtualbox-host-dkms

    sudo pacman -S virtualbox-host-dkms

  • @joekamprad
    Yes i found it in pamac and installed VIRTUALBOX-HOST-DKMS and VirtualBox is now working fine on my LTS kernel!

    Much thanks! ☺ 👍

kernel152 fails52 virtualbox47 oracle4 Posts 10Views 66
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.