• Dualboot Windows 7 - Can't boot Antergos


    Hello everyone,

    I am trying to install Antergos next to Windows 7 Professional.
    Something went wrong during the installation and whenever I start my computer it boots into Windows 7 and I can’t boot into Antergos even if antergos_grub has the highest boot priority. In the following I will explain exactly what I did:

    I followed the tutorial that was recommended during the installtion but I had to vary from the instructions at one point: The tutorial recommends to set the path of boot/efi to ESP partition that already exists and is used by windows. Unfortunately this partition does not exist in my system. I just had:

    1. Windows7_OS(C:) - 134 GB
    2. SYSTEM_DRV - 2,10 GB

    I googled a bit and figured out that I do not even need a boot/efi partition on my system. But because I couldn’t proceed with the installation without having boot/efi, I decided to just create this boot/efi partition for Linux.

    I reserved 340 MB for it and chose fat32 for its type. I also created a partition for root (15GB, primary, ext4), /home (20GB) and one for swap (4GB). I chose Grub2 as the bootloader. Because I couldn’t create any more primary partitions, root is the only primary partition and swap, boot/efi and /home are placed in an extended partition. If you need any more information I will happily provide it.

    I know that I didn’t reserve much storage for the home directory and root so far but my plan is to get used to Antergos and then reduce the Windows partitions and give this space to Antergos.

    Now I can see all this partitions after booting into Windows but I just can’t boot Antergos. Does anyone know what went wrong and how to fix that?

    It will be great if anyone can help me!

    Best regards,

    David

  • @david-0 I installed recently Antergos next to Windows 7 and it is working, so there is hope. What kind of disk do you have, MBR/BIOS or GPT/UEFI? I had MBR/BIOS. Also can you post the picture of your disk partition?

  • Thanks for your answer!

    I have an MBR/BIOS system.

    My disk looks like that:

    Screenshot from 2019-03-21 10-12-03.png

    I took this picture after booting in Antergos Live.

    Did you also create a boot/efi partition?

  • @david-0 said in Dualboot Windows 7 - Can't boot Antergos:

    I have an MBR/BIOS system.

    Why do you install EFI system then?
    EFI have grub installed on a partition, BIOS/MBR installs grub at the MBR of a disk…

  • @joekamprad said in Dualboot Windows 7 - Can't boot Antergos:

    Why do you install EFI system then?

    Thanks for you answer.
    I am very sorry, but I have no clue about how operating systems work in respect thereof.

    So what do I have to do to make it work properly?

  • reinstall Antergos, but first, erase all the partitions you have created for it…
    Bildschirmfoto vom 2019-03-21 09-38-15.png
    then just create two partitions: swap (same size as your installed RAM) and root [/] (rest of space, will hold home directory then under it) if you want to have /home on a separate partition create this too… but to try out it is not necessary…

    you can do this inside installer when you reach partition slide… and make sure to not erase the two first partitions on the disk as they are from your windows system!!

  • @david-0
    Joe is right, you don’t want to add EFI/UEFI stuff (like /boot/efi) on your BIOS Legacy system.

    But to make sure that your machine does not support UEFI:

    • how old is the machine?
    • did you simply choose to use /boot/efi or did the installer ask for it?
    • if you boot to BIOS (press F2 or similar immediately at boot), can you see any settings for UEFI?

    As an advanced tip, you can use swap file instead of swap partition. See https://wiki.archlinux.org/index.php/Swap#Swap_file for more. Swap (either way) is optional but recommended if you have less RAM than about 6-8 GB.

  • Thank you!

    I tried it but I can’t proceed with the installation if I do not choose a /boot/efi partition. That’s where I can’t proceed:
    Screenshot from 2019-03-21 09-01-13.png

    When I click the arrow in the top right corner to continue with the next step nothing happens. If I do choose /boot/efi I can continue.

  • @david-0 so looks like windows-7 is installed on a EFI system in legacy mode… and also looks like installer have a BUG as it want to use EFI but provides to install Grub on MBR of /dev/sda

  • @david-0
    Could you show the output of commands

    sudo fdisk -l
    lsblk -fm
    

    And make really sure your machine BIOS/firmware does or does not support UEFI.

  • @david-0 : Did you also create a boot/efi partition?

    Unfortunately I do not remember, and I do not have access to the computer right now. I will be able to come up with an answer only later today.

    I installed Antergos about three months ago, so I do not remember all the details. What I do remember is that many things were already imposed by the installer, so I think you are right when you say that you must choose /boot/efi for the installer to continue.

    When did you install Windows 7? How old and what kind of computer do you have?

  • @manuel

    • I am using a Lenovo T430 which was released in 2012.
    • I can’t proceed with the installation if I do not choose any boot/efi/.
    • I can i.e. choose to boot UEFI only, but then I need to choose a boot device and can`t boot into windows or linux whatever I choose.

    sudo fdisk -l
    Screenshot from 2019-03-21 09-32-41.png

    lsblk -fm
    Screenshot from 2019-03-21 09-33-08.png

  • @joekamprad
    That sounds great. Do you have any advice for me?

  • @david-0

    Don’t panic! I will post later today (as I said earlier, I do not have access to the computer right now) my partition structure, which you can emulate. As far as I can remember I had the same problems three months ago and I could solve them.

    My computer is about the same age and also MBR/BIOS, so it should work!

  • @david-0
    How did you burn the installed USB stick?
    The preferred programs are:

    • dd on Linux
    • etcher on Windows

    Your stick has gpt partition table. That probably explains why it tries to boot in UEFI mode.
    And your motherboard probably supports both UEFI and BIOS Legacy boot.

    So, burn the stick again with a program listed above, and reinstall Antergos.
    You should install Antergos in BIOS Legacy mode because of your Windows 7 installation.

  • @manuel
    I used Rufus.
    Alright, I will burn it again using etcher.

    How do I install Antergos in BIOS Legacy mode?

  • @david-0
    Rufus may work too, but needs to be configured exactly right (DD mode).
    But etcher is known to work without additional configurations.

    To install, it depends on the successful boot. As your machine seems to be able to boot in either mode, you must select the BIOS mode in machine’s BIOS/firmware, then installer should boot in BIOS mode. Then you should not see anything related to /boot/efi. But if you see the /boot/efi in the Checklist, installer has booted in the wrong mode, try booting again with different settings.

    If the installer boots OK in BIOS mode, then select suitable partitions for Antergos when asked, shouldn’t cause any trouble. You may want to have only one partition (root or /) for Antergos, since a swap file can be created later, after install. And let the installer overwrite the MBR of /dev/sda (Windows had written it earlier), otherwise Windows remains in control of booting.

    BTW, if you wish to keep Windows, I strongly suggest you make a WIndows recovery disk (or whatever the term is in Windows). With that disk you are able to rewrite Windows MBR if needed.

    And, before doing anything, make sure you have backups of your personal data on some external drive. Any error can occur during install or its preparations, and hence the whole disk may be wiped.

    BTW, I know Windows is able to boot Antergos with some arrangements, but that is out of scope of this forum.

  • @manuel
    Thank you, that sounds like a plan!

    @manuel said in Dualboot Windows 7 - Can't boot Antergos:

    And let the installer overwrite the MBR of /dev/sda (Windows had written it earlier), otherwise Windows remains in control of booting.

    Which partition do you mean? The one that is labeled SYSTEM_DRV? Should I just delete it?

    I did also backup all my files and created a Windows recovery disk.

    @manuel said in Dualboot Windows 7 - Can't boot Antergos:

    To install, it depends on the successful boot. As your machine seems to be able to boot in either mode, you must select the BIOS mode in machine’s BIOS/firmware, then installer should boot in BIOS mode. Then you should not see anything related to /boot/efi.

    That worked, awesome! Now I do not need to select a /boot/efi partition anymore.

  • @david-0

    Do not delete the partition SYSTEM_DRV, or else you can forget about Windows 7! It seems that is the Windows 7 system partition and is needed!

    So here are the steps I would recommend in case you still did not make it work. What I describe is what I made when I installed Antergos. As I said, my system is MBR/BIOS.

    1. Backup your Win 7 system and also the MBR, which are the first 512 Bytes of your drive; you can backup the MBR (in a file) using the dd command - just do an internet search for the exact command syntax.

    2. Delete previous partitions except the Windows ones and make the following partions during installation (partition 1 is your Win 7 system, partition 2 is Windows 7):

    • an ESP Partition 3, 512 MB (FAT 32): this you will assign to /boot/efi;
    • an extended Partition 4, under which you make Partitions 5 and 6;
    • Antergos Root Partition 5 (Ext 4);
    • Antergos Swap Partition 6 (Swap);
    1. Continue with the installation.

    2. After reboot you should see the Antergos Menu.

    I hope this helps. I must also mention that I used Etcher to make the bootable USB stick.

boot310 windows68 dualboot14 Posts 21Views 171
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.