• How can I change the keyboard? \[SOLVED\]


    Installation of IBUS or running it for the first time changed my Japanese keyboard to an English one. I searched for (settings / input devices) but did not find yet a possibility to change the keyboard.

    Question:
    Can I change the keyboard from English to Japanese without re-installing Antergos?
    If yes, how can a change the keyboard?

  • Installation of IBUS or running it for the first time changed my Japanese keyboard to an English one. I searched for (settings / input devices) but did not find yet a possibility to change the keyboard.

    Question:
    Can I change the keyboard from English to Japanese without re-installing Antergos?
    If yes, how can a change the keyboard?

  • Hi,

    You should be able to change it using your installed DE’s system settings tools.

    GNOME = System Settings>>Keyboard
    Cinnamon = Cinnamon Settings>>Keyboard>>Keyboard Layouts
    Xfce = Settings>>Keyboard>>Layout

    If that does not work there are instructions to configure it using the command line here:

    [https://wiki.archlinux.org/index.php/Keyboard_configuration_in_Xorg#Setting_keyboard_layout][0]">[https://wiki.archlinux.org/index.php/Ke][1] … ard_layout

    Let me know if you get it working. Cheers!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Ke

  • Thanks for your help!!! Problem seems to be solved. “seems to be” because I cannot yet test a few keys, which only work while writing Japanese.

    I am using KDE, but the 3 examples you explained in details made me looking again into

    System settings > Input devices > Keyboard > tab: layout

    The trick is to check “configure layout” (until now I hesitated to check the field to not mess up things more).

    :exclamation:Sorry, this attachment is unavailable.

    The keyboard layout image for the Japanese (ODAG 109A) does not exactly match the keyboard layout of my Japanese version of Thinkpad x240. However, if there is interest I am willing provide a picture and the Japanese characters printed on some keys. Please advice.

  • I have not used KDE as my primary desktop in quite some time so I could not remember where the setting was located (so I just posted what I knew for sure) I’m glad it helped. As far as the missing keys, if you are sure that there isnt a variant of the keyboard that would work 100% I recommend reporting the bug upstream. I’m not sure if it would fall under KDE or Xorg developers though

  • Pro Tip: KDE is very advanced in (I think) every possible way. If You have no idea where to find some settings or options in “settings” menu, just open the main page and start typing what are you looking for. In this case typing “keyboard” or “layout”.
    This will shade icons, that have nothing to do with thing You are asking for.

  • …if you are sure that there isnt a variant of the keyboard that would work 100% I recommend reporting the bug upstream.

    As soon as I am ready to make a full test (Japanese) I will put needed information together.

    The keyboards I am using are the buit-in Japanese keyboard of the Lenovo Thinkpad x240 and the (external) IBM Rapid Access Keyboard, Japanese version. First I try to get all working using the built-in keyboard.

    … open the main page and start typing what are you looking for …

    This is indeed an interesting functionality of KDE, which, from now on I will use more often.

    I decided to use Antergos KDE on recommendation of my IT wizard younger brother. I read more about KDE and feel that the Plasma activities seems to be an excellent approach to the work I have to do. But as I am a newbie, I might post quiet some questions on the KDE DE …

Posts 7Views 1736
Log in to reply