• Gnome Shell causing high CPU usage


    /usr/bin/gnome-shell is causing continuous high CPU usage on one core at boot and on idle.

    gnome-shell 1:3.32.0+16+g1341d5557-1 17/03/19

  • Could you give us your hardware info, because you’re running into specific bugs in Gnome 3.32.

  • @Bryanpwo Hi, is that my general setup or do you want me to post the output from a specific terminal command?

  • No, I’m asking for your computer specs: like intel or AMD cpu and type, which kind of video graphics etc.

  • @Bryanpwo OK

    AMD® Fx™-6300 six-core processor × 6
    GeForce GTX 650 Ti/PCIe/SSE2
    8 GB Ram
    120 GB SanDisk SDSSDA120G (Z32080RL)

    Antergos Linux 64-bit
    Kernal 5.0.2
    Nvidia 417.43-7

    Continuous 100% CPU usage on one core attributed to /usr/bin/gnome-shell. Fluctuates between cores.

  • Try to see how your performance is, when you disable the Nvidia driver. (I know it’s blasphemy, but just try it for testing purposes.)

  • Not sure how to do that, Is it easy to do? Whenever I’ve messed with graphics drivers in the past (without really knowing what I’m doing) it’s ended in a right mess.

  • I used nvidia-installer to install the drivers

  • Just type in the next command in the terminal:

    sudo nvidia-installer -n
    

    Then reboot the machine.

  • OK. I ran that command. It removed nvidia and installed the nouveau drivers. Antergos now boots to a blank screen with flashing cursor (same in fallback)

  • Okay, I think the easiest way for you now, is to start Antergos live from the live usb (another distro does the job as well) and use chroot.

    Just open the terminal in the Live environment and type in:

    sudo fdisk -l
    

    Your partitions will show up then type in:

    sudo su
    

    And type

    mount /dev/sdXN /mnt
    mount /dev/sdXN /mnt/boot
    mount /dev/sdXN /mnt/boot/efi
    
    arch-chroot /mnt
    

    Note that the XN I typed should be your specific extension, for example sda1 etc. The first entry should be you root partition.

    Then install the nvidia drivers by the command

    sudo nvidia-installer
    

    then close down the live usb and boot the system.
    I’m leaving within a couple of minutes, just post back if it works and I will get back to you soon.

  • I already booted into a command line and reinstalled nvidia. Everything working again.

  • Have you by chance installed the topicon extension, this is causing high cpu usage in Gnome 3.32 and should be switched off.

  • @Bryanpwo Hurray, well spotted. I just turned off topicons plus and it’s fixed the CPU usage problem. Thanks a lot.

  • KStatusNotifierItem/AppIndicator Support seems to be a good replacement for Topicons Plus, although the dropbox menu doesn’t seem to be fully functional.

  • @anivegmin said in Gnome Shell causing high CPU usage:

    Topicons Plus

    https://github.com/phocean/TopIcons-plus/issues/91

    but the package from Antergos Repository seems outdated also… as some users reporting latest version from github is working with latest GNOME shell

gnome355 shell18 high6 causing4 Posts 16Views 302
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.