• Gnome 3.32 Updated - Computer Fails To Resume From Suspend


    Hello Everyone,

    I recently updated to Gnome 3.32, and now my XPS 13 (9350) fails to resume from suspend. It looks like it tries for a few seconds, then starts a new session for some reason.

    Anyone else seeing this issue? I’m assuming this is due to one of the dependent packages also getting updated.

    Any help would be greatly appreciated. TIA!

    Thanks,
    Asif

  • using GDM as displaymanager ?

  • And also did you reboot the computer after the update?

  • @a4orce84 Well, I am not running antergos but Arch Linux and I am experiencing the same issue you describe on my ThinkPad T450. Unfortunately, I haven’t been able to find a workaround or solution for it.
    But it seems to be an issue with gnome-shell and/or mutter.

  • @ringo32 said in Gnome 3.32 Updated - Computer Fails To Resume From Suspend:

    using GDM as displaymanager ?
    I am using GDM, correct.

    @Bryanpwo said in Gnome 3.32 Updated - Computer Fails To Resume From Suspend:

    And also did you reboot the computer after the update?
    I’ve rebooted several times.

    @Summerer said in Gnome 3.32 Updated - Computer Fails To Resume From Suspend:

    @a4orce84 Well, I am not running antergos but Arch Linux and I am experiencing the same issue you describe on my ThinkPad T450. Unfortunately, I haven’t been able to find a workaround or solution for it.
    But it seems to be an issue with gnome-shell and/or mutter.

    Disappointing, surprisingly Hibernate still works for me.

    Please let me know if I can provide any additional details to help troubleshoot!

    Thanks!

  • @a4orce84 I don’t know if this could help, but I noticed your behaviour when I closed my laptop lid and when I opened it back, it looked like it rebooted the pc instead of just resuming.
    What did it for me was going into my laptop bios, disabling the option ‘wake on lid open’ (it should be active by default), saving and exiting the setup, and on the next reboot enabling again the same option. Since then my pc hasn’t had any issues with suspension, so this maybe will help you!

  • I opened an issue regarding this with the gnome-shell/mutter devs here for anyone interested.

  • Just wanted to bump this up.

    I read through the comments but it looks like there is still no official fix yet for this issue?

    Thanks again!

  • in discussion there is some talk too in dte wiki

  • I’m using the latest BIOS, this issue started after the Gnome 3.32 shell upgrade and is definitely tied to that according to the links that Summerer posted around gnome-shell and mutter.

    I did not have this issue prior to Gnome 3.32 shell update.

  • bummer, my wrong :) already tested to leave all extentions out ?

  • Yes, again just looking for a general update on the issue that has already been identified. No troubleshooting needed at this point.

  • @a4orce84 I don’t know if you have the bios option “wake on lid open”, I previously stated that disabling that option and enabling it again solved this issue for me. Unfortunately, the issue reappeared after some days, and I have now disabled that option. Since then I have to press a button after suspension (it doesn’t wake when I open the lid obviously), but in return my pc resumes from a suspension just fine, both from closing the lid and from the menu. So, if you can, try that. Hope this helps!

gnome361 fails52 updated14 3.327 Posts 14Views 355
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.