• gnome-terminal and nautlius issues


    after the 3.32 upgrade gnome-terminal and nautilus are not active when you launch them until you click in them. This makes no sense to me, I would expect that if I launched something it should be active so that I can type in it. Other programs behave as expected. Anyone else seeing this? Anyone know how to fix it?

  • Yes, I also have this problem, but the entire Gnome update didn’t arrive completely yet. The updates are still coming in.

  • @Bryanpwo hopefully an update will fix this issue

  • Same here. Bit annoying but …we wait and see.

  • @galvez_65 said in gnome-terminal and nautlius issues:

    gnome-terminal and nautilus are not active when you launch them until you click in them

    yes this is not a feature, this is a bug ;)

  • Todays gnome updates (mutter, Gnome shell and some others) solved the problem.

  • Corrections: it only solved the Nautilus problem.

    Forget what I said, it only works the first two times, after a while Nautilus opens unfocused and you have to click in it to make it work.

  • @Bryanpwo yep just updated this morning and Nautilus and gnome-terminal still open unfocused

  • I wonder whether it’s a Antergos things or an Gnome things. I have Arch/Gnome, and it doesn’t have this problem. Till now, terminal is still not focus upon open. It’s annoying.

  • I’d say it’s probably local - it is highly annoying so there should have been lot’s of reports on that everywhere.

    I can report that changing focus-new-windows value to “strict” in org -> gnome -> desktop -> wm -> preferences
    has no effect on the problem. Did not expect it to do but gave it a try just in case.

  • I wonder where is the right place to report issues. It seems this is completely ignored.

  • @elgs1980 https://github.com/Antergos is for BUG reports…
    But i do have exactly the same at a pure Archlinux GNOME install.

    https://bbs.archlinux.org/viewtopic.php?id=244989

  • Yes, this is clearly a Gnome issue, although over here Nautilus is fixed.

  • @Bryanpwo I’m still having issues with both nautilus and gnome-terminal. This is very annoying

  • @galvez_65 Yep same here, highly annoying every time I open a terminal. Maybe the point release in a couple of weeks will fix it?

  • @galvez_65
    The terminal still opens unfocused, but Nautilus opens focused in my system. I don’t know when exactly it got fixed, but I’m pretty sure it was somewhere towards the end of last week. Have you reboot your machine?

  • @Bryanpwo both still unfocused for me. reboots and all.😖

  • Giving wayland a try. At first glance opening gnome-terminal and nautilus they open with the appropriate focus. Not sure what issues wayland will bring at this point, hopefully it’s finally mature enough to try as my daily driver

  • @galvez_65
    That’s interesting to learn, on the other hand; Gnome is pushing Wayland as if it is the best invention since sliced bread, so your outcome isn’t that surprising when you think about it.

  • you can change /org/gnome/desktop/wm/preferences/focus-mode to sloppy, what will give focus to windows when you reach them with mouse cursor…

    Bildschirmfoto vom 2019-03-30 11-50-12.png

issues100 gnome-terminal6 nautlius1 Posts 28Views 409
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.