• how do I get rid of the applications menu?


    updated to gnome-shell 3.32 and now the application menu, which was supposed to be gone on this build are back. Gnome-tweak also doesn’t seem to be able to get rid of them. How do I get rid of them?

  • Try to switch off the extensions menu in the Gnome tweaktool and switch it on again, then switch off the application menu.

  • @Bryanpwo tried that multiple times doesn’t seem to be working. Is it working for you?

  • yes, it does and the application menu doesn’t show up by default either over here. The Gnome shell did have an update a couple of hours ago, have you installed that one?

  • @Bryanpwo I am running versoin 1:3.32.0+15+gb7d79a5f0-1
    From the tweak tool I turned off the extensions, turned them back on and then turned off application menu. logged off and logged back in and the menu is still there. The application menu is currently set to off, but they are still present.

  • Did you also restart your computer? Gnome shell needs a reboot to finalize the update.

  • @Bryanpwo no I didn’t reboot only log out and back in, I will give that a try

  • @Bryanpwo rebooting didn’t change anything, does anyone know what the tweak tool is actually changing when we turn off the application menu? I’l like to verify that the setting is actually changing but I can’t seem to find anything in dconf that looks relevant

  • @galvez_65
    Try org/gnome/shell/enabled-extensions in dconf!

  • @new2antrgs looked there nothing looks like it would change the application menu

  • @galvez_65
    Which gnome shell extensions are you running?

  • i can see … it is under top bar settings, it do not make a difference to activate or disable it it shows up anyway
    have nothing to do with extensions, i do remove them all exept dash to dock and the unremovable pamac extension

  • That’s strange, this is how my default Gnome look like:

    Schermafdruk van 2019-03-18 09-57-55.jpg

  • And this is the modified one, the applications menu doesn’t show.

    Schermafdruk van 2019-03-18 10-06-08.jpg

  • @Bryanpwo said in how do I get rid of the applications menu?:

    And this is the modified one, the applications menu doesn’t show.

    Schermafdruk van 2019-03-18 10-06-08.jpg

    I like the way your gnome set up looks like, i need this too :)

  • @Bryanpwo are you using dash-to-panel extension?
    it is replacing the default panel as far as i can see, so it do not have the appmenu ;)

  • These are my extensions from my set up:

    Panel: Dash to panel
    Icons: Sardi icons (it problably will get updated soon, because some icons are overwritten by the Gnome icon set under Gnome 3.32)
    Gnome shell theme and theme: United archers. (There’s also an Antergos set included)
    Openweather extension on the left.
    Next to the openweather extension is Freon ( it isn’t working properly at the moment, but I thin it will get fixed soon.)

    Not showing: Gnome dash fix
    This organizes the applications into groups.

  • Gnome dash fix looks like this (it’s a screenshot from a video, hence the double taskbar)

    Gnome dash fix.jpg

    You can install it by doing this:

    git clone https://github.com/BenJetson/gnome-dash-fix
    cd gnome-dash-fix
    
    sudo chmod +x interactive.py
    sudo chmod +x appfixer.sh
    
    python3 interactive.py
    

    Then follow the instructions on your terminal.

  • @Bryanpwo said in how do I get rid of the applications menu?:

    Gnome dash fix

    this should be the default view for apps ;)

  • @joekamprad
    The first image I submitted is the default Gnome set up, without the extensions

menu48 applications35 rid3 Posts 44Views 307
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.