• \[Solved\] sleepy (external) mouse (random)


    Dear all,

    I have some sort of sleepy mouse effect which seems to occur rather randomly but often. I have a laptop sitting in a docking station connected to a wireless keyboard / mouse combo from Logitech (K340).

    When booting the laptop in the dock, often the mouse seems very sleepy, meaning it goes unresponsive after a short time and needs be waken up by moving it back and forth a few times. This is already the case on the login screen, so I guess has nothing to do with the DE (I’m using gnome-shell as well as cinnamon). This get’s usually fixed by reboots however it often takes a few.

    The issue does not occur with the built-in touch pad and does not occur when booting in the the LMDE installation. So I don’t think it’s a problem with the hardware of the mouse.

    I have no idea where to look for a solution are to at least narrow down on the core of the problem. Maybe I just need to restart some system service or make sure it starts earlier or later …

    Any ideas would be greatly appreciated.

    Cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Dear all,

    I have some sort of sleepy mouse effect which seems to occur rather randomly but often. I have a laptop sitting in a docking station connected to a wireless keyboard / mouse combo from Logitech (K340).

    When booting the laptop in the dock, often the mouse seems very sleepy, meaning it goes unresponsive after a short time and needs be waken up by moving it back and forth a few times. This is already the case on the login screen, so I guess has nothing to do with the DE (I’m using gnome-shell as well as cinnamon). This get’s usually fixed by reboots however it often takes a few.

    The issue does not occur with the built-in touch pad and does not occur when booting in the the LMDE installation. So I don’t think it’s a problem with the hardware of the mouse.

    I have no idea where to look for a solution are to at least narrow down on the core of the problem. Maybe I just need to restart some system service or make sure it starts earlier or later …

    Any ideas would be greatly appreciated.

    Cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • There is a config file somewhere for usb “auto suspend” (or something similar to that, not sure what its called…let me check and I’ll get back to you)

    [b:3oj9jwuh]Update:[/b:3oj9jwuh] Here it is: [https://wiki.archlinux.org/index.php/Power_saving#USB_autosuspend][0]">[https://wiki.archlinux.org/index.php/Po][1] … utosuspend

    Let me know if it helps

    Best Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Po

  • Thanks for your answer, unfortunately, no improvement. But maybe I just screwed up the udev rules being a complete udev noobie. These are the usb devices listed when the machine is docked:

    \> lsusb  
    Bus 002 Device 005: ID 1058:0810 Western Digital Technologies, Inc. My Passport Ultra  
    Bus 002 Device 003: ID 413c:2513 Dell Computer Corp. internal USB Hub of E-Port Replicator  
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub  
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
    Bus 001 Device 004: ID 0c45:648b Microdia Integrated Webcam  
    Bus 001 Device 003: ID 413c:8197 Dell Computer Corp.   
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub  
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
    Bus 004 Device 002: ID 413c:5534 Dell Computer Corp.   
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub  
    Bus 003 Device 007: ID 046d:c52b Logitech, Inc. Unifying Receiver  
    Bus 003 Device 006: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub  
    Bus 003 Device 005: ID 046d:c50e Logitech, Inc. Cordless Mouse Receiver  
    Bus 003 Device 004: ID 10d5:5552 Uni Class Technology Co., Ltd KVM Human Interface Composite Device (Keyboard/Mouse ports)  
    Bus 003 Device 003: ID 04cc:1520 ST-Ericsson USB 2.0 Hub (Avocent KVM)  
    Bus 003 Device 002: ID 413c:2134 Dell Computer Corp.   
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
    
    

    I first blacklisted everthing which is “Logitech”. When that didn’t help, I also blacklisted all devices which are not present when the machine in undocked and are not obviuosly something else (like usb drive or something). The usb hub and port switcher listed don’t use the Logitechs. They are directly connected to the port replicator.

    This is how the rules file looks like:

    \> cat /etc/udev/rules.d/50-usb\_power\_save.rules  
    \# try to fix sleepy mouse issue when docked  
    \# location /etc/udev/rules.d/50-usb-power\_save.rules  
    \# source: https://wiki.archlinux.org/index.php/Power\_saving\#USB\_autosuspend  
      
    \# blacklist for usb autosuspend Logitech wireless mouse / keyboard  
    \#\> lsusb | grep Logitech  
    \# Bus 002 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver  
    \# Bus 003 Device 005: ID 046d:c50e Logitech, Inc. Cordless Mouse Receiver  
      
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="046d", ATTR{idProduct}=="c52b", GOTO="power\_usb\_rules\_end"  
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="046d", ATTR{idProduct}=="c50e", GOTO="power\_usb\_rules\_end"  
      
    \# in addition blacklist from autosuspend all USB devices only present when docked; and obviously NOT ext. mouse related  
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="413c", ATTR{idProduct}=="2513", GOTO="power\_usb\_rules\_end"  
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="413c", ATTR{idProduct}=="5534", GOTO="power\_usb\_rules\_end"  
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="413c", ATTR{idProduct}=="2134", GOTO="power\_usb\_rules\_end"  
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="10d5", ATTR{idProduct}=="5552", GOTO="power\_usb\_rules\_end"  
      
    \# allow all others to autosuspend  
    ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control", ATTR{power/control}="auto"  
    LABEL="power\_usb\_rules\_end"  
    
    

    does that look principally OK? Same sleepiness, though.

    Thanks!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Hi again,

    the “autosuspend” sent me into the right direction. Looks like the laptop-mode package auto-suspended my mouse!

    I added an usb-autosuspend.conf to laptop-mode and blacklisted the Logitech devices:

    \> cat /etc/laptop-mode/conf.d/usb-autosuspend.conf  
    \#  
    \# Configuration file for Laptop Mode Tools module usb-autosuspend.  
    \#  
    \# For more information, consult the laptop-mode.conf(8) manual page.  
    \#  
    \# source: http://fitzcarraldoblog.wordpress.com/2013/02/26/how-to-prevent-a-usb-mouse-auto-suspending-in-linux-when-a-laptops-power-supply-is-disconnected/   
      
    \#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#  
    \# USB autosuspend settings  
    \# ------------------------  
    \#  
    \# If you enable this setting, laptop mode tools will automatically enable the  
    \# USB autosuspend feature for all devices.  
    \#  
    \# NOTE: Some USB devices claim they support autosuspend, but implement it in a  
    \# broken way. This can mean keyboards losing keypresses, or optical mice turning  
    \# their LED completely off. If you have a device that misbehaves, add its USB ID  
    \# to the blacklist below and complain to your hardware vendor.  
    \#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#  
      
    \# Enable debug mode for this module  
    \# Set to 1 if you want to debug this module  
    DEBUG=0  
      
    \# Enable USB autosuspend feature?  
    \# Set to 0 to disable  
    CONTROL\_USB\_AUTOSUSPEND="auto"  
      
    \# Set this to use opt-in/whitelist instead of opt-out/blacklist for deciding  
    \# which USB devices should be autosuspended.  
    \# AUTOSUSPEND\_USE\_WHITELIST=0 means AUTOSUSPEND\_\*\_BLACKLIST will be used.  
    \# AUTOSUSPEND\_USE\_WHITELIST=1 means AUTOSUSPEND\_\*\_WHITELIST will be used.  
    AUTOSUSPEND\_USE\_WHITELIST=0  
      
    \# The list of USB IDs that should not use autosuspend. Use lsusb to find out the  
    \# IDs of your USB devices.  
    \# Example: AUTOSUSPEND\_USBID\_BLACKLIST="046d:c025 0123:abcd"  
    AUTOSUSPEND\_USBID\_BLACKLIST="046d:c52b 046d:c50e"  
      
    \# The list of USB driver types that should not use autosuspend. The driver  
    \# type is given by "DRIVER=..." in a USB device's uevent file.  
    \# Example: AUTOSUSPEND\_USBID\_BLACKLIST="usbhid usb-storage"  
    AUTOSUSPEND\_USBTYPE\_BLACKLIST=""  
      
    \# The list of USB IDs that should use autosuspend. Use lsusb to find out the  
    \# IDs of your USB devices.  
    \# Example: AUTOSUSPEND\_USBID\_WHITELIST="046d:c025 0123:abcd"  
    AUTOSUSPEND\_USBID\_WHITELIST=""  
      
    \# The list of USB driver types that should use autosuspend. The driver  
    \# type is given by "DRIVER=..." in a USB device's uevent file.  
    \# Example: AUTOSUSPEND\_USBTYPE\_WHITELIST="usbhid usb-storage"  
    AUTOSUSPEND\_USBTYPE\_WHITELIST=""  
      
    \# Trigger auto-suspension of the USB deivce under conditional circumstances  
    BATT\_SUSPEND\_USB=1  
    LM\_AC\_SUSPEND\_USB=0  
    NOLM\_AC\_SUSPEND\_USB=0  
      
    \# USB Auto-Suspend timeout in seconds  
    \# Number of seconds after which the USB devices should suspend  
    AUTOSUSPEND\_TIMEOUT=
    

    This is the crucial piece:

    \# Example: AUTOSUSPEND\_USBID\_BLACKLIST="046d:c025 0123:abcd"  
    AUTOSUSPEND\_USBID\_BLACKLIST="046d:c52b 046d:c50e"  
    
    

    Tried a few reboots and shutdown-restarts and haven’t had a problem yet. I’ll keep observing for a few days and mark this thread as [Solved] it is persists.

    The original reference I used:

    [url:1ozomlae]http://fitzcarraldoblog.wordpress.com/2013/02/26/how-to-prevent-a-usb-mouse-auto-suspending-in-linux-when-a-laptops-power-supply-is-disconnected/[/url:1ozomlae]

    Cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • I guess, I got excited too early - mouse is still sleepy at times …

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • After looking at your udev rules again I noticed that your rules for the logitech devices are missing this:[code:1cyumigi]ATTR{power/control}=“on”[/code:1cyumigi]The possible values of that field are auto, on, and off. From what I can tell

    “auto” lets the system decide
    "on" though I am confused at the logic, multiple users say that this setting disables autosuspend.
    “off” no power controls

    Best Regards,

  • Heya Dustin,

    it’s looking good for now! With several restarts the mouse was always wide awake!
    I’ll observe for a few more days but hope this is solved now. The udev rules file now looks like this:

    \> cat /etc/udev/rules.d/50-usb\_power\_save.rules  
    \# try to fix sleepy mouse issue when docked  
    \# location /etc/udev/rules.d/50-usb-power\_save.rules  
    \# source: https://wiki.archlinux.org/index.php/Power\_saving\#USB\_autosuspend  
      
    \# blacklist for usb autosuspend Logitech wireless mouse / keyboard  
    \#\> lsusb | grep Logitech  
    \# Bus 002 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver  
    \# Bus 003 Device 005: ID 046d:c50e Logitech, Inc. Cordless Mouse Receiver  
      
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="046d", ATTR{idProduct}=="c52b", ATTR{power/control}="on", GOTO="power\_usb\_rules\_end"  
    ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="046d", ATTR{idProduct}=="c50e", ATTR{power/control}="on", GOTO="power\_usb\_rules\_end"  
      
    \# allow all others to autosuspend  
    ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control", ATTR{power/control}="auto"  
    LABEL="power\_usb\_rules\_end"  
    \>   
    
    

    Thanks and cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Hi again,

    issues seems to be solved now.

    @“lots.0.logs”:1dzqpm30 said:

    [code:1dzqpm30]ATTR{power/control}=“on”[/code:1dzqpm30][/quote:1dzqpm30]

    This was the missing piece.

    Thanks again and cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

Posts 9Views 1936
Log in to reply