• Antergos Installation with UEFI


    Hi all,
    I have some problems with installing antergos on my machine:
    I have successfully installed antergos with a legacy boot, however as I want to have a parallel Windows 10 installation I need an UEFI install…
    Therefore I am trying to reinstall Antergos:
    In my Bios/UEFI, of my Mainboard, If I put in the live USB stick (which I created both with dd and suse Studio Imagewriter) I can select the drive directly or the drive with an “UEFI:” in front of it.

    If I read correctly I have to boot up in UEFI in order to get a proper UEFI install, is that right? Because here is where it gets tricky:
    The installation Medium gives me two options, that appear to be valid options for me:

    • Antergos Live System (cd/dvd)
    • Antergos Live System (usb)

    I read somewhere that one should just select cd/dvd… however for the sake of completeness If I select the second option (which in my opinion would be the intuitive one for me as I am booting from a USB-Stick) I get an error like

    EFI\archiso\archlinuz\vmlinuz

    then blue Error Message:
    ERROR
    Failed to start loader.efo: (14) Not Found

    If I hit “OK” my system just reboots…
    so I select

    • Antergos Live System (cd/dvd)

    However here I also get an error message:

    Error: ‘/dev/disk/by-label/ANTERGOS’ device did not show up after 30 seconds…
    Falling back to interactive prompt
    You can try to fix the problem manually, log out when you are finished
    sh: can’t access tty; job control turned off

    At this point I need some help because I do not know how to go on.
    I have installed Antergos on my Laptop (using a BIOS I think, since I only use Antergos on that device).
    I like it a lot and I would like to use the same distro on both devices.

    Thank you in advance!

  • @fingolin looks like secure boot is still enabled inside efi-firmware (BIOS) ?

  • @joekamprad thanks for the hint, but I think secure boot is disabled. My mainboard (gigabyte h97-d3h) does not have an explicity entry for secure boot but only an entry for Windows 8 Features which are turned to Other OS.

    In the notes to Windows 8 Features it says Select Windows 8 to enable Windows boot features such as Secure Boot. So I think its off…

  • o.k. then the culprit is may the suse image app?
    can you try flashing the iso to usb with etcher ?

  • @joekamprad said in Antergos Installation with UEFI:

    can you try flashing the iso to usb with etcher ?

    Yes sure… just a quick question should I go with the minimal install medium or “the big one”?

  • Okay Flashed it with Etcher, but it gives me the exact same behavior…

  • @fingolin said in Antergos Installation with UEFI:

    just a quick question should I go with the minimal install medium or “the big one”?

    the difference is only the live environment where you start the installer… the big one have a full GNOME Desktop to try without install as an extra… both will install the same way.

    Minimal gives only a minimal Desktop to start the installer, also good for older machines…

  • Okay I tried the minimal install medium (flashed with Etcher, as suggested) and it booted up! yay

    However… after I ran through the installation wizard I am stuck at Getting your disk(s) ready for Antergos
    Since I started Cnchi from the console I can see some Errors appearing:

    [ERROR ] Traceback (most recent call last): (run_cmd.py:78)
    [ERROR ] File “/usr/share/cnchi/src/misc/run_cmd.py”, line 102, in call (run_cmd.py 78)
    [ERROR ] timeout=timeout) (run_cmd.py 78)
    [ERROR ]File “/usr/lib/python3.7/subprocess.py”, line 395, in check_output (run_cmd.py 78)
    [ERROR ]**kwargs).stdout (run_cmd.py 78)
    [ERROR ] File “/usr/lib/python3.7/subprocess.py”, line 487, in run (run_cmd.py 78)
    [ERROR ] output=stdout, stderr=stderr) (run_cmd.py 78)
    [ERROR ] subprocess.CalledProcessError; Command ‘[’/usr/bin/umount’, ‘-l’, ‘/install’]’ returned non-zero exit status 32. (run_cmd.py 78)
    [ERROR ] (run_cmd.py 78)

  • what exactly you were choosing on disk partitioning?
    Do you want to dualboot or erase the entire disk?

  • @joekamprad said in Antergos Installation with UEFI:

    Do you want to dualboot or erase the entire disk?

    I have a seperate SSD on which I want to install linux, while installing I just unplugged my windows drives…
    So I just erase the entire disk and let cnchi do the partitioning

  • Somehow I have a problem getting my post through the spam filter
    But I get the following error:

    [ERROR ] Partition(s) 2, 3, 4 on /dev/sda/ have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use, As a result, the old partition(s) will remain in use. You should reboot now before making further changes. (partition_module.py: 387)

    When I try to manually partition the drives

  • @fingolin
    I suppose you just have to decide which system mode to use, UEFI or BIOS legacy.
    Both may work OK, since you probably have a hybrid BIOS that supports both UEFI and BIOS mode, right?

    Is your Windows installed in UEFI mode? You can check that by looking at the partitions of the Windows disk. If there is a small partition with FAT32 formatting, then you have installed it in the UEFI mode. Then it may be better to install Antergos in UEFI mode, too.

    I suggest you double check the settings of the BIOS/firmware about the system mode (UEFI or BIOS legacy).

  • @fingolin said in Antergos Installation with UEFI:

    When I try to manually partition the drives

    You must unmount partitions before modifying them.

  • @manuel said in Antergos Installation with UEFI:

    double check

    I double checked it a lots of times 😅
    Yes my windows is in UEFI installed and also has the small FAT32 partition.

    You must unmount partitions before modifying them.

    How do I do that? Isnt cnchi supposed to do that?

    Thanks

  • @fingolin
    OK, didn’t quite get in what situation you got the error. Cnchi can be configured to do many things with the partitions.

    But is it possible to have the Windows disk also plugged in while installing Antergos? Then you could add Antergos EFI files to the same EFI partition as Windows. And in that case, DO NOT DELETE/OVERWRITE the EFI partition, just mount it to /boot/efi while installing.

  • Yes I can do that but I don’t see why this would change the fact that cnchi cannot change the drives?

  • @fingolin
    What do you mean by “change the drives”?

  • @fingolin said in Antergos Installation with UEFI:

    [ERROR ] Partition(s) 2, 3, 4 on /dev/sda/ have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use, As a result, the old partition(s) will remain in use. You should reboot now before making further changes. (partition_module.py: 387)

    I am sorry If my answers are a bit clumsy, I am not the most experienced user 😕

  • @fingolin
    So currently you have only the “linux” disk plugged on the machine?
    And it is empty, or it has nothing important to be saved?

    Then you can use program gparted to modify the linux disk as you wish. Please try that and report the result. The gparted should be available in the installer stick.

error iso1 uefi usb-instal1 parallel instal1 Posts 29Views 140
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.