• Antergos MATE installation broken

    Screenshot from 2019-03-14 22-07-45.png

  • this is a connection or mirror problem, as the package mate-mint-menu is valid and available over Antergos repository.

    check your internet connection and/or try different mirrors / select them manual.

  • … but … i do try it here in VM and it gives the same error…

    culprit seems to be: python2-keybinder2 a called dependency not available over Antergos or Arch Mirrors.
    (python2-keybinder2 0.3.1-2 has been removed from the [community] repository.)

    BUG report on Github https://github.com/Antergos/antergos-packages/issues/437

  • yes during the install i just switched to KDE and it installed like a charm … still eager about my Budgie/GNOME post, as i really haven’t settled in any DE yet …

  • close cnchi after starting Antergos LIVE ISO then get the package list without mate-mint-menu:


    wget https://gist.githubusercontent.com/killajoe/0e058f012266c9edda6c4b88825f920e/raw/0c60a56925ebc5cdf441840b8a8b7ea015fe3397/packages-fixed.xml && sudo cnchi -p ~/packages-fixed.xml

    should install MATE
    (edit: fixed wrong url)

  • can i do that with a DVD installation? I’m not using a USB stick for installations as i had a situation where Rufus bricked my USB

  • @kronikpillow
    Probably yes, since AFAIK it is using RAM disks. Hope I’m not wrong… ;)

    Check with the df command which partition has tmpfs and copy the file there.

  • @kronikpillow
    You don’t have to reinstall to get another DE, you know that, right? If I read your other posts you went back to KDE, so just install the Antergos meta packages for the concerning DE.

  • @Bryanpwo Mate meta package is broken at the moment … @kronikpillow but you may can build missing dep from AUR and install antergos-meta-mate then:

    yay -S python2-keybinder2
    sudo pacman -S antergos-mate-meta
  • @joekamprad
    I was merely responding to @kronikpillow question about Budgie and Gnome in this thread.

  • @joekamprad


    Tried it but didn’t install… Same problem.

    BTW, seems the the -p option in cnchi does not work.

    cnchi -p $PWD/packages-fixed.xml

    Must have the full path.

    OK, now trying to install MATE so that I removed the mate-mint-menu from packages.xml. Let’s see.

  • @manuel i do paste the wrong url… for packages.xml ;) corrected… and using ~/ as path seems to work

  • I got MATE installed by that trick: removed mate-mint-menu from packages.xml.

  • i can confirm this here too

  • if you want mate-mint-menu install it from AUR:
    yay -S mintmenu (or over pamac)

  • Ok I’ll try it out :) @Bryanpwo yes i know but that leaves me packages from the previous DE and gets me mixed software doesn’t it?

  • @kronikpillow
    You can uninstall the entire group afterwards by sudo pacman -Rs kde for example and if you’ve installed it by antergos meta just use sudo pacman -Rs antergos-kde-meta and all packages and dependencies are removed.

mate66 ins1 Posts 17Views 280
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.