• Antergos on New UEFI Windows Machine with Secure Boot


    Had to buy a new machine because I broke my 8-yr old PC moving. The new one is a Dell Inspiron 3670 (64-bit), so it had Windows 10 Windows installed with Secure Boot and it uses UEFI. I was a little surprised to discover I could not just wipe Windows out by installing Antergos because of these features. A little research revealed that the Ubuntus will work, so I installed Xubuntu and wiped out Windows, but Secure Boot remains. I would like to go back to using Antergos, but it will not install in the same way I was used to on my old legacy EFI machine. (I did try again after installing Xubuntu, but at the part in the installation where the installer checks for all the files to download I get this message: ‘cannot find these packages: xorg-mkfontdir’: add fatal in /usr/share/cinchi/;rc/misc/eventsp.:83) The topic is a common one on the web, but the proposed solutions vary and conflict. I know many of you have surmounted this problem on your newer machines. Does anyone have a clear procedure I could follow to get home to Antergos? Thanks very much in advance.

  • cant you disable secure boot in efi bios menu ?

  • @rocket said in Antergos on New UEFI Windows Machine with Secure Boot:

    Dell Inspiron 3670

    common issue about mkfont https://forum.antergos.com/topic/11482/antergos-installer-error/2 there is another link but … lazy :p

  • @rocket
    AFAIK the workaround what @ringo32 just mentioned should no more be needed, it was fixed this afternoon.

    But as @ringo32 suggested, you should disable Secure Boot, since Antergos does not support it.

  • Yes, I can disable Secure Boot. The problem appears to have been unrelated, as the fix Manuel reported was the culprit. I now am happily home in Antergos. Thanks to all.

boot310 windows68 uefi42 secure2 Posts 5Views 98
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.