• Issues with WiFi and sound after installation\[SOLVED\]


    My laptop is an Asus x202e. I ran the lspci command and the audio device lists: Intel Corporation 7 series Chip set Family High Definition Audio Controller (rev 04). I don’t know what to look for under dmesg. I could take a screen shot but it seems I can’t even access the internet. On boot up I remember seeing fail under IPv6 and Speech-Dispatcher.
    Audio and wifi works fine on Live USB but after installation and reboot I have WiFi and audio problems. It worked the first time when I installed Antergos but my last 4 attempts have been futile.

  • My laptop is an Asus x202e. I ran the lspci command and the audio device lists: Intel Corporation 7 series Chip set Family High Definition Audio Controller (rev 04). I don’t know what to look for under dmesg. I could take a screen shot but it seems I can’t even access the internet. On boot up I remember seeing fail under IPv6 and Speech-Dispatcher.
    Audio and wifi works fine on Live USB but after installation and reboot I have WiFi and audio problems. It worked the first time when I installed Antergos but my last 4 attempts have been futile.

  • Hi,

    Please post the output of the following after a fresh boot (once the system has settled and you’ve made a failed attempt to conntect to wifi):

    lspci -k  
      
    dmesg  
      
    journalctl -b 
    

    Best Regards,

  • @“lots.0.logs”:xyy8m1xn said:

    Hi,

    Please post the output of the following after a fresh boot (once the system has settled and you’ve made a failed attempt to conntect to wifi):

    lspci -k  
    >   
    > dmesg  
    >   
    > journalctl -b 
    

    Best Regards,[/quote:xyy8m1xn]

    Thank you for the response. I really like Antergos and would like to continue using it. I found that posting images would be a bit inefficient as my 11.2 inch display doesn’t capture much on snap shots. Posted the code for each command on Google Docs and made it public.

    [https://docs.google.com/document/d/115Fv2UQ28eWgs9wwfvszxAEX7o0Uy0-1IQyzTZ-Vbf4/mobilebasic][0]">[https://docs.google.com/document/d/115F][1] … obilebasic

    [https://docs.google.com/document/d/1-hiyCyJtJiXbNOnlIUsVl_x0TcHMkhvstHJNoud8bGc/mobilebasic][0]">[https://docs.google.com/document/d/1-hi][2] … obilebasic

    [https://docs.google.com/document/d/1-S4BP_SclASboMRAylhcGurIrWQKxLh1M-DwGakcJb4/mobilebasic][0]">[https://docs.google.com/document/d/1-S4][3] … obilebasic

    [0]: <a href=
    [1]: https://docs.google.com/document/d/115F
    [2]: https://docs.google.com/document/d/1-hi
    [3]: https://docs.google.com/document/d/1-S4

  • Try installing this AUR package: "backports-patched "

    Best Regards,

  • @“lots.0.logs”:f1l29mxo said:

    Try installing this AUR package: "backports-patched "

    Best Regards,[/quote:f1l29mxo]

    Any advice on how I go about doing that? I downloaded the this package from my phone [http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.15.1/backports-3.15.1-1.tar.xz][0]">[http://www.kernel.org/pub/linux/kernel/][1] … 1-1.tar.xz from this webpage [https://aur.archlinux.org/packages/backports-patched/][0]">[https://aur.archlinux.org/packages/backports-patched/][2]

    How to I install the tar.xz package? I can’t find the package you were talking about in the Arch repo with PacmanXG.

    [b:f1l29mxo]UPDATE: I got things going by using yoaurt command to install backports-patched but I end up with an error. The latest back ports-patched package is for kernel version 3.15.x. and my kernel is 3.16.1 if I remember correctly. I don’t think the backports-patch solution would work for me.[/b:f1l29mxo]

    [0]: <a href=
    [1]: http://www.kernel.org/pub/linux/kernel/
    [2]: https://aur.archlinux.org/packages/backports-patched/

  • [b:1vlpriq2]I solved both issues with the help of some guys on the Antergos Google+ community [/b:1vlpriq2] To get Wifi working again I disabled everything execept NetworkManager.service. That is to say, I ran the [b:1vlpriq2]sudo systemctl disable <your.service>[/b:1vlpriq2] command on netctl.service, dhcpcd.service and wpa_supplicant.service and everything seems to be working fine. Turns out they were battling each other for resources and there was conflict. Wifi automatically connects without any issues. That is to say, I ran:

    [b:1vlpriq2]sudo systemctl disable netctl.service[/b:1vlpriq2]
    [b:1vlpriq2]sudo systemctl disable dhcpcd.service[/b:1vlpriq2]
    [b:1vlpriq2]sudo systemctl disable wpa_supplicant.service[/b:1vlpriq2]

    Of course if you want to enable them again you can run this: [b:1vlpriq2]sudo systemctl disable <your.service>[/b:1vlpriq2]

    [b:1vlpriq2]To solve the audio isssue I:[/b:1vlpriq2] went to /etc/conf.d/fluidsynth(open nautilus as Root) and locating the following line:
    SYNTHOPTS="-is -a alsa -m alsa_seq -r 48000" Where you see the first alsa, I changed it to pulseaudio so that the line would look like this [b:1vlpriq2]SYNTHOPTS="-is -a pulseaudio -m alsa_seq -r 48000"[/b:1vlpriq2]

Posts 7Views 1743
Log in to reply