• Antergos not installing on Dell XPS 9575


    Hello, World. I am currently attempting to install Antergos on my Dell XPS 9575 using the antergos-19.3-x86_64.iso liveUSB (SHA1=b287e4158d3e1c328222965f0b266963cc1324b7) and am experiencing a plethora of issues. While the system acts like it has installed, the result is an impossible to use pile. I previously ran manjaro and elementaryOS on it, so Linux itself isn’t the issue. Here are the steps I took and the cnchi logs:

    1. I made a liveUSB on a stick via dd from another machine.

    2. I selected the liveUSB in UEFI mode, and booted “Antergos Live System (cd/dvd)” (the usb option fails and falls back to memtest)

    3. I open a terminal and run sudo gedit /usr/share/cnchi/data/packages.xml, remove the package xorg-mkfontdir on line 89 and save.

    4. I run sudo cnchi -p /usr/share/cnchi/data/packages.xml 2> $HOME/Desktop/cnchi-log.txt (attached)

    5. I follow the process, selecting these options:

      • English installer language
      • OK system check (which btw lags like crazy but that’s neither here nor there)
      • Select English (US) location
      • Select New York timezone and turn on NTP sync
      • Select English (US) keyboard
      • Select GNOME desktop
      • Select Advanced power management, AUR support, Bluetooth, Firefox, LibreOffice, Printing, SSH, and Wine. Authorizing the AUR
      • Do not select a cache partition.
      • Let cnchi determine mirrors
      • Select “erase disk and install Antergos”, select “encrypt this instillation for increased security” and “Use LVM with this instillation”
      • Select “/dev/nvme0n1” instead of /dev/sda (which is the USB drive) to install on, and select grub2 to be put on /dev/nvme0n1 as well.
      • I fill out the fields for my account as asked.
      • I ok the install and wait for it to happen.

    After that, cnchi asks to restart, however when it starts up again I’m directed to my fallback ethernet boot. What’s going on?

    Here’s the log. Sorry this isn’t the standard way of sending these things but the forum was giving me trouble and it’s too big for pastebin.

  • do it ask to create a user and password?
    and i can see lot of can not resolve host errors…

  • @joekamprad Yes, I create a user and password. It doesn’t ask me about root, however.

  • @whitman-colm
    It should have asked for root password while installing.

    Anyway, I suggest reinstalling (maybe temporarily) without using encryption so that we can minimize the potential reasons of problems. The problem might be where the grub was installed, but that’s just a guess.

    As you have an UEFI system (right?), you need to have at least two partitions, EFI (/boot/efi) and root (/).

  • @manuel said in Antergos not installing on Dell XPS 9575:

    It should have asked for root password while installing.

    it takes the same password for initial user and root on install ;)

  • @manuel I chose to completely replace my OS, does it not automatically partition for UEFI?

  • @whitman-colm
    It should if you select automatic partitioning and you have an empty drive. But if you already have an EFI partition (e.g. because of Windows dual boot), then you need to manually assign that partition to /boot/efi to be able to dual boot.

    Partitioning must be done very carefully, otherwise it does not work as expected, and may even delete existing partitions (that you might want to keep).

  • I didn’t update grub for UEFI like I was supposed to. Its not a cnchi thing its a UEFI thing.

  • @whitman-colm
    If you still have a problem (the thread is marked as solved), could you show the output of the following commands:

    lsblk -fm
    sudo fdisk -l
    
  • I have the same issue as you. My computer doesn’t have grub showing up in bios so I have to use legacy option to select hard disk to boot Antergos. I hope it helps

cnchi161 dell xps1 Posts 10Views 304
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.