• Antergos on a VirtualBox VM & VmWare VM


    I can’t seem to boot to Antergos Live system using the VirtualBox VM, it opens the first boot screen, i select the live media option (the first one) and start booting in to the system, a screen hows with loading, and all of a sudden it changes to a black screen with the tty login … anyone had similar issues and possibly know the solution? I’v been using Antergos KDE, but want to try out other desktop versions without modifying my current system

  • @kronikpillow
    Just tested a virtual machine install, and it works (but needed a workaround like in this thread: https://forum.antergos.com/topic/11467/xorg-mkfontdir-breaks-installation-for-all-versions/4).

    It could be some temporary glitch. Or maybe you need to change some virtual machine settings?

  • Open up your VM settings and under display if it is set to VMSVGA change it to VBOXVGA, that sometimes helps.

  • @manuel that option is not doable as i can’t enter cnchi installer or the system at all

    @Listening’s suggestion worked, ty

  • Ok so new update to this situation, I managed to launch Antergos Installer once in VirtualBox, the installer was broken (something about some folder missing from the installer), so while i was waiting for Antergos installer to be fixed, i decide to give VmWare a try, on my other VM distros it works perfectly and installs perfectly, much better overall performance then what I have in VirtualBox … but … the Antergos Installer is anything but responsive in WmVare, basically anything i click i have to wait 10 mins to open the next section of the installer, I have 8GB ram, intel i5 on 3.2 ghz quad core, i gave the Vm 2 cores gave it 2GB ram, edited the .vmx file with a text editor and set it to a EFI system … and practically I can not Install Antergos on a VM, not in VirtualBox or VmWare … what am I missing?

  • @kronikpillow
    For me Antergos installer in VirtualBox works really well, especially now that the xorg-mkfontdir issue was solved yesterday. I haven’t tried VmWare for ages, so I cannot really comment on that.

    So as I see it, there are some potential problem spots to begin with:

  • @manuel the ISO is the official antergos ISO from antergos repo, verified the MD5SUMS

    settings on WmVare
    Screenshot_8.png Screenshot_6.png Screenshot_4.png Screenshot_2.png Screenshot_1.png

    and added a line firmware = “efi” in the .vmx file to boot it in EFI firmware = “efi”
    On VmWare the ISO boots in seconds, the Live OS boots, but after that, pretty much everything is unresponsive


    in VirtualBox
    Screenshot_7.png Screenshot_6.png Screenshot_5.png Screenshot_4.png Screenshot_3.png Screenshot_2.png Screenshot_1.png

    in VirtualBox if i use cd/dvd option i get a EFI boot loader not found message, which is weird because on VmWare i boot using the same ISO and the same option, i also booted the same ISO on my host and installed GNOME, Budgie, KDE in EFI with no issues … if i disable EFI in the VmBox (which is not my goal as i need to simulate EFI installations for my EFI system) i get past the boot selection screen, and get stuck on the tty live session login screen … if i try to boot with the USB option (while using a loaded CD/DVD) i still get a black screen …

    how are you guys booting Antergos in a Virtual environment as having to format my HDD and reinstall Antergos everytime i want to play a little different desktop, is kinda not healthy for my PC :-/ I’m a antergos supporter, I do not want to have to give up on this distro just to be able to test other desktop enviroments … and no, I wont install multiple desktops on my system, as that mixes up its default software

  • @kronikpillow
    I comment on VirtualBox only. I have some different settings, and I try to keep my modifications as small as possible.
    The different settings are:

    • Display
      • no Enable 3D Acceleration (I’m using Xfce)
      • Graphics Controller: VBoxVGA
    • System Acceleration: same, but have you enabled VT-x or AMD-V in your BIOS?
    • System Processor: no Enable PAE/NX
    • System Motherboard: no Enable EFI (I think it is for Mac?)

    The EFI/UEFI setting is not even needed in VirtualBox guest, even if your host is UEFI.

    And yes, my host is not Windows! ;)

    EDIT: one more difference: on Storage, I have the .vdi under SATA controller. The ISO is under IDE controller, like yours.

  • @kronikpillow hello, I’m new in the forum here but i have been using Antergos for a couple of years or more. I’m a Cinnamon desktop user but i’ve been a distro hopper and I have also used and or tried most Linux distributions since th 90’s… I am no Linux expert but i can tell you that i have used VmWare & Virtual box extensively in Windows but i have used Virtualbox even more in Linux and i don’t have many issues with it. I have used Vmware player and also the VMware worksation. One of the things is that you have an Nvidia video card so some of those can present challenges getting Antergos installed. Then you have to install the Nvidia drivers after. But this is not in virtual that i’m referring to. That’s another issue, but it could also carry over into the virtual box possibly. Normally i just use the v-box drivers. One of the things with v-box is create the new entry and before you launch it go into settings and make sure you set the different settings. There are only 3 or four you need to worry about. I have run this both on my EFI system and MBR without any issues. I’m not sure why you need to change things for EFI? Anyway getting back to the settings. I set the processor cores, make sure video memory is high enough…you can put it at 128 if you like or less. If you have lots of memory give it enough as some ditro’s just work better with more. Vbox doesn’t like it if you use more than 50% of your memory so it will give you an error. The other thing is to make sure you use vbox-vga. Do not use SVGA or the other what ever it is. Leave the standard settings for type of virtual disc when you create it and make sure it’s big enough. Also you shouldn’t have to change much else other than check the boxes for the virtual acceleration settings of the processor. Use hardware virtualization and make sure you enable 3D acceleration. What i do after i create the virtual disk and change the settings and install it to the virtual disc i shutdown v-box and then remove the check mark in Optical drive in the boot order so it boots from the hard drive in the settings. Because once it is created you want it to boot from the virtual disc which is basically a file and not from the ISO anymore. Here is a link to Oracle and everything is explained.

    https://www.virtualbox.org/manual/UserManual.html

    I hope this helps a little. Antergos is just awesome.

  • well now that’s 2 different type of suggestions, but for most part what @ricklinux said i already have enabled in virtualbox as you can see mate in the screenshots, every setting you suggested is exactly like you said it… I’m emulating EFI because my host is EFI, so that kinda makes more sense doesn’t it?

    I have successfully installed all versions of antergos on my host’s separate partition many times, including yesterday where i had some performance issues on GNOME and Budgie, very serious ones, especially when enabling wayland session, but that topic you can find here: Antergos Budgie & GNOME performance issues , the only Antergos desktop i didn’t try out yet is MATE and it’s because of this Antergos MATE installation broken

    @manuel the reason my host is on Windows is because keep a partition separate for windows, even thou i don’t use it much, and because I still haven’t settled in a DE to run it as a daily driver, reasons for this is because i jumped in to Linux a few months back, and all the variations out there, are overwhelming, and i want to see them all so that I could know what suites me and my workflow and my needs best, and when i break a system, i can just return to Windows, and get a new one prepped, or i can even take a break from installing Linux that day because i might not have time to do it properly, and then i can just use windows as a temp 1-2 day solution …

    VT-x according to speccy is enabled : download.png

    changed graphics to VBoxVGA
    left system acceleration on
    disabled PAE/NX
    left EFI on

    it still won’t boot in to EFI, says EFI loader not found, which is impossible because I’m booting to VmWare trough the same iso in EFI mode
    Screenshot_9.png

    proof of successfully booting in to VmWare with EFI enabled:
    Screenshot_10.png

    it took me 25 mins to type in cat /sys/firmware and it froze after, it wouldn’t allow me to type efi, but you can see its there

    with EFI disabled in VmWare the performance issue still persists, i cant do anything in it once the iso boots the live enviroment

    with EFI disabled in VirtualBox i succesfully boot in to Live ISO after applying the above mentioned settings, but still I have to wonder why is VirtualBox reporting that the EFI loader can’t be found, when it’s there?

    another note, I have just booted in to VmWare ArcoLinux ISO in EFI and BIOS and the performance is awesome, but VirtualBox can’t boot ArcoLinux in efi, so I’m thinking if it’s possible that Antergos lacks support for VmWare and tha VirtualBox just can’t boot EFI virtualization?

  • @kronikpillow I don’t really think it’s two different suggestions. Manuel may have some slightly different settings. I can tell you that your thoughts on EFI are wrong. You don’t need to emulate EFI just because your host is EFI. The reason i have the virtual settings set for hardware is because my hardware supports it. I have run a lot of different Linux distros both in Windows and Linux on v-box with the same settings in both whether it is on an EFI sytem or MBR. EFi doesn’t do anything…it is just a different way of booting the system. It is a boot manager and it boots using a firmware.

    MBR contains executable code to function as a loader for the installed operating system—usually by passing control over to the loader’s second stage, or in conjunction with each partition’s volume boot record (VBR). This MBR code is usually referred to as a boot loader. A master boot record (MBR) is a special type of boot sector at the very beginning of partitioned computer mass storage devices like fixed disks or removable drives.

    UEFI is a software interface between an operating system and platform firmware. It manages what boots in what order.
    I think you are trying to do way too many different things all at once and it doesn’t help come to any conclusions.

    I am a hardware person and i know hardware, especially what i am working with. I deal with specifications and i know what the hardware is capable of. I am not a programmer or developer. Everything else i have to figure out the hard way by reading and doing and failing and trying again and again. I don’t know everything and i’m not a Linux expert. I just know that if i have the hardware in front of me it’s a lot easier to understand what’s going on. When you are booting a virtual disc in v-box it doesn’t matter how it boots and when you install it you are installing it in v-box with v-box settings even if you have an EFI system. My suggestion is create a new virtual disc as i have explained and leave the EFI stuff out of it. Set the settings as i have explained and try again. Also make sure you have the virtual box extensions installed and set in the settings. Read the Oracle manual on v-box that is applicable. Don’t give up too easily. A lot of people get frustrated and blame the distro when in fact it is a lack of understanding and knowledge. Please don’t take any offense to what i’m saying. Understanding how something is supposed to work for me makes all the difference. Eventually i just get it! Not everything but most of it. I wish you success as Antergos is the best distro out there in my opinion and i have tried most of them.

  • @kronikpillow
    In the user manual of virtualbox they tell their EFI implementation is very experimental. Probably vmware’s implementation is more mature.

    But anyway, EFI gives zero benefit for virtual machines. And if it doesn’t work, there’s no sense in setting it.

  • @manuel I also found this online.

    VMware Player and Workstation

    The virtual machine products offered by VMware support UEFI, but BIOS firmware is enabled by default. Furthermore, the VMware products do not provide an option in the GUI for enabling UEFI.

    UEFI support must be enabled by manually editing the .VMX file or by using a third-party tool like VM Tweaker.

    To manually edit the .VMX file, simply open with a text editor and add the following line and then save:

    firmware = “efi”

    That’s it — now that particular VM should run with UEFI.
    VirtualBox

    VirtualBox by default uses the BIOS firmware for virtual machines. It supports EFI too, but unfortunately does not support booting UEFI-based system volumes, which includes Windows 8 in UEFI mode. However, if you’d still like to test or use EFI with other operating systems, enabling EFI support is easy. Open the VM settings, select System, and on the Motherboard tab, select Enable EFI (special OSes only).

    This is dated late 2014 so i’m not sure if much has changed or not?

  • @kronikpillow here is the answer you are seeking although this info is a bit dated.

    https://www.virtualbox.org/ticket/14279

    Getting EFI to Boot an OS install CD

    64 bit running an a VM with EFI enabled:

    Settings:

    • System -> Motherboard -> Extended Features: Enable EFI
    • Boot HDD must be attached to SATA controller! IDE, SCSI or SAS will not work (bug report: Ticket #14142)

    EFI Boot Screen:

    When the UEFI boot screen appears, it should show blkX: and fsX: devices. fsX: are file systems accessible by the boot loader. If the EFI boot partition does not appear as fsX:, the boot manager will not be able to boot. This will happen if the EFI partition is on a disk attached to an IDE, SCSI or SAS controller (see above).

    Boot from the EFI boot shell (for Ubuntu system, others may be different):

    efi\ubuntu\grubx64.efi

    Once you know what to boot (in my case: efi\ubuntu\grubx64.efi), put this line into a new file startup.nsh in the root directory of the EFI file system. Then, the EFI boot loader will boot it automatically after 5s.

    Not sure if this will help you or not. But that’s how EFI works. It looks to the EFI partition to get the path to the boot EFI file for whatever you are booting.

    This information comes from a virtual box forum.

    https://forums.virtualbox.org/viewtopic.php?f=1&t=45065

  • @ricklinux That’s exactly how i enabled it … but i think you missed the point in the vast length of my post, I’m not blaming the distro, nor am I giving up on the distro, I’m saying that on the same VM software (VmWare) with the same settings, I can boot any distro in both firmware settings (EFI & BIOS) without any performance issues except Antergos, so on VmWare i can run Debian, Ubuntu, ArcoLinux, Manjaro, no issues, the live CD boots, and everything works, when I boot Antergos on VmWare with EFI enabled & disabled it took me about 25 mins to type a simple command in the terminal … so when i run VmWare, it doesnt matter if EFI is enabled or disabled, Antergos is unusable …

    Basically I’m reporting what I have done and tried out, and how it works, maybe someone can try to boot antergos in VmWare VM to see if the same problem occurs to him ? :)

  • here’s a simple solution, i gave up on VmWare :D

  • @kronikpillow
    For me VirtualBox has always run very well (despite some glitches made by VirtualBox devs and then fixed them). And vmware-workstation seems to be an AUR package, so I’ll stay with VirtualBox.

  • I prefer virtual box over vmware and i also find it works very well for what it is. Having said that i would rather have the distribution installed on my computer rather than running virtual. I can install and set up Antergos and add software and tweak in 10 minutes or more. I have tried most other ditros and Antergos is awesome. Every time i have tried a different distro i have always came back to Antergos. It is my favorite. I like the installer. I like the package manager. It just works for me.

  • @ricklinux i fully agree, i go off antergos, to try out other distros, and then i come back to antergos :D only thing i dislike is the software selection during installation, wish we had more freedom, as some of the apps i would never install, like hTop and screenfetch … i consider hTop unnecessary as a default installed package as each DE gives it’s own resource monitoring app, also I prefer neofetch, having the option to select each software if to install or not is much better then having to uninstall everything you don’t need or use, and i actually uninstall a lot of stuff after installing any DE as I am a pure desktop browsing/media/gaming user and i dislike unnecessary clutter… :) also wish there was a Google Chrome option during installation as Chromium sucks, and i dislike Firefox, the “google tracking” in a world full of tracking is something i can bare with considering the advantages of chrome, like HTML5 performance as the main game i play is HTML5 … firefox just performs bad in it … anyways great distro overall, just need more freedom during installation … althou, the installer is rather buggy and slow sometimes, the Calamares installer or whats it called i find is much better

  • @kronikpillow I guess i’m kind of the opposite as i am not a gamer. I don’t like an empty desktop as i do want a few icons and i prefer Firefox over all other browsers. I prefer and use the Cinnamon desktop. As far as the installer goes i have not had that many problems with it other than when there is a problem with something. I have fibre optic to my location so it’s not slow for me. I don’t find it buggy… it’s just the nature of the beast. When there is a problem …there is a problem. I can’t control that. If it’s a software issue…packages… repository or server or the installer because they’ve changed something then it is up to the devs to correct that and i have to wait and or rely on someone else who is involved with Antergos to let us know what the issue is and or someone in the community who has figured out a work around or i figure it out myself if i’m capable by reading and doing. If i have to wipe it out and start over that’s not a problem for me. It doesn’t take that long with this installer…for me if i mess it up by trying something. Everyone’s hardware is different and they may not have the best internet either. It also makes a difference on the brand of USB drives and the software used to burn the ISO and that is where some of the problems come from trying to install. It all has to do with the hardware and or the software. As far as the choices go on the install i don’t have many issues with it. Anything i want to install is available in the update manager after and the installer doesn’t really install much other than what is pre-packaged in the particular desktop you choose. If there is something i don’t use or don’t want i just uninstall it if that’s possible. I don’t really see an issue with it. I like Antergos a lot because i believe in the rolling release model and i like it because it’s Arch based. It just works for me.

virtualbox47 Posts 20Views 344
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.