• xorg-mkfontdir breaks installation for all versions


    Hello,

    I wanted to use Antergos and used 19.3 installation image for installation. Installation breaks with message

    'Cannot find these packages: xorg-mkfontdir': add_fatal in /usr/share/cnchi/src/misc/events.py:83
    

    I also tried 19.1 build with the same outcome which is maybe not surprising givin’ that the issue is maybe with a change made to the provider for xorg-mkfontdir which is apparently since 4th of March (?) xorg-mkfontscale. When trying to (re)install xorg-mkfontdir in the live session (via pacman -S) it instead tries to remove/replace it.

    Kind Regards,

    TheVoid

    PS.: Also tried installing it in a VM with the same outcome. Not surprising too if my guess is right.

    Workaround:
    0.) Connect to internet and let Cnchi pop up and close it
    0.) Open terminal
    1.) cp /usr/share/cnchi/data/packages.xml ~
    2.) gedit ~/packages.xml
    3.) Remove line that contains xorg-mkfontdir
    4.) Save
    5.) cnchi -p ~/packages.xml

  • yeah that is lately changed to xorg-mkfontscale i think chnci have to adapted to changes.

    @developers

  • @ringo32 When about wait for a fix?

  • Oh, the workaround is so easy:

    1. open /usr/share/cnchi/data/packages.xml with your favourite editor
    2. delete the line that contains “xorg-mkfontdir”
    3. cnchi -p /usr/share/cnchi/data/packages.xml

    I did not somehow try to manipulate the image unpacking/unsquashing it and resquashed/repacked it, to find out that the packages.xml is loaded from the internet and still failed. No that wasn’t me … doh!

  • @enterthevoid said in xorg-mkfontdir breaks installation for all versions:

    cnchi -p /usr/shar/cnchi/data/packages.xml

    Thanks for solution!

  • @Asgard7 ah yeah because Chnci always look for a new version then it updates itself :) but if fixed is nice :)

  • Hey guys,

    First of all: I am a total Linux novice. 😅
    At the moment I’m looking for a distribution that fits my preferences and I’m trying some things.
    I really like the USB-live (?) version of Antergos, but I can’t try the other desktops because of this bug.

    So I guess this workaround is meant for already installed systems that get an update or else? Am I missing something?
    I can’t find the packages.xml file anywhere on the bootable USB stick, let alone the file path to it. Is my only option to wait for an update in which the outdated script has been corrected? 🤔

    Thanks for any insights!
    MrDoodlezz 😉

  • @enterthevoid This didn’t work for me! My steps

    1. Boot from live USB
    2. sudo gedit /usr/share/cnchi/data/packages.xml
    3. ctrl+F for mkfontdir, delete the line, save file
    4. cnchi -p /usr/share/cnchi/data/packages.xml
    5. Returns same error during installation.

    New to linux, what am I doing wrong?

  • @passenger0001
    Did you let Cnchi update and open first? Then close it and continue as you did.

  • @grenouille Yes, I did! After the first attempt, I tried many times the following:

    1. Tried install the normal way, searched forum because I got the error (cnchi must have updated at this time)
    2. Searched forum and made changes to packages.xml
    3. Rechecked packages.xml to see if the change was persistent (mkfontdir line removed)
    4. Ran cnchi -p /usr/share/cnchi/data/packages.xml many times
    5. Same error

    Let me try again from scratch, hopefully it will work this time.

  • @passenger0001
    The only thing I did differently from you is that after a fresh reboot, I didn’t attempt an install before editing packages.xml. When Cnchi opened after updating, I immediately closed it and opened a terminal to run through the rest.

  • I come back now and then and give Antergos another try and still the antergos team (small team) are unable to make the distro usable because it cannot be installed. People do support your project through donations and word of mouth, but there seems to be a lack of acknowledgement from the team that there is a problem. At the very least tell people about the problems and how to solve them if possible. People are going to leave and never come back, you have put in time and work and it’s all going to be for nothing.

    Enjoy your day

    Cheers

  • Hi all I ran into the same issue but my file was read-only so I copied packages.xml to a folder that I could read and write from. Deleted the mkdir line then saved in same folder and ran
    cnchi -p /directorywhereyoucanreadandwrite/packages.xml and installed like a dream. Still reads the new package file and skips the mkdir.

  • Added workaround to first post and made it a bit more verbose and beginner friendly as suggested by some.

  • @enterthevoid problem solved installation will work without the workaround from now on!

  • Hey guys!

    Thanks @enterthevoid and @joekamprad for the quick responses, updated/more detailed workaround and the installation fix! 👌

    I’ll try this again tomorrow. 😄

installation321 breaks38 versions2 xorg-mkfontdir1 Posts 17Views 3942
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.