• Upgrading python2-progress breaks pip2

    After upgrading python2-progress to version 1.5.1, I am no more able to install packages via pip2. The output of

    pip2 install numpy


    Traceback (most recent call last):
      File "/usr/bin/pip2", line 11, in <module>
        load_entry_point('pip==18.1', 'console_scripts', 'pip')()
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 489, in load_entry_point
        return get_distribution(dist).load_entry_point(group, name)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2793, in load_entry_point
        return ep.load()
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2411, in load
        return self.resolve()
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2417, in resolve
        module = __import__(self.module_name, fromlist=['__name__'], level=0)
      File "/usr/lib/python2.7/site-packages/pip/_internal/__init__.py", line 40, in <module>
        from pip._internal.cli.autocompletion import autocomplete
      File "/usr/lib/python2.7/site-packages/pip/_internal/cli/autocompletion.py", line 8, in <module>
        from pip._internal.cli.main_parser import create_main_parser
      File "/usr/lib/python2.7/site-packages/pip/_internal/cli/main_parser.py", line 8, in <module>
        from pip._internal.cli import cmdoptions
      File "/usr/lib/python2.7/site-packages/pip/_internal/cli/cmdoptions.py", line 22, in <module>
        from pip._internal.utils.ui import BAR_TYPES
      File "/usr/lib/python2.7/site-packages/pip/_internal/utils/ui.py", line 15, in <module>
        from pip._vendor.progress.helpers import HIDE_CURSOR, SHOW_CURSOR, WritelnMixin
    ImportError: No module named helpers

    Downgrading to 1.4.2 fixes the issue.

  • @mpetitjean
    It is advisable to inform the package maintainer in the AUR. Then a fix can be expected sooner I guess…

  • The package python2-progress comes from the Arch Linux repositories: https://www.archlinux.org/packages/community/any/python2-progress/

  • @mpetitjean
    python2-pip is already flagged as outdated.

    Can you use pip3?

    EDIT: well I tried it and a similar problem occurs. Seems that the packages are now incompatible. Hopefully they fix it soon.
    As I’m no python user, unfortunately I cannot help more. But you have a workaround, that’s great.

  • Update: the upgrade from python2-pip to 18.1-2 fixed the issue.

  • @mpetitjean
    And if you feel this thread is solved, could you please mark it as such?
    There are buttons for it on this page below the posts.

pacman122 upgrading8 python2-progres1 pip21 Posts 6Views 125
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.