• Huge Authenticate Panel!


    Just out of curiosity, why is the Authenticate Panel for Xfce so big in Antergos, but not in other distros? I went distro hopping for fun, and I’ve installed Antergos w/Xfce twice just make sure I hadn’t done something wrong.

    It’s about twice the size of normal panels in width, and it doesn’t matter what theme I’m using, either.

    Huge Authenticate Panel

  • is gksu installed ?

  • every distro has removed the use of gksu but you can still install it even though most developers say it’s a security risk using it. i’m in my mint 19.1 xfce now where i do not have gksu installed but trick the system thinking gksu is installed but using an alias to pkexec.

    using gksu will not fix the issue, it will only open a different password input dialog. i use a modified arch dark theme not sure if that makes any difference

    does pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY HOME=$HOME gedit open a smaller window?

  • @trytip
    Hi. Unfortunately, that did not work. It isn’t a big deal, but just curious.

  • @Adam-Worth
    ah, yes now that i am in arch linux i see the password dialog is large same as yours.
    i haven’t payed much attention to it but now that you point it out it does bother me also. if i find anything i’ll post results

  • @trytip

    Thank you for looking into it. I don’t know enough about this to know where to begin. ☺ Also, glad to know that I’m not the only one. LOL

  • Authentication agents
    An authentication agent is used to make the user of a session prove that the user of the session really is the user (by authenticating as the user) or an administrative user (by authenticating as an administrator). The polkit package contains a textual authentication agent called ‘pkttyagent’, which is used as a general fallback.

    If you are using a graphical environment, make sure that a graphical authentication agent is installed and autostarted on login.

    Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE, theShell and Xfce have an authentication agent already. In other desktop environments, you have to choose one of the following implementations:

    lxqt-policykit, which provides /usr/bin/lxqt-policykit-agent
    lxsession, which provides /usr/bin/lxpolkit
    mate-polkit, which provides /usr/lib/mate-polkit/polkit-mate-authentication-agent-1
    polkit-efl-git, which provides /usr/bin/polkit-efl-authentication-agent-1
    polkit-gnome, which provides /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
    polkit-kde-agent, which provides /usr/lib/polkit-kde-authentication-agent-1
    ts-polkitagent, which provides /usr/lib/ts-polkitagent
    xfce-polkit-git, which provides /usr/lib/xfce-polkit/xfce-polkit

  • @joekamprad said in Huge Authenticate Panel!:

    xfce-polkit-git, which provides /usr/lib/xfce-polkit/xfce-polkit

    Bildschirmfoto vom 2019-03-07 07-42-24.png

  • @joekamprad

    Well, what do you know? It wasn’t installed. I installed it from Package Manager and restarted…Voila! Beautiful!

    Thank you. I wonder why it doesn’t automatically get added when you do a fresh install?

  • @joekamprad

    And, ahem…what is that theme you’re running? Beautiful!

  • @Adam-Worth xfce-polkit usually is the one for xfce, size is more tiny cause the shown info text is shorter only as far as i know ;) it shown only authentification necessary and gnome-polkit is showing
    An application is attempting to perform bla bla e.t.c.u.s.w. u.s.f

    gtk-theme = arc-gtk-theme
    icons = sardi-icons

  • @joekamprad Thank you, for the explanation and the theme info. Have a great weekend!

panel35 authenticate3 huge2 Posts 12Views 182
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.