• Dateikonflikt Pacman-Update


    Hallo zusammen. Folgendes Problem tritt auf:

    sudo pacman -Sy && pacman -Qu

    gvfs 1.38.1+8+ge4eec2bc-1 -> 1.38.1+9+gd4dab113-2
    gvfs-goa 1.38.1+8+ge4eec2bc-1 -> 1.38.1+9+gd4dab113-2
    gvfs-google 1.38.1+8+ge4eec2bc-1 -> 1.38.1+9+gd4dab113-2
    gvfs-gphoto2 1.38.1+8+ge4eec2bc-1 -> 1.38.1+9+gd4dab113-2
    gvfs-mtp 1.38.1+8+ge4eec2bc-1 -> 1.38.1+9+gd4dab113-2
    gvfs-smb 1.38.1+8+ge4eec2bc-1 -> 1.38.1+9+gd4dab113-2

    sudo pacman -S gvfs

    Löse Abhängigkeiten auf…
    Suche nach in Konflikt stehenden Paketen…
    Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
    :: Installation vongvfs (1.38.1+9+gd4dab113-2) verletzt Abhängigkeit ‘gvfs=1.38.1+8+ge4eec2bc’, benötigt von gvfs-goa
    :: Installation vongvfs (1.38.1+9+gd4dab113-2) verletzt Abhängigkeit ‘gvfs=1.38.1+8+ge4eec2bc’, benötigt von gvfs-gphoto2
    :: Installation vongvfs (1.38.1+9+gd4dab113-2) verletzt Abhängigkeit ‘gvfs=1.38.1+8+ge4eec2bc’, benötigt von gvfs-mtp
    :: Installation vongvfs (1.38.1+9+gd4dab113-2) verletzt Abhängigkeit ‘gvfs=1.38.1+8+ge4eec2bc’, benötigt von gvfs-smb

    Überwiegend gehts ums löschen wenn ich danach suche. Wahrscheinlich ist es hier auch so. Nur was? gvfs und/oder die anderen Dateien? Sicherheitshalber frag ich lieber mal nach. ^^ Vielleicht kann jemand helfen. :)

    Danke.

  • sie mache pacman -Qsq gvfs in die terminal

    du sehn dich gvfs pakketten…

    probiere al dich gvfs as :

    pacman -S gvfs gvfs-afc etC…

    oder pacman -S $(pacman -Qsq gvfs)

    gvfs-afc muss die version haben, dan is konflikt…

  • oder pacman -Syu .

  • Hallo ringo32 :)

    pacman -S hab ich für alle probiert. Bekam aber leider immer folgende Meldung: ‘Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)’
    Funktioniert hat es mit: ‘pacman -S $(pacman -Qsq gvfs)’. Kannst du mir bitte sagen, wofür das ‘q’ steht? Und kann ich diese Befehlskombination auf alle Dateikonflikte dieser Art anwenden?

    Lieben Dank & beste Grüße

  • pacman -Qs pakket , mache un lijst von program + version nr’s .
    mis pacman -Qsq is une list von program’s mit keine version

    q ist as stil in version alein program naam

  • das q kannst du nicht mit alle konflikt. in diese gefal du neme alle gvfs name in eine pacman -S
    *afc gphoto must have das neue gvfs name, if dich alein gvfs instalierd , du kanst nicht alle andere gvfs muß have same version

  • Wenn du mir jetzt noch sagen kannst, was du mit afc bzw *afc meinst? Die Fehlermeldungen sehen doch alle gleich aus. Wie kommst du auf gphoto?

  • ist eine beispiel …

    meine lijst :

    [email protected] ~ % pacman -Qs gvfs
    local/gvfs 1.38.1+9+gd4dab113-2 (gnome)
        Virtual filesystem implementation for GIO
    local/gvfs-afc 1.38.1+9+gd4dab113-2 (gnome)
        Virtual filesystem implementation for GIO (AFC backend; Apple mobile devices)
    local/gvfs-gphoto2 1.38.1+9+gd4dab113-2 (gnome)
        Virtual filesystem implementation for GIO (gphoto2 backend; PTP camera, MTP media player)
    local/gvfs-mtp 1.38.1+9+gd4dab113-2 (gnome)
        Virtual filesystem implementation for GIO (MTP backend; Android, media player)
    [email protected] ~ %
    

    is allelaam lokaal, alein on installed on meine pc.

    mit pacman -Qsq

    [email protected] ~ % pacman -Qsq gvfs
    gvfs
    gvfs-afc
    gvfs-gphoto2
    gvfs-mtp
    

    mist $(pacman -Qsq gvfs) nehme das list zu gebrauch as beispiel : pacman -S gvfs gvfs-afc gvfs-gphoto2 gvfs-mtp, es ist allein installed list its neemst von repo…

    -Q est lokaal nor repo allein on dich pc

  • ah ok. gvfs-afc ist bei mir nämlich nicht vorhanden.

    ein kleines bisschen kann ich das nachvollziehen. und wie ich grad im wiki nachschaue, fällt mir auch auf, das die anfangsbuchstaben ja für etwas stehen. danke ringo32 :)

  • ich glaube ich habs verstanden.

    pacman -S gvfs-afc
    pacman -S gvfs-gphoto2
    pacman -S gvfs-mtp

    ist nicht -> pacman -S gvfs-afc gvfs-gphoto2 gvfs-mtp

    ich hab nämlich alle einzeln ausgeführt und bekam immer: ‘Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)’ wenn ich die aber hintereinander geschrieben hätte, hätte es funktioniert? und -> pacman -S gvfs-afc gvfs-gphoto2 gvfs-mtp gvfs-whatever = pacman -S $(pacman -Qsq gvfs) ?

  • as gvfs si musse nicht einzeln es ist as pacman -S xxx xxx xxx , gvfs-afc wilst gere version 9 beispiel, mar gvfs ist 8…das gahr nicht gut. sie mache pacman -S gvfs also nicht maar pacman -S xxx xxx mache dich.

  • hmm … ich freu mich schon auf den nächsten dateikonflikt :D

  • @gutgelaunt said in Dateikonflikt Pacman-Update:

    hmm … ich freu mich schon auf den nächsten dateikonflikt :D

    der est viele keind datakonflikten, as beispeil eine pakket teilt in zwei dan si habe also einde datakonflikt. dan sie kahn pacman -Qo such for dich data …

    Deutsche wiki pacman is keine outdated.

    Forum gut bron to suche hilfe :)

  • ich werd mich garantiert noch oft melden. ^^
    natürlich nur, wenn ich überhaupt nicht mehr weiter weiß. vieles ist gut dokumentiert find ich ^^

pacman-update1 dateikonflikt1 Posts 14Views 134
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.