• USB 3.0/2.0 refuse to work.

    I’ve recently installed Antergos on my desktop PC after a successful install on laptop. I’m so far loving it on laptop (I found it very comfortable), not so much on desktop.

    My problem is as follows: During the installation process it took me a while to recognize that the USB ports on my motherboard (a Gigabyte F2A88X-UP4) weren’t working properly outside of the 1.0 ones (installation got stuck on white splash screen when I plugged it on the other ones, it recognised the drive to boot, but not after 30 secs according to the non-graphical fallback). After a successful installation I’ve tried a few things: disabling USB Legacy Support, disabling EHCI and xHCI handoffs, to no avail. Do I need to download any package for my other ports to work?

    If it’s of any use, I’m on an AMD A10-5600K with 16GB DDR3 RAM and a Radeon R7 240 video card. I apologize beforehand if the post comes off as illiterate, I’m still green when it comes to the technical Linux/Arch stuff. Thanks in advance!

  • @kamenriderflora
    AFAIK, you don’t need to download any additional packages for the USB ports.
    USB ports should work out of the box.
    So it sounds like a hardware or firmware issue

    BIOS settings may really have an impact.
    Also, while talking about the BIOS, BIOS update might help if your BIOS is outdated.

  • @manuel said in USB 3.0/2.0 refuse to work.:

    BIOS settings may really have an impact.

    Indeed it was a firmware thing! I had to update the BIOS (it was three updates behind) but I had to reinstall Antergos since the new BIOS wouldn’t recognise it.

    Now all ports work without trouble, my apologies!

  • @kamenriderflora
    Nothing to apologize, great that it works now!
    If you feel this thread is now solved, would you please mark it as such. 😃

  • @kamenriderflora
    My old pc has a motherboard that simply can’t boot some usb drives, and doesn’t matter if they are USB 1.0 or 2.0. Some boot a linux distro just fine, some are not recognized to boot and some freeze the bios startup screen, needing force shutdown. So far none USBs managed to boot windows from usb drive, weird, but that’s it.

usb117 work6 3.02.01 refuse1 Posts 5Views 222
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.