• Login manager (SDDM) shows monospaced font


    Hi

    I use KDE Plasma 5.15.2 desktop environment with SDDM login manager.
    Font rendering was damaged on my system after I change font settings in System Settings > Font, I needed to remove fonts.conf file to fix the problem.
    However SDDM login manager is still showing the fonts incorrectly, like this screenshot.

    How can I fix login manager fonts?

  • do you use a custom theme for sddm?

  • @joekamprad said in Login manager (SDDM) shows monospaced font:

    do you use a custom theme for sddm?

    No, I use beeeze theme.
    I tested other themes, but the problem persists.

    Breeze theme looks fine when tested with

    sddm-greeter --test-mode --theme /usr/share/sddm/themes/breeze
    
  • Monospaced fonts also look horrible in Firefox and Thunderbird.
    I need to reset font settings completely.

  • may you have qt5ct installed? as this is known to do such issues on QT Desktop environments?
    (it is to configure qt-apps using inside GTK-Environments)

  • @joekamprad said in Login manager (SDDM) shows monospaced font:

    may you have qt5ct installed? as this is known to do such issues on QT Desktop environments?
    (it is to configure qt-apps using inside GTK-Environments)

    qt5ct is not installed.

  • as far as i know, sddm has no font configuration on its own… and as you say you have the same issue inside firefox …

  • I already solved the problem with Firefox by changing its own font settings.

  • Try changing the theme to something else.
    Logout, then login back, change the SDDM theme back to what you want.
    This may fix the issue with fonts.

  • Solarized theme works, but I can’t use it because it has no dropdown to select different user accounts. All other themes installed here have the same problem.

    I have just noticed that libreoffice also has horrible font rendering.

  • fc-cache command gives me this error

    Fontconfig error: Cannot load default config file
    

    Reinstalling fontconfig solves both this error message and the problem with the fonts of the login manager.
    However the fonts after login looks horrible. Changing settings in system settings and even in the preferences of the internet browsers has no effect.

    I remember that I followed the instrutions of the link below to improve the font rendering a few days after install my system, maybe it’s a cause of my problems.
    https://www.reddit.com/r/archlinux/comments/5r5ep8/make_your_arch_fonts_beautiful_easily/

    Can anyone say how to undo the following symbolic links please?

    sudo ln -s /etc/fonts/conf.avail/70-no-bitmaps.conf /etc/fonts/conf.d
    sudo ln -s /etc/fonts/conf.avail/10-sub-pixel-rgb.conf /etc/fonts/conf.d
    sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d

  • @Strangiato said in Login manager (SDDM) shows monospaced font:

    sudo ln -s /etc/fonts/conf.avail/70-no-bitmaps.conf /etc/fonts/conf.d
    sudo ln -s /etc/fonts/conf.avail/10-sub-pixel-rgb.conf /etc/fonts/conf.d
    sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d

    sudo rm /etc/fonts/conf.d/70-no-bitmaps.conf and so on would remove the links.

  • /etc/fonts/conf.d/70-no-bitmaps.conf

    is a font config file.

    I already solved the problem creating a new user account.
    Font rendering is correct now.

  • There should only be links to files in /etc/fonts/conf.d
    rm will only remove the link but keeps the original file as it is.
    For example on my system

    $ ls -l /etc/fonts/conf.d
    total 4
    lrwxrwxrwx 1 root root  44 Oct  5 05:06 10-hinting-slight.conf -> /etc/fonts/conf.avail/10-hinting-slight.conf
    lrwxrwxrwx 1 root root  48 Oct  5 05:06 10-scale-bitmap-fonts.conf -> /etc/fonts/conf.avail/10-scale-bitmap-fonts.conf
    lrwxrwxrwx 1 root root  46 Feb 16  2018 20-unhint-small-dejavu-sans.conf -> ../conf.avail/20-unhint-small-dejavu-sans.conf
    lrwxrwxrwx 1 root root  51 Feb 16  2018 20-unhint-small-dejavu-sans-mono.conf -> ../conf.avail/20-unhint-small-dejavu-sans-mono.conf
    ....
    ....
    ....
    

    You can see the -> pointing to the original file in …/conf.avail

login135 manager80 sddm15 shows10 Posts 14Views 184
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.