• No longer able to see any wifi networks - Gnome


    I’m not sure if this is because a recent update, but I have not changed any internal settings on my dilapidated laptop.

    [[email protected] yeep]# wifi-menu
    Scanning for networks... failed
    No networks found
    

    Any thoughts on what I can test to find the issue?

    Thank you!

  • @YeeP
    Please give some info about your machine.
    For example, install AUR package inxi and show here the output of this command:

    inxi -Fc0
    
  • @manuel Here you go!

    [[email protected] ~]$ inxi -Fc0
    System:
      Host: derp Kernel: 4.20.12-arch1-1-ARCH x86_64 bits: 64 
      Desktop: Gnome 3.30.2 Distro: Antergos Linux 
    Machine:
      Type: Laptop System: TOSHIBA product: Satellite L855 v: PSKFUU-030003 
      serial: <root required> 
      Mobo: TOSHIBA model: Portable PC v: MP serial: <root required> 
      UEFI [Legacy]: Insyde v: 6.70 date: 04/15/2013 
    Battery:
      ID-1: BAT0 charge: 46.9 Wh condition: 46.9/47.5 Wh (99%) 
    CPU:
      Topology: Quad Core model: Intel Core i7-3630QM bits: 64 type: MT MCP 
      L2 cache: 6144 KiB 
      Speed: 1197 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 1198 2: 1197 
      3: 1197 4: 1199 5: 1197 6: 1197 7: 1197 8: 1198 
    Graphics:
      Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
      Display: x11 server: X.Org 1.20.3 driver: intel 
      unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz, 1920x1080~60Hz 
      Message: Unable to show advanced data. Required tool glxinfo missing. 
    Audio:
      Device-1: Intel 7 Series/C216 Family High Definition Audio 
      driver: snd_hda_intel 
      Sound Server: ALSA v: k4.20.12-arch1-1-ARCH 
    Network:
      Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx 
      IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: 00:8c:fa:27:6f:91 
      Device-2: Realtek RTL8723AE PCIe Wireless Network Adapter 
      driver: rtl8723ae 
      IF: wlp2s0 state: down mac: c2:15:db:97:11:02 
    Drives:
      Local Storage: total: 3.41 TiB used: 2.34 TiB (68.5%) 
      ID-1: /dev/sda vendor: Toshiba model: MQ01ABD075 size: 698.64 GiB 
      ID-2: /dev/sdb type: USB vendor: Seagate model: Expansion Desk 
      size: 2.73 TiB 
    Partition:
      ID-1: / size: 678.52 GiB used: 68.71 GiB (10.1%) fs: ext4 dev: /dev/sda2 
      ID-2: /boot size: 486.8 MiB used: 60.0 MiB (12.3%) fs: ext4 dev: /dev/sda1 
      ID-3: swap-1 size: 7.78 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
    Sensors:
      System Temperatures: cpu: 52.0 C mobo: N/A 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 266 Uptime: 23h 44m Memory: 15.55 GiB used: 2.46 GiB (15.8%) 
      Shell: bash inxi: 3.0.30 
    
  • @YeeP said in No longer able to see any wifi networks - Gnome:

    rtl8723ae

    Ok, you have a Realtek 8723ae, which should work out of the box.

    What’s the output of rfkill? It should look something like this:

    [[email protected] ~]$ rfkill
    ID TYPE      DEVICE      SOFT      HARD
     0 wlan      phy0   unblocked unblocked
     1 bluetooth hci0   unblocked unblocked
    

    If it looks more like this:

    [[email protected] ~]$ rfkill
    ID TYPE      DEVICE      SOFT      HARD
     0 wlan      phy0     blocked unblocked
     1 bluetooth hci0   unblocked unblocked
    

    then you need to unblock your wireless network. The command is “rfkill unblock all”

    Failing that, have you tried the solutions listed in the Arch wiki?
    https://wiki.archlinux.org/index.php/Wireless_network_configuration#rtl8723ae/rtl8723be

  • @TaraF Here is the rfkill output:

    [[email protected] ~]$ rfkill
    ID TYPE      DEVICE                 SOFT      HARD
     0 bluetooth Toshiba Bluetooth unblocked unblocked
     1 bluetooth hci0              unblocked unblocked
     2 wlan      phy0              unblocked unblocked
    
    

    I have looked at the document you sent, but I have no errors related to powersave. Wifi was working great until a recent update. I guess I am of the opinion right now that something has changed.

    You are correct, out of the box, my wifi worked flawlessly.

    Thank you for any ideas.

  • I see that the wlp2s0 state is down:

    [[email protected] ~]$ ip link
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
        link/ether 00:8c:fa:27:6f:91 brd ff:ff:ff:ff:ff:ff
    3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
        link/ether 66:5c:2e:ac:19:64 brd ff:ff:ff:ff:ff:ff
    
    
  • @YeeP
    Maybe you have accidentally disabled wifi? Is there a physical switch? Or are the wireless network connections still set up OK? Wifi password’s OK?

    If that doesn’t help, you could try the LTS kernel.

  • @manuel Nope no physical switch on this laptop for wifi. Just an internal setup. I used to have it setup as a dual boot, and with that I could test both sides. Alas, I eliminated windows from this machine recently and made it a pure linux one. I could boot up with a live antergos disc to see if wifi works there.

    Can I change Kernels without reinstalling Antergos?

  • @YeeP
    In my case the networkmanager 1.14.6 stopped connect, I downgraded to 1.14.5 then now 1.14.7 is available which works without any problem. Could it be same problem maybe?

  • @YeeP

    Can I change Kernels without reinstalling Antergos?

    Yes. The LTS kernel can be installed with command

    sudo pacman -S linux-lts linux-lts-headers     # headers is optional
    

    and after reboot, select LTS kernel from the additional options of the grub menu.

    BTW, downgrading may help, but that’s just a temporary workaround until the real problem is resolved.

  • @Edwin-Foss
    Wow, that really got me excited, but unfortunately I have 1.14.7 already. :(

    [[email protected] ~]$ pacman -Q --info networkmanager
    Name            : networkmanager
    Version         : 1.14.7dev+3+g353743b99-1
    Description     : Network connection manager and user applications
    Architecture    : x86_64
    URL             : https://wiki.gnome.org/Projects/NetworkManager
    Licenses        : GPL2  LGPL2.1
    Groups          : gnome
    Provides        : None
    Depends On      : libnm  libnm-glib  iproute2  polkit  wpa_supplicant  libmm-glib  libnewt  libndp  libteam  curl  bluez-libs  libpsl  audit
    Optional Deps   : dnsmasq: connection sharing
                      bluez: Bluetooth support [installed]
                      ppp: dialup connection support [installed]
                      modemmanager: cellular network support [installed]
                      iwd: wpa_supplicant alternative
    Required By     : network-manager-applet  vpndemon
    Optional For    : libproxy
    Conflicts With  : None
    Replaces        : None
    Installed Size  : 12.85 MiB
    Packager        : Jan Alexander Steffens (heftig) <[email protected]>
    Build Date      : Tue 26 Feb 2019 03:39:16 PM MST
    Install Date    : Tue 26 Feb 2019 05:10:20 PM MST
    Install Reason  : Explicitly installed
    Install Script  : No
    Validated By    : Signature
    

    I will try falling back to 1.14.5 as a test.

  • @YeeP said in No longer able to see any wifi networks - Gnome:

    I will try falling back to 1.14.5 as a test.

    That was a bust, still no wifi networks show in the network manager. The 26th on those updates sure sounds familiar though as far as when I first noticed I didn’t have any networks available.

  • @YeeP

    Add the following to file /etc/modprobe.d/rtl8723ae.conf:

    options rtl8723ae fwlps=0
    

    More at https://wiki.archlinux.org/index.php/Wireless_network_configuration#rtl8723ae/rtl8723be

  • @manuel said in No longer able to see any wifi networks - Gnome:

    options rtl8723ae fwlps=0

    [[email protected] ~]$ ls /etc/modprobe.d/
    i915.conf  nvdimm-security.conf
    [[email protected] ~]$ sudo vim /etc/modprobe.d/rtl8723ae.conf
    [sudo] password for yeep: 
    [[email protected] ~]$ cat /etc/modprobe.d/rtl8723ae.conf
    options rtl8723ae fwlps=0
    

    Rebooting just in case…

    EDIT: No luck there either. I will download a live copy of antergos at work today and burn it to a flash drive just to test and see if I have wifi with an “unchanged” copy. Thanks to everyone for trying to help. I did scan the journalctl for a bit, even grepped it for ‘wlp2s0’, no clues yet.

  • @YeeP
    But did you try the LTS kernel?

  • @manuel No, not yet. I just kind of feel like this is some package upgrade that got me. I am trying to figure out what the package in question is.

    Here is a screen shot from the live antergos usb. Connected to my network no problem. So at least I know this is not a hardware issue.

    wifi.png

    I will try the kernel change.

  • @YeeP
    It may well be a kernel update issue, that’s why testing with another kernel might help.

  • @manuel I installed the LTS kernel and went into the options menu while in Grub, I did not see any specifications as to which kernel would be loaded. Do I need to manually add an additional option in the grub config file to boot into the LTS kernel?

  • @manuel LTS kernel did not fix the problem, however, the “fallback” selection in grub does have working wifi.

  • @YeeP
    That fallback thing sounds like reinstalling linux might help:

    sudo pacman -S linux
    
gnome361 wifi151 longer18 networks3 Posts 20Views 141
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.