• Top bar using bold font in gnome


    Hi,

    I’ve just installed Antergos in a new SSD and I have realized that there is something wrong with my Numix theme. The top bar shows all the texts in bold, also many text that used to be regular are now bold.

    How can I fix this? Is there anyway I can adjust the theme? I don’t know what happened, in my updated version of antergos the texts are still using the regular font.

    I can provide images if necessary.

    Thanks in advance!

  • Have you try to change the font settins in the tweak tool?

  • @Bryanpwo said in Top bar using bold font in gnome:

    Have you try to change the font settins in the tweak tool?

    I have. Changing the only font which is bold doesn’t fix the problem.

  • You can edit the theme here -

    /usr/share/themes/THEMENAME/gnome-shell/gnome-shell.css

    You’ll have to search through to find any relevant code.

  • “top bar” is handled by shell theme

  • Could you provide the image, so we know what you’re talking about?

  • @anivegmin said in Top bar using bold font in gnome:

    You can edit the theme here -

    /usr/share/themes/THEMENAME/gnome-shell/gnome-shell.css

    You’ll have to search through to find any relevant code.

    I have look inside that file, but I can’t find anything “relevant”.

    @Bryanpwo said in Top bar using bold font in gnome:

    Could you provide the image, so we know what you’re talking about?

    Now the top bar is shown like this:
    ebdb4d54-07d6-4cef-89ae-2dffd5350034-image.png
    And some apps have the same issue, for example, telegram:
    b1f11c1a-def9-4771-8a10-cb0a3b2c4498-image.png

    They used to be like this:
    8f2e156c-fa5e-4d09-9842-1ba633d2c942-image.png
    84911a77-c078-4f40-97c6-f90aed66546c-image.png

  • It looks like you have the default shell theme running, just switch themes in the tweak tool.

  • I have Numix-Frost as my Gnome Shell theme. It shouldn’t be using that bold font, right?

  • default shell-theme:
    Bildschirmfoto vom 2019-02-24 22-07-04.png
    numix-frost:
    Bildschirmfoto vom 2019-02-24 22-07-25.png

  • @joekamprad Both of the images I posted are taken in Antergos’ installations using numix-frost themes, I just don’t know why there is such difference and how to remove the bold in the font.

  • When I compare the theme files (/usr/share/themes/Numix-Frost/gnome-shell/gnome-shell.css) from my old installation and my new one, I get no diffs, so they are exactly the same. But the theme it is not, what am I missing?

  • as @Bryanpwo say it seems you where using the default theme, may be caused by some misconfiguration or rights problem

  • In /usr/share/themes/Numix-Frost/gnome-shell/gnome-shell.css

    at the beginning -

    /* Text Styles */

    /* default text style */
    stage {
    font-family: Open Sans;
    font-size: 10pt;
    color: white;
    }

    you could try reducing the font-size value.

    I’ve done this is my Materia theme to adjust overall font size/appearance.

  • @joekamprad I have both installations using the same theme, with exactly the same gnome-shell.css file. I don’t have any misconfiguration, all that I have is a different font type, and I would like to know why…

    @anivegmin Font size, is the same as it was before. It could be a possible solution but I still don’t understand where the difference is coming from.

  • no need to tinkering the css file, as it seems it do not get the shell theme at all, and instead using gnome shell default theme.
    do you try to install any other gnome shell theme to see if choosing this changing the font?

    may try arc-gtk-theme

  • @joekamprad I’d like to use Numix-Frost, so I haven’t tried any other theme. If I set the default gnome theme, the top bar font changes but the apps texts don’t (for example, telegram does not change). It is a completely clean install, so I cannot understand where is all of this coming from.

  • The top bar is a different element from window dressing.

    I can check what Numix Frost looks like on my laptop when I get home. But it may actually be the theme itself.

    There’s lots of options out there on gnome-look… the easiest solution might be to find a different theme that looks similar but doesn’t have this feature.

  • I might not be explaining myself. I have two antergos installations, same theme, different aspect. If I get the theme from installation #1 and use it in installation #2, the way it looks on #2 is different from #1.

  • Well, I’ve pasted my old fonts into the path /usr/share/fonts and the issue has disspeared. The only question left is which of the fonts fixed the issue.

    What font is used for the status bar text in the Numix Frost theme?

font36 top15 bar9 bold1 Posts 21Views 284
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.