• Warning [cannot open file {locale}-std] during kernel update


    I’ve noticed lately this warning issued during kernel update. While the system is functional I was wondering if there is something I can do to stop the warning from ocuring.
    I’m concerned about the line cannot open file ro-std.

    Screenshot_2019-02-22_10-17-14.jpg

    Here is a screenshot of my keyboard settings:
    Screenshot_2019-02-22_09-32-23.png
    And here is the $ locale output:

    LANG=en_US.utf8
    LC_CTYPE="en_US.utf8"
    LC_NUMERIC="en_US.utf8"
    LC_TIME="en_US.utf8"
    LC_COLLATE=en_US.UTF-8
    LC_MONETARY="en_US.utf8"
    LC_MESSAGES="en_US.utf8"
    LC_PAPER="en_US.utf8"
    LC_NAME="en_US.utf8"
    LC_ADDRESS="en_US.utf8"
    LC_TELEPHONE="en_US.utf8"
    LC_MEASUREMENT="en_US.utf8"
    LC_IDENTIFICATION="en_US.utf8"
    LC_ALL=
    

    System information:

                     `.-/::/-``                
                   .-/osssssssso/.               
                  :osyysssssssyyys+-             OS: Antergos 
               `.+yyyysssssssssyyyyy+.           Kernel: x86_64 Linux 4.19.24-1-lts
              `/syyyyyssssssssssyyyyys-`         Uptime: 34m
             `/yhyyyyysss++ssosyyyyhhy/`         Packages: 1115
            .ohhhyyyyso++/+oso+syy+shhhho.       Shell: bash 5.0.0
           .shhhhyso-/+++/-ss+++yyy+shhhhs.      Resolution: 3520x1080
          -yhhhh-/+++++/-ssso+++yyys+ohhddy:     DE: XFCE4 4.12
         -yddhhy-/+++/-syyss++++yyyyooyhdddy-    WM: Xfwm4
        .yddddhso++osyyyyys+++++yyhhsoshddddy`   WM Theme: Cyanogen
       `odddddhyosyhyyyyyy++++++yhhhyosddddddo   GTK Theme: Numix-Frost-Light [GTK2]
       .dmdddddhhhhhhhyyyo+++++shhhhhohddddmmh.  Icon Theme: Papirus-Maia
       ddmmdddddhhhhhhhso++++++yhhhhhhdddddmmdy  Font: Segoe UI 10
       dmmmdddddddhhhyso++++++shhhhhddddddmmmmh  CPU: Intel Core i5-3317U @ 4x 2.6GHz [55.0°C]
       -dmmmdddddddhhyso++++oshhhhdddddddmmmmd-  GPU: Mesa DRI Intel(R) Ivybridge Mobile 
        .smmmmddddddddhhhhhhhhhdddddddddmmmms.   RAM: 2221MiB / 11631MiB
          `+ydmmmdddddddddddddddddddmmmmdy/.    
             `.:+ooyyddddddddddddyyso+:.`
    
  • @nate_x
    Could you show the output of command:

    journalctl -b0
    

    You can use e.g. pastebin and show the URL here.

  • @nate_x
    Couldn’t find anything related there…

    What do you have in the HOOKS variable of file /etc/mkinitcpio.conf?

  • HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck"
    

    Been doing a bit of research starting off from your question above (googled “HOOKS keymap”), and found
    /etc/vconsole.conf to have the following content:

    $ cat /etc/vconsole.conf
    KEYMAP=ro-std
    FONT=ter-v14b
    

    After even more research (googled “vconsole.conf KEYMAP”) :

    $ localectl list-keymaps | grep ro
    croat
    cz-lat2-prog
    dvorak-programmer
    euro
    euro1
    euro2
    mac-euro
    mac-euro2
    ro
    ro_std
    ro_win
    sk-prog-qwerty
    sk-prog-qwertz
    

    Apparently there is a typo in vconsole.conf as it requests ro-std instead of ro_std (this was automatically added during language install I guess, so must be a bug)

  • @nate_x
    So does it work better if you change the name? If so, then we should inform the @developers so that they can fix it or report upstream perhaps.

  • @nate_x said in Warning [cannot open file {locale}-std] during kernel update:

    localectl list-keymaps | grep ro

    then simple correct it:

    For convenience, localectl may be used to set console keymap. It will change the KEYMAP variable in /etc/vconsole.conf and also set the keymap for current session:

    sudo localectl set-keymap --no-convert ro_std
    

    The --no-convert option can be used to prevent localectl from automatically changing the Xorg keymap to the nearest match.

  • Reinstalling kernel went smooth after editing vconsole.conf and setting KEYMAP=ro_std

    Screenshot_2019-02-22_10-17-14_cr.jpg

    @joekamprad I guess you are right, sudo localectl set-keymap --no-convert ro_std would do the trick even better than just editing vconsole.conf (in case there are other places where the KEYMAP is being stored)

    @manuel thanks for your input. your questions lead me in the right direction.

during35 warning11 locale-std]1 [cannot1 Posts 8Views 34
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.