• Kernel Panic After My Pacman Updating Being Interrupted


    A few months ago I updated my Antergos through the Pacman application. but at that moment suddenly the electricity in my house died. a few moments later I tried to revive my PC and I got a Kernel Panic problem.
    So now I want to fix my Antergos through a Live CD for archiving and completing the updates. but after doing :

    note: My Antergos partition is on sda6

    mount /dev/sda6 /mnt
    

    then try

    arch-chroot /mnt
    

    I got this problem:

    [[email protected] ~] $ su
    [root @ antergos ant-18] # mount /dev/sda6 /mnt
    [root @ ant-18 antergos] # arch-chroot /mnt
    chroot: failed to run command '/bin /bash': Exec format error
    [antergos root @ ant-18] #
    

    How to fix this? some article said it is about matching the architecture between host environment and chroot environment.
    but i’ve check that my Antergos system on HDD was 64 bit and my liveCD is 64 bit too. but still didn’t work.

  • @wilmanzendart

    First try what @joekamprad said…

    Just in case, instead of switching to su you can use sudo. I know it sounds dumb, but i’ve never manager to use su directly in antergos iso, i don’y know how you did it…

    I also always use the normal terminal…

    • In the normal terminal you can use sudo su just fine.

    • if still doens’t work, then maybe bash is corrupted in your installed system, let’s hope not.

  • try sudo -i also

  • @trytip

    -i, --login
    Run the shell specified by the target user's password database entry as a login shell. This means that login-specific resource files such as .profile, 
    
    .bash_profile or .login will be read by the shell. If a command is specified, it is passed to the shell for execution via the shell's -c option.
    
     If no command is specified, an interactive shell is executed. sudo attempts to change to that user's home directory before running the shell. 
    
    The command is run with an environment similar to the one a user would receive at log in. 
    
    Note that most shells behave differently when a command is specified as compared to an interactive session; consult the shell's manual for details. 
    
    The Command environment section in the sudoers(5) manual documents how the -i option affects the environment in which a command is run when the sudoers policy is in use.
    
    
  • @wilmanzendart
    Could you show the output of command

    lsblk -fm
    

    after booting with the USB installer stick? No need to chroot for that.
    Then we’ll see what partitions you have.

  • You could also, please, paste here your:

    cat /etc/fstab

  • I’m sorry to not reply on this, because due to my work time. days ago, one day after i make this post, i do fresh install on my Antergos. but, i really appreciate your replies on this topic. thank you very much everyone.

  • @wilmanzendart
    It is kind of amazing how many problems are best and easiest solved by reinstalling :)

kernel141 pacman120 panic10 updateing1 Posts 9Views 130
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.