• Low disk Space warning when updateing


    Well, this is new for me 😕
    Went to install today’s updates and got

    Error: Partition / too full: 69594 blocks needed, 386 blocks free
    Failed to commit transaction:
    not enough free disk space
    

    My root partition is 30GB but only 317MB left.

    Not much information I’m finding in searches, but I did recently
    have issues with baloo_file which I guess has something to do with metadata cataloging or something.

    Before I do something stupid & un-doable, I need help.
    Could there be a mass of temp files someplace using up all the space?

  • df -hT
    ?
    sudo paccache -d
    ?

  • @judd said in Low disk Space warning when updateing:

    sudo paccache -d

    I just got back from a reboot…
    It figures, Right after I posted I found using another search term gave me

    “You can have pacman clean its cache, keeping only the current version and one previous version, by running:”

    sudo pacman -Sc
    

    This cut the usage of root in half to 15GB

    $ df -hT
    Filesystem     Type      Size  Used Avail Use% Mounted on
    dev            devtmpfs  5.9G     0  5.9G   0% /dev
    run            tmpfs     5.9G  1.3M  5.9G   1% /run
    /dev/sda2      ext4       29G   15G   15G  51% /
    tmpfs          tmpfs     5.9G   36M  5.8G   1% /dev/shm
    tmpfs          tmpfs     5.9G     0  5.9G   0% /sys/fs/cgroup
    tmpfs          tmpfs     5.9G   40M  5.8G   1% /tmp
    /dev/sda1      vfat      253M  364K  252M   1% /boot/efi
    /dev/sda3      ext4      423G  190G  212G  48% /home
    tmpfs          tmpfs     1.2G   12K  1.2G   1% /run/user/1000
    /dev/sdb1      ext4      1.8T  267G  1.5T  16% /run/media/major/Apocalypse
    

    I’m guessing it looks better now lol

    but, cmd not found, curious as to why?

    $ sudo paccache -d
    sudo: paccache: command not found
    

    @judd
    I didn’t expect a response quite so quick so I thank you, IMMENSELY!

    I’m going to mark this solved, however I do have another question this brings me.
    Is it possible to make root partition larger, without deleting it, or a reinstall?

    Why is root so big anyway, is it the desktop?

  • @Firespray said in Low disk Space warning when updateing:

    Is it possible to make root partition larger, without deleting it, or a reinstall?

    Resize a partition / root, as power can be, but it is not advisable at all.

    but, cmd not found, curious as to why?

    https://wiki.archlinux.org/index.php/Pacman#Cleaning_the_package_cache

  • @Firespray
    paccache is included in package pacman-contrib.

    Could you show the output of

    df
    

    Also the du command is useful, it shows the disk usage.
    See

    man du
    
  • @manuel said in Low disk Space warning when updateing:

    Also the du command is useful, it shows the disk usage.
    See
    man du

    @Firespray
    As recommended by @manuel, in addition to reading man du, you could paste the result of:

    du /var/log/journal -h

    ?

  • @judd said in Low disk Space warning when updateing:

    du /var/log/journal -h

    $ df
    Filesystem     1K-blocks      Used Available Use% Mounted on
    dev              6102092         0   6102092   0% /dev
    run              6110580      1280   6109300   1% /run
    /dev/sda2       30106488  15352656  14430248  52% /
    tmpfs            6110580    128360   5982220   3% /dev/shm
    tmpfs            6110580         0   6110580   0% /sys/fs/cgroup
    tmpfs            6110580     45932   6064648   1% /tmp
    /dev/sda1         258095       364    257731   1% /boot/efi
    /dev/sda3      443152616 199450812 221121120  48% /home
    tmpfs            1222116        56   1222060   1% /run/user/1000
    
    $ du /var/log/journal -h
    8.0K    /var/log/journal/remote
    817M    /var/log/journal/3ba44611d0394c22b20710fbad290693
    817M    /var/log/journal
    
    

    hmmm, that’s a big journal?

  • @Firespray said in Low disk Space warning when updateing:

    hmmm, that’s a big journal?

    If clear 817M is too much for the journal.
    You can erase it and leave nothing but a value of about 8k only.
    Personally I do it the way he taught me at the time @karasu

    sudo and the file manager that you use, in my case pcmanfm, then it would be:
    sudo pcmanfm or nautilus or thunar etc …
    then in graphic form, go to var → log → journal, when you get to journal do not delete the journal file, click on it and delete what is inside the file, and then exit root with Ctrl + c.
    Restart and when you return to your session, type the du /var/log/journal -h command again in the console and verify the difference with the previous 817M.

  • Inside /var/log/journal/

    I have 2 folders
    remote
    &
    3ba44611d0394c22b20710fbad290693

    remote is empty
    delete folder 3ba44611d0394c22b20710fbad290693 or delete the contents of 3ba44611d0394c22b20710fbad290693 ?

    or

    inside folder 3ba44611d0394c22b20710fbad290693 is a file called system.journal and a whole bunch of files called [email protected] number.journal
    leave system.journal and a few of the [email protected] number.journal files and delete the rest?

  • Except the journal file, everything inside, delete it.

    After this,
    edit the file /etc/systemd/journald.conf and modify the following line:
    SystemMaxUse=50M to limit its size.

  • @Firespray said in Low disk Space warning when updateing:

    du /var/log/journal -h

    $ du /var/log/journal -h
    8.0K    /var/log/journal/remote
    41M     /var/log/journal/3ba44611d0394c22b20710fbad290693
    41M     /var/log/journal
    
    

    Also un-commented the SystemMaxUse= in /etc/systemd/journald.conf
    and added 50M

    Got root down to 49%

    $ df
    Filesystem     1K-blocks      Used Available Use% Mounted on
    /dev/sda2       30106488  14578508  15204396  49% /
    
    

    Still seems high, but then again, I’m not an expert and
    don’t know what all goes in root, but very happy to have it limited now.

    Maybe someday there will be a system tweaks GUI you can change things in lol

    have paccache in now

    $ sudo paccache -d
    ==> no candidate packages found for pruning
    

    If you think of any other places log buildup or old backup
    files may be hiding, let me know.
    Thanks for your help in this, other things have seemed to
    work correctly since the purge.
    Should be good for now… as long as nothing explodes lol

  • @Firespray said in Low disk Space warning when updateing:

    I’m not an expert

    Neither am I, I always try to learn, just that.

  • @Firespray

    Is it possible to make root partition larger, without deleting it, or a reinstall?

    Yes it is, but how easy it is to do depends on your disks and their partitioning.

    To evaluate that, could you show the output of these commands:

    lsblk -fm
    sudo fdisk -l
    

    BTW, this thread is now on another topic, so could you make another thread?
    That would help later readers.

  • if you use pamac you can go in preferences and disable Check available disk space. i disabled that option long ago when i received warnings like yours even though the space was available.

  • @trytip
    Well that depends on which space is low. Sometimes it is /tmp which is of tmpfs type. There is an easy way to solve it, described in the Arch wiki.

disk15 warning12 low10 space8 Posts 16Views 208
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.