• Aisleriot Not Working with Xfce


    Suddenly the aisleriot solitaire program will not launch in Xfce. Uninstalling and reinstalling, as well as logging out and back in do not help. Is anyone else experiencing this?

  • @rocket
    Hi,
    just saying something “is not working” doesn’t help much.
    You should provide more info, for example logs.
    In this case, what is the output if you start that program in the terminal?

    sol
    
  • Manuel, thanks for the response. What I said was it does not launch. That is, when you click on the icon nothing happens. When you use the terminal (sol), the output is:
    Non UTF-8 locale (ANSI_X3.4-1968) is not supported!

    When I type “locale” into the terminal, the output is:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=en_US.UTF-8
    LC_CTYPE=“en_US.UTF-8”
    LC_NUMERIC=“en_US.UTF-8”
    LC_TIME=“en_US.UTF-8”
    LC_COLLATE=“en_US.UTF-8”
    LC_MONETARY=“en_US.UTF-8”
    LC_MESSAGES=“en_US.UTF-8”
    LC_PAPER=“en_US.UTF-8”
    LC_NAME=“en_US.UTF-8”
    LC_ADDRESS=“en_US.UTF-8”
    LC_TELEPHONE=“en_US.UTF-8”
    LC_MEASUREMENT=“en_US.UTF-8”
    LC_IDENTIFICATION=“en_US.UTF-8”
    LC_ALL=

    Any assistance would be appreciated.

  • @rocket said in Aisleriot Not Working with Xfce:

    Non UTF-8 locale (ANSI_X3.4-1968) is not supported!

    localectl
    

    may related to something you tried on setting keymap before?

  • That is possible, joekamprad. When I installed I accidentally selected Australian English, but later changed it. Output for localectl is:
    System Locale: LANG=en_US.UTF-8
    VC Keymap: us
    X11 Layout: us
    I could reinstall, I guess, if that really might be affecting the card program. Seems unlikely to me, but I am not a technical user.

  • @rocket said in Aisleriot Not Working with Xfce:

    Non UTF-8 locale (ANSI_X3.4-1968) is not supported!

    try removing settings:

    rm ~/.config/gnome-games/aisleriot
    rm ~/.config/gnome-games/aisleriot.accels
    
  • joekamprad: I was able to mess around with it using the rm commands you provided and resolve the issue. Thank-you.

xfce79 aisleriot1 Posts 7Views 67
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.