• Antergos lightdm error after update, cannot boot up


    I did a system upgrade a couple of days ago, upgrading only 3 items, and am now unable to boot Antergos XFCE. After the initial ‘240’ message I get an error:

    'Failed to start Light Display Manager. See ‘systemctl status lightdm.service for details’

    and below that:

    ‘OK Reached target Graphical Interface’.

    I tried two fixes I found on the web, by logging into grub using ctrl + alt + F2, however neither of these work.

    systemctl enable lightdm.service
    systemctl start lightdm.service
    

    -> 'error message ‘job for lightdm.service failed. Control process ended with errors’

    su
    pacman -Rncc lightdm-wellkit2-greeter
    pacman -Syy lightdm-wellkit-theme-antergos
    systemctl restart lightdm
    

    -> lightdm-wellkit2-greeter ‘target not found’ at 2nd step.

    I found an on line guide to rolling each update, which in my case shoudn’t be hard to identify if there are 3-4 updates to downgrade, however, I was unable to boot the system in single user mode by appending ‘init-/bin/bash’ to the relevant line in the grub ‘e’ menu. I got the error message ‘Cannot set terminal process group (-1). Inappropriate ioctl for device.’

    https://www.ostechnix.com/restore-broken-arch-linux-previous-working-state/

    How do I go about fixing this please? Should I try to do the rollback according to the Arch guide by running Linux from a USB stick? Or is there a way to log in from grub? I tried the fallback Antergos option from Grub but had the same problems and could not boot up.

  • Figured it out, I’m not very familiar with command line. After I read the thread below, I knew I just had to update the system from the repo and it would fix the lightdm issue. My mistake before was not using the root login to use the sudo pacman command.

    https://forum.antergos.com/topic/11353/after-update-feb-6-2019-get-message-cannot-load-lightdm-no-boot/18

    Used ctrl + alt + F2 at the lightdm failure error message
    Logged in

    Sudo sulogin
    sudo pacman -Syyu
    reboot
    
  • Bildschirmfoto vom 2019-02-09 01-26-15.png
    typo here ?

    it is called:

    lightdm-webkit2-greeter

  • @joekamprad said in Antergos lightdm error after update, cannot boot up:

    Bildschirmfoto vom 2019-02-09 01-26-15.png
    typo here ?

    it is called:

    lightdm-webkit2-greeter

    You are right! That would explain why one of the proposed fixes did not work. I was reproducing their typo. Thanks for the input.

boot-problems6 rollback3 Posts 4Views 185
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.