• GSYNC (VRR) NV-418.30 Gnome BLIT mode Issue!

    I have been trying to get gsync working under GNOME for some time now, but if you enable the indicators for it and rendering mode it does not work because its stuck in BLIT rendering mode.

    NVIDIA has specifically said gsync can’t work in blit mode, does anyone know a fix? I have tried disabling anything extra like full compos pipeline etc since those typically prevent it from working also.

    I’ve also only got a single display connected and it has had gsync working under plasma and xfce to some respect.

    Blitting mode it is called, related to glXSwapBuffers and happens if the game fails to negotiate flipping mode. Perhaps GNOME doesn’t even support flipping mode.

  • Yeah been there done that, thanks non the less.

    It seems I might have found a solution afterall? What I did was compile and install these two things and it resovled the problem for me.

    yaourt -S mutter-781835-workaround
    yaourt -S gnome-shell-performance

    Now she works fine… odd hey.

    Still you need to disable the two fullcompospipeline options which was the main way I avoided ALL tearing on my linux desktop and in games… so now there is tearing due to those not being enabled.

    I’ve read around there are solutions to that, just can’t remember what, will need to do testing.

    I got the tearing issue fixed by enabling vsync which would crash the system under XFCE and Plasma5, but works with Gnome… so that’s nice.

    Now to figure out why warthunder has a stutter issue every 15sec when using vulkan api, but that’s not gsync related I believe.

  • Great you’ve worked it out. I just have a little tip on the side for you, which is not related to your problem, install and use yay instead of yaourt as an AUR helper. Yaourt hasn’t been updated for almost two years now, yay has a similar workaround as yaourt, so there’s no learning curve.

gnome361 nv-418.301 gsync1 vrr1 Posts 4Views 69
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.