• Turn off hibernate/standby completely

    I have an issue which I’ve had before, but I can’t recall how I fixed it and I’m out of ideas.
    In short, when I turn off my monitor, my computer attempts to hibernate/standby, which is of course undesirable.
    I really need this to stop, but it seems like I’ve tried everything, like I’ve turned everything off in power manager (XFCE btw), I’ve searched for ways to disable hibernate and standby all together, without success I might add, and the result is that whenever I turn off my monitor, well most times anyways, it tried to hibernate or suspend, which inevitably results in me having to do a hard reboot.

    Please, if you’ve got any ideas, let me know.

  • moved to xfce

  • https://antergos.com/wiki/miscellaneous/how-do-i-include-system-logs-when-asking-for-help/

    we need some more system info and logs:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1

    this will auto pastebin the info we need to pastebin service and give you the link to it at the end, you can just post this one here…

  • @joekamprad said in Turn off hibernate/standby completely:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1

    That’s very nifty: https://ptpb.pw/6hDd

  • AMD CPU + a VEGA GPU ( Vega 10 XL/XT [Radeon RX Vega 56/64] (rev c1) )

    kernel: [drm:dce110_vblank_set [amdgpu]] *ERROR* Failed to get VBLANK!

    is the only error i can see in a way may related…
    is it an Ryzen CPU?

    i see there is an update for Firmware (EFI-BIOS)
    Yours: kernel: DMI: System manufacturer System Product Name/ROG STRIX X470-I GAMING, BIOS 0601 04/19/2018
    Version 1201
    2018/12/21 8.15 MBytes
    Release BIOS 1201

    If you want to update take care to follow your handbook, and take exactly the right one for your Mainboard!!

    But it is said often that resume/hibernate problems can be solved by a firmware update, as the current kernel works mostly only with latest features…

  • Well, I tried changing some setting, which didn’t help, and I’ve just succeeded updating the BIOS finally, so now the waiting game begins. I’ll be back though.

  • Well, that’d be a no. The behavior is still the same.
    think the last time I “solved” the issue by using some kernel parameter, disabling whatever is causing this, but again, can remember which.

  • I’m sorry, but I don’t understand how that would help?

    For now I’ve added kernel parameter acpi=no and am hoping for the best.

  • @zacariaz
    Those acpi settings may cause all input to stop…

  • I rather think this was my previous “solution”, but if you have any better solutions, I’m very interested.
    For now, I’d be happy to know just what’s causing the problem.
    If I turn off my monitor, my computer may or may not end up unresponsive, seemingly due to attempt to suspend or hibernate, and the same goes if I turn of my monitor via the command line. (which of course I’ve also forgotten how to do)
    I’ve tried changing every relevant (and some irrelevant) settings using the gui, I’ve tried changing acpi events manually, I’ve updated the bios and now my last hail mary is that kernel parameter.

  • @zacariaz
    It would help to know the exact model of your machine.

    Maybe some combination of the following parameters, or slightly modified:
    acpi_osi=“Windows 2009” (or some other year)

    Also this may help: https://github.com/torvalds/linux/blob/master/Documentation/admin-guide/kernel-parameters.txt

  • @manuel
    As for the exact model, it’s a DIY
    MB: ASUS ROG STRIX X470-I GAMING Bundkort - AMD X470
    CPU: AMD Ryzen 7 2700X
    GPU: ASUS Radeon RX VEGA 64 OC - 8GB HBM2
    RAM: Corsair Dominator P DDR4-3000 DC - 32GB
    SSD: Samsung 970 EVO SSD M.2 2280 - 500GB
    PSU: SilverStone SFX Series SX700-LPT
    And not that is matters, the kabinet is a
    SilverStone MILO ML08B with a modified Scythe Big Shuriken 2 Rev. B utilizing a Noctua NF-A12x15 PWM fan.

    The only issue I’ve really had is that I’m not able to use the dust filters, as it inhibits the airflow too much.
    as previously mentioned I’ve updated the BIOS to the latest version, hoping to resolve this issue, which didn’t help, and I’m running Antergos XFCE. I also have a Windows 10 installed on a separate SSD that I got for free, A Kingston something or rather, but I don’t actually use it.
    I’ve also has to modify the RAM slightly, in order to reduce height, but nothing that should cause issues, it was simply removing the top part of the cooling solution, which haven’t cause any issues as far as I’m aware.

    My monitor is some random, and temporary I might add (waiting for my samsung c49rg9 to arrive), 1080p AOC monitor, connected via DP.

    peripherals include logitech mx ergo, logitech k800, blue yeti, Vincent sv-400, xbox controller and logitech G saitek wheel, pedals and side panel, which I’ve yet to get to work.

    And that I think is all. I’ve on occasion tried to under volt the CPU, but Either it’s not exactly miracle silicon, or I have no clue what I’m doing. Regardless I’ve stopped trying.

  • I though I wrote acpi=off, but I wrote acpi=no 🤦
    Suffice to say acpi=off is not an option, so that weren’t how I solved it before.

  • @zacariaz
    As it is Ryzen, I have no experience with it, sorry.
    And as it is not a laptop, it makes it somewhat more challenging to find answers in the net.

    Arch wiki may have some useful ideas to test.

    My guess is to experiment with those acpi_osi parameters. But it is just guessing and may not help at all.

    Hopefully someone with a somewhat similar hardware can help you more.

  • Okay, so I’ve added some recommend xorg configs, kernel param amdgpu.dc=1 and ensured that acpid is actually running, which wasn’t the case.
    Here’s hoping that this somehow makes a difference.

  • @zacariaz
    Can’t wait the results … ;)

  • @manuel Seems there isn’t a solution as of yet. It is some sort of VSYNC issue, which will hopefully be fixed in kernel 4.21. I have yet to find a workaround the general problem, but in my particular case, which is basically to listen to podcasts on youtube and such, while drifting of to sleep, I avoid the issue simply by not having the video rendered, by minimizing the browser. It is of course still an issue if I forget about it, in which case I have to do a hard reboot, but that’s life I guess.

  • this is something that might be of help. If going from scratches, I’ve got a dualboot machine that wakes up after plugging a socket into the same line the machine is plugged in. Very irritating. Windows-style. Linux does quite the opposite: it keeps sleeping (no response to unnecessary system or/and hardware inputs.
    My (and ArchWiki) solution here:

    $ sudo touch etc/polkit-1/rules.d/10-disable-suspend.rules
    $ sudo gedit etc/polkit-1/rules.d/10-disable-suspend.rules

    in place of gedit here - whatever CLI or GUI text editor of choice, &insert

    polkit.addRule(function(action, subject) {
        if (action.id == "org.freedesktop.login1.hibernate" ||
            action.id == "org.freedesktop.login1.hibernate-multiple-sessions") {
            return polkit.Result.NO;

    &save & reboot
    then inspect power management policies in your distro: if GUI, just go to Parameters/Administration and see what actions are scheduled in case of display power off, correct accordingly. For ex, I’ve got notebook Cinnamon configured not to “sleep” in case lead is closed but another (HDMI-like) display is connected, hence I’ve got the possibility of using my notebook as a mediabox for everything that just connects.

turn13 completely7 Posts 27Views 358
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.