• After Update Feb. 6, 2019 Get Message Cannot Load LightDM - No Boot!


    Hello all.

    I have two (2) computers on which Antergos is installed. This is the first time I have had any problem with the operating system.

    I did a normal update today on one of the computers and, when I went to reboot, I got a message that LightDM cannot be loaded. Then the computer freezes and will not boot.

    I decided to update my second Antergos computer and I took note that LightDM was being upgraded to version 1:1.28.0-2 (I think that that’s correct). I proceeded with the upgrade and, sure enough, when I rebooted, that computer too would not boot after displaying the same message.

    I tried rebooting with all four kernel options (regular, fallback, LTS regular, and LTS fallback) and nothing worked.

    Isn’t that lovely?

    NOW what do I do (short of reinstalling the system)? I am using the XFCE version.

    I hope someone can help me boot into my computer and can tell me how to get rid of the new version of LightDM (or has some sort of fix for it).

    THANK YOU to anyone who can help me.

    Lawrence

  • Hello and don’t panic ;)
    All you have to do is reinstall the old version of lightdm from the cache.

    sudo pacman -U /var/cache/pacman/pkg/lightdm-1:1.28.0-1-x86_64.pkg.tar.xz
    
  • @Noel
    Well, I am one for panicking! Before I got your message, I started looking for an answer to this. For some reason, I could not find anything on the forum; I guess this was because of what I typed into the search box.

    But when I went to Google and typed in antergos lightdm problem, I found this answer as to what to do at the point of the computer freezing:

    Ctrl+Alt+F2
    usuario
    (password)
    $ sudo su
    systemctl stop lightdm.service
    systemctl disable lightdm.service
    pacman -S gdm [This installs gdm if it isn’t already installed]
    systemctl enable gdm.service
    systemctl start gdm

    And that worked perfectly. I now have gdm as my login. It’s an “ugly” looking screen but I don’t care as long as it works!

    Just to be on the safe side, I completely removed lightdm (and just before I did that I saw that there is another update to the version ending in 3 - but I’m not taking any more chances!).

    Now I’m going to fix that other computer.

    Thanks for writing to me. I wonder if others will have this same problem? And does anyone know if using gdm will open up a different can of worms?

  • Very glad you could fix the problem. The standard greeter of Antergos is unfortunately not recommendable because there have been problems before. I’m using lightdm-gtk-greeter because of this, but was also affected by this update.
    Unfortunately, I can’t say anything about gdm, problem reports can also be found here on the net.

  • @lhb1142 I didn’t have any cached older versions so your solution worked perfectly! I just deleted the cache a few days ago for the first time to maintain disk space… unfortunate timing.

    gonna try to install a downgraded version from the repo now

    edit:

    This bug is fixed in the next lightdm release (probably a hotfix that will be available shortly) https://bugs.archlinux.org/task/61654?string=lightdm

    edit2: just got the v3 update available in pacman! hurray!

  • fixed version 1:1.28.0-3 is already at the mirrors

  • @joekamprad
    Yes, I saw the update after I had installed gdm (and had removed lightdm). But that update wouldn’t have done any good for me; because of the flaw in lightdm, I could not boot into the system in the first place until, using gdm, I was able to boot the system so, A) I didn’t know about the update, and, B) how would I have installed it if I had known about it?. I had removed lightdm completely (but had not yet re-booted) before I saw the new update.

    If only I had waited an hour or so before updating …

    Now after reading Noel’s post “… Unfortunately, I can’t say anything about gdm, problem reports can also be found here on the net.” I am curious as to which is better - gdm or lightdm.

    I’d be very interested in reading others’ opinions.

    In my particular case, if most people think lightdm is actually the better manager, how would I go about removing gdm and get lightdm to again be the default display manager? I’ll be curious to see how one would go about doing this (though, frankly, I may want to stay with gdm, at least for the present).

    Thanks. And thanks to everyone who has responded to this post.

    Lawrence

  • @lhb1142 Wouldn’t it basically be the same steps in reverse but this time to get lightdm?

    You switch to terminal (alt ctrl f2) and stop the gdm -> disable gdm and then enable and start lightdm

    I am not sure if lightdm becomes the default automatically but you probably could uninstall gdm again (for me it was not installed beforehand). After that lightdm must become default if it is the only manager.

    I myself do not really care which manager I use as long as it does its job of starting my DE. The only issue with gdm I have at the moment is the default language setting of en instead of de. Since my password contains special letters I need to switch to de manually every bootup. Need to figure out the config of gdm or I am gonna switch back to lightdm

  • @Noel

    Hello,

    i am writing from Germany, so sorry for my bad english. Since yesterday i have the same Issue like the thread starter.

    I have tried already this line:
    sudo pacman -U /var/cache/pacman/pkg/lightdm-1:1.28.0-1-x86_64.pkg.tar.xz
    and also i replaced the tar package with the newer version
    sudo pacman -U /var/cache/pacman/pkg/lightdm-1:1.28.0-3-x86_64.pkg.tar.xz

    But still no luck here :(

    Booting with the ugly gdm is the last way out.

    Looking for help. Thanks!

  • @dimka said in After Update Feb. 6, 2019 Get Message Cannot Load LightDM - No Boot!:

    Booting with the ugly gdm is the last way out.

    Yes, GDM is sort of ugly - but it works. At least for the moment, I am keeping it. After all, for how long do you see the greeter?

    Lawrence

  • @Wandang said in After Update Feb. 6, 2019 Get Message Cannot Load LightDM - No Boot!:

    Wouldn’t it basically be the same steps in reverse but this time to get lightdm?

    I think that that’s correct. I suppose I should have to do that if there were some problem with gdm.

    But I hope there aren’t any!

    Lawrence

  • @lhb1142
    In the Arch Wiki there is a long article about LightDM, how to configure and install it.

  • @lhb1142 said in After Update Feb. 6, 2019 Get Message Cannot Load LightDM - No Boot!:

    After all, for how long do you see the greeter?

    What do you mean, the login screen? ;) The radiators of my graphics card speed up for 1 sec (this is normal) ->screen flickers (i think its a driver loading routine, also normal) and i see the light DM failed to start message.

    Meanwhile i tried pacman -S lightdm, also no success.

  • @dimka
    Downgrading to lightdm-1:1.28.0-1 only works if it is in the cache, otherwise you have to download it manually. To install the new version lightdm-1:1.28.0-3 you have to update the system with

    sudo pacman -Syu
    

    This downloads all updates and installs them.

  • @Noel said in After Update Feb. 6, 2019 Get Message Cannot Load LightDM - No Boot!:

    @dimka
    Downgrading to lightdm-1:1.28.0-1 only works if it is in the cache, otherwise you have to download it manually. To install the new version lightdm-1:1.28.0-3 you have to update the system with

    sudo pacman -Syu
    

    This downloads all updates and installs them.

    Yes. I used the tab-key to navigate to lightdm 1:1.28.0-1. The package was also in the cache, and the install routine downgraded lightdm successfully.

    Before i found this thread, i tried another steps from an older thread:

    pacman -Rncc lightdm-webkit2-greeter
    pacman -Syy lightdm-webkit-theme-antergos
    systemctl restart lightdm

    maybe this is the reason why lightdm wont work here?

    Sorry, i am a beginner on Linux, especially antergos.

    btw: still no luck with

    sudo pacman -Syu
    
  • @Noel said in After Update Feb. 6, 2019 Get Message Cannot Load LightDM - No Boot!:

    @lhb1142
    In the Arch Wiki there is a long article about LightDM, how to configure and install it.

    I read this article. How long? About as long as WAR AND PEACE! (Just kidding.) But do you know what I say to all that? NUTS! Is it really worth it to go through all of that (and risk “bricking” your computer) just to have a fancy greeter?

    Not for me. As I’ve stated, I’m staying with gdm and I hope that it doesn’t break.

    Thanks for writing though. I do appreciate that link.

    Lawrence

  • @Noel said in After Update Feb. 6, 2019 Get Message Cannot Load LightDM - No Boot!:

    @dimka
    Downgrading to lightdm-1:1.28.0-1 only works if it is in the cache, otherwise you have to download it manually. To install the new version lightdm-1:1.28.0-3 you have to update the system with

    sudo pacman -Syu
    

    This downloads all updates and installs them.

    I wonder if this would have worked at the point where my computer(s) froze with the message that lightdm would not load.

    But of course I would have had to know that there was a quick update fixing the defective lightdm version, something I would not have known as my computer would not boot.

    I’m glad lightdm was fixed. It was certainly fixed quickly which says something about the maintainers of Antergos!

    Nonetheless, I’m sticking with gdm at least for the moment.

    Thanks for writing - and thanks to ALL for writing. I’ll be interested in reading further comments on this subject.

    Lawremce

  • Okay. I solved the problem here.

    My mistake was, that i followed the steps from an older thread. The recommended command

    pacman -Rncc lightdm-webkit2-greeter

    removed the webkit2-greeter. So i reinstalled it with:

    sudo pacman -S lightdm-webkit2-greeter

    In my opinion

    sudo pacman -Syu

    would have had solve the problem.

  • Aside from design gdm uses more system rescources than lightdm…
    You can have both installed, only the one you have enabled via systemd will load automatic.

    Read here for some userfriendly howto:
    https://antergos.com/wiki/de/desktops/installing-display-managers/

  • there is also a package to easily downgrade, also if before versions are not in cache:
    sudo pacman -S downgrade
    downgrade "packagename"

boot321 lightdm137 20193 feb2 Posts 21Views 415
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.