• Failed to start Light Display Manager


    After applying latest updates today, after reboot:

    Failed to start Light Display Manager

    Computer is lenovo R500 (7-8 years old?)
    linux is 4.20.6

    systemctl status lightdm.service
    doesn’t reveal much other than an error has occured

    First time there’s been a problem in this area so would like any pointers to finding out how to fix or resolve.

    Can get into alt-f2 and log in.


  • have captured “systemctl status lightdm.service”

  • I have exactly the same problem after installing lightdm. Exactly the same message from “systemctl status lightdm.service”.

  • I had the same problem, the update of lightdm (1:1.28.0-1 -> 1:1.28.0-2) does not work. The problem can be solved by downgrading lightdm from the cache with

    sudo pacman -U /var/cache/pacman/pkg/lightdm-1:1.28.0-1-x86_64.pkg.tar.xz

    Good luck

  • I installed GDM instead as a workaround

    Fixed it for me :)

  • Same issue here (running XFCE instead of GNOME).

    Could you detail how you switched to GDM?

  • @Noel Many thanks, that fixed the issue for me!

  • @Noel Or, with a fresh install and no version in cache, the downgrade can be done from the archive:

    sudo pacman -U https://archive.archlinux.org/packages/l/lightdm/lightdm-1:1.28.0-1-x86_64.pkg.tar.xz
  • for an Xfce install a work around is switch to gtk-greeter or lxdm display manager :)

  • @Noel Thank you that worked here too.

    If you could explain how you worked that out, it would be really appreciated.

    Presumably if updates are requested there will be another attempt to upgrade, which must be resisted… until we know that the problem is fixed.

  • @Noel said in Failed to start Light Display Manager:

    the update of lightdm (1:1.28.0-1 -> 1:1.28.0-2) does not work

    Haven’t you received the 1:1.28.0-3 update yet? It works well for me.

  • https://wiki.archlinux.org/index.php/LightDM

    is now updated with the information about the problem with the lightdm release:


  • @new2antrgs
    I can confirm that by installing the latest driver (1:1.28.0-3) lightdm now works.

  • @boogy
    After the login screen didn’t work anymore, it was clear that the error occurred with the last lightdm update.
    All operations are stored in the file


    It also said that lightdm was upgraded.

    [ALPM] upgraded lightdm (1:1.28.0-1 -> 1:1.28.0-2)

    Now only the name of the previous version had to be determined for the downgrade.

    sudo ls -1h /var/cache/pacman/pkg/lightdm*

    You take the right version and downgrade it with:

    sudo pacman -U /var/cache/pacman/pkg/[package]
  • @Noel Thanks for that.

    The pacman log is very useful.
    I also used:

    ls -l /var/cache/pacman/pkg/lightdm*

    inspired by your command to revert the lightdm version, and that showed Feb 6 for the version…2.

    I don’t know if there is any overall way to be able to revert the whole system (excluding user data) to a known good point that is commonly or easily used, because of the unintended consequences conundrum, so your pointers are very important, and are noted!

    Found the use of this sort of command very useful:

    systemctl status lightdm.service | curl -F [email protected] https://ptpb.pw/?u=1

    and wondered if they are well used or if there are alternatives.

    Also, when grappling with how to get more info, tried

    lightdm -d

    command and saw some text then a black screen, and wanted to know if there is a way to see that text. It probably wasn’t helpful anyway, but still…

    Thanks again.

manager80 display59 light20 Posts 15Views 376
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.