• Can't install from DVD with NVIDIA GTX650Ti

    Hi guys, I’m new here :) registered today, I’m a Windows power user, with 6 months of experience in Ubuntu, and i decided to switch to a Arch based distro, first one i tried was Manjaro (didn’t even heard of Antergos yet back then), so the thing is, I have tried Manjaro, and it has given me hell for the first few days to get a few simple things setup, probably because of my lack of knowledge, but that doesn’t matter, what matters is, trough all the research i did for getting my Manjaro KDE to work the way i want it, i have stumbled across Antergos and realized it’s basically Arch linux pre-configured, and i thought, okaay, this is what i want … so i go to the website, download the latest ISO, Burn it on a DVD (and i note, I currently don’t have a USB stick, my old one died), load the DVD up, reboot, and i end up in that selection menu which offers me several options for booting to the live system, i go to the cd/dvd option and Antergos gets stuck on the logo screen … then i start research and realize that Antergos has issues booting with latest NVIDIA drivers. … but then again, i don’t have the latest, it’s like 6-7-8 years old, maybe more … i have NVIDIA GTX650Ti, i have tried other options in it the live bootloader like the one that has NVIDIA in the title, but i end up having a error screen stating that some file is missing from the CD, my system runs on EFI/GPT … i will edit this post in the morning once i get some sleep as its 4 am, and when i can actually remember the error :D but hoping maybe when i wake up, someone has had similar or same issue, and knows how to solve it :)

    I do not prefer the minimal install, as i don’t have enough experience to know which Apps i want to use, especially in KDE as i want to learn KDE

    side note: the “nvidia iso” version in the “community” editions links are broken

  • @kronikpillow nvidia iso is not maintained anymore, no need for it…

    To me it looks like not properly burned dvd, or an issue with your efi-bios…

    You can try boot with the usb option from dvd boot menu, some users needed to do so on some efi systems.

  • @kronikpillow This post does not directly address the problem you have but…
    I use KDE on my desktop box with a [GeForce GT 630] (rev a1) and Antergos installed and works well.

    IIRC the installation uses the nouveau drivers by default, which works reasonably well.

    If you want to install nvidia drivers use the nvidia-installer provided by Antergos.
    @joekamprad wrote the very useful wiki entry https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/

    For the record on my system I have the following installed

    $ pacman -Qs nvidia
    local/lib32-libvdpau 1.1.1-3
        Nvidia VDPAU library
    local/lib32-nvidia-390xx-utils 390.87-2
        NVIDIA drivers utilities (32-bit), 390xx legacy branch
    local/libvdpau 1.1.1+3+ga21bf7a-1
        Nvidia VDPAU library
    local/libxnvctrl-390xx 390.87-1
        NVIDIA NV-CONTROL X extension, 390xx legacy branch
    local/nvidia-390xx-dkms 390.87-31
        NVIDIA driver sources for linux, 390xx legacy branch
    local/nvidia-390xx-utils 390.87-1
        NVIDIA drivers utilities
    local/nvidia-installer 1.17-2
        Script to setup nvidia drivers in Antergos

    The -dkms stands for Dymanic Kernel Mode Support, which IMHO makes the installation work better when nvidia packages and kernel are updated in the future.
    IIRC the nvidia-installer installs -390xx and not the -dkms version.

    Another KDE related tip is to use SDDM instead of LightDM.
    Good luck.

  • ok, here’s an update after a few hours of sleep, when i try any option except the standard cd/dvd boot it says

    Error loading \EFI\archiso\vmlinux
    Failed to execute Antergos Live media (\EFI\archiso\vmlinux)

    then a dialog pops out saying the same thing, and boom, it restarts :-/

    I tried to boot all options, says the same thing on all options except cd/dvd but on cd/dvd it boots, but gets stuck on the loading screen … the DVD is properly burned using K3b @ 4x speed … and i have checked the md5sum and it matches perfectly with: 1d176dc7a29337e5fae99e7ae399995b

    @BlaiseD i would love to do that, and I’m familiar with the Arch command line because i used Manjaro up untill now, but … i can not even get to a console as i get the above mentioned error when trying to boot

  • Minimal ISO is only a minimal live environment it will install exactly the same Antergos System as the big ISO

  • the latest ISO works :) successfully switched to Antergos :)

nvidia166 dvd7 gtx650ti1 Posts 7Views 104
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.